Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: Pentax K-5 capture failed

Pentax K-5 capture failed 5 months 2 days ago #25166

You forgot to attach.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Pentax K-5 capture failed 5 months 2 days ago #25185

knro wrote: Debug logs are required when reporting issues. These things are quite complex as you can imagine, I cannot make an assessment (usually) alone from the description of the problem. I don't know why sometimes it returns the _last_ image. If anything in the logs looks funny when this happen, then this would be a place to start investigating. I'll see if there is a way to clear _everything_ whenever a capture is taken as well.


First of all, thanks Jasem. After upgraded to new version of kstars, I am now using the Pentax DSLR option but not the Gphoto CCD option. So, my question is do I need to switch back to gphoto CCD just to test out your small modification?

Regards,
Tom

Please Log in or Create an account to join the conversation.

Pentax K-5 capture failed 5 months 2 days ago #25194

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
Sorry Jasem, here it is.
After some reflection, during the execution of a sequence, the frame is shown in the viewer leaving the option to save or not, but the dialogue does not wait until you reply. As a consequence, frames are not saved at all. Is this normal? I have not understood why watching a frame in the viewer is not an option. When you do not take the option, frames are just saved in a predefined directory.
Attachments:

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Pentax K-5 capture failed 5 months 2 days ago #25208

tmheroes wrote:

knro wrote: Debug logs are required when reporting issues. These things are quite complex as you can imagine, I cannot make an assessment (usually) alone from the description of the problem. I don't know why sometimes it returns the _last_ image. If anything in the logs looks funny when this happen, then this would be a place to start investigating. I'll see if there is a way to clear _everything_ whenever a capture is taken as well.


First of all, thanks Jasem. After upgraded to new version of kstars, I am now using the Pentax DSLR option but not the Gphoto CCD option. So, my question is do I need to switch back to gphoto CCD just to test out your small modification?

Regards,
Tom


Pentax DLSR option??? what's that?

Please Log in or Create an account to join the conversation.

Pentax K-5 capture failed 5 months 2 days ago #25209

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
Good question. Does that mean that today beside Canon and Nikon DSLR drivers we have now also a Pentax DSLR driver?

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Pentax K-5 capture failed 5 months 2 days ago #25211

gbeaton wrote:

tmheroes wrote:

knro wrote: Debug logs are required when reporting issues. These things are quite complex as you can imagine, I cannot make an assessment (usually) alone from the description of the problem. I don't know why sometimes it returns the _last_ image. If anything in the logs looks funny when this happen, then this would be a place to start investigating. I'll see if there is a way to clear _everything_ whenever a capture is taken as well.


First of all, thanks Jasem. After upgraded to new version of kstars, I am now using the Pentax DSLR option but not the Gphoto CCD option. So, my question is do I need to switch back to gphoto CCD just to test out your small modification?

Regards,
Tom


Pentax DLSR option??? what's that?


In the latest 2.9.4, Pentax DSLR option already in the list. :) Now Jasem is fixing the ghost image issue but only available in nightly build which I am using it now.

Please Log in or Create an account to join the conversation.

Last Edit: by TomAstro.

Pentax K-5 capture failed 5 months 2 days ago #25212

Yeah! Pentax has finally made the list!

That’s super cool because I just opted to modify my K-5II for full-spectrum rather than buy a CCD. Nice!

Please Log in or Create an account to join the conversation.

Last Edit: by gbeaton.

Pentax K-5 capture failed 5 months 2 days ago #25213

gbeaton wrote: Yeah! Pentax has finally made the list!

That’s super cool because I just opted to modify my K-5II for full-spectrum rather than buy a CCD. Nice!


Yeah. You won't regret it.

Please Log in or Create an account to join the conversation.

Pentax K-5 capture failed 5 months 1 day ago #25218

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
I just tested the Pentax DSLR driver.
For the logging I selected Ekos Capture and FITS and the CCD-driver (See log attached).

I created one sequence of 2 shots with exposure 2s/2s delay and started with ISO 3200. Next I deleted the sequence and just changed the ISO back to ISO 100.

The viewer shows the frame at ISO 3200 and does not change the ISO while the sequence has ISO 100. I am pushing the start sequence button rather than the Preview button. The result is that the viewer pops up and allows me to invert colors, save or close. The behaviour is totally under control if selecting the FITS format. Frames get saved properly. Also the communication of new parameters for a new sequence seems to work well with the FITS format. Issues reported before were probably due to the native format viewer.
Attachments:

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Pentax K-5 capture failed 5 months 1 day ago #25228

The log shows only ISO 100 as being selected, there is no ISO 3200 there at all. I'll check this with Canon later today.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Pentax K-5 capture failed 5 months 1 day ago #25234

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
If you want I will check again this evening. I was first running tests with one line of 2 exposures in the sequence list. I deleted the line and put a new one with another ISO value and the ISO did not change on the DSLR. Another test was running two identical lines with only the ISO value that was different. I do not remember whether I run the tests with the FITS format or the Native format. I have the impression that performance is better with FITS than with native. Do not put too much time in it now. I will come back this evening with verified tests and provide the logs.

Just one additional question. Which signal starts and stops logging? Is it the "Connect" signal?

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC
Last Edit: by noste99.

Pentax K-5 capture failed 5 months 18 hours ago #25240

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
Here follows the result of my verified test.
The gphoto2 version gives the following result:
This version of gphoto2 is using the following software versions and options:
gphoto2 2.5.9 gcc, popt(m), exif, no cdk, aa, jpeg, readline
libgphoto2 2.5.16.1 all camlibs, gcc, ltdl, EXIF
libgphoto2_port 0.12.0 iolibs: disk ptpip serial usb1 usbdiskdirect usbscsi, gcc, ltdl, USB, serial without locking

I used the Pentax DSLR driver
After reboot and launch of kstars I launched indi and connected the DSLR.
I created a first sequences 2 times a 2s exp, 0s delay with FITS format ISO 100 followed by a sequence with 2 frames with 2s exp and 0s delay again with fits format and ISO 800.

I started both sequences and it all went well except after the 3rd frame the ISO value went temporarelly 1600 before again returning to 800.

Find attached the log

File Attachment:

File Name: log_20-32-39.txt
File Size: 47 KB
Attachments:

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC
Time to create page: 0.298 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica