Robert created a new topic ' Hitechastro DC 2 focuser controller' in the forum. 2 days ago

Hi,

I was wondering whether anybody else owns a HitechAstro DC focuscontroller 2. Did anybody manage to make this controller work with the existing driver indi_hitecastrodc_focus?
Jasem has been looking into it but couldn't fix it.

Thanks,

Robert

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 1 week ago

Hi Jasem. Looks like I'm stuck with my 'cursed' Hitechasto focuscontroller. No one was seems to be interested in having a go into finding a solution.
Have you contacted David Grennan since? He said he would help any way he could.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 1 month ago

Two more logs attached.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 1 month ago

Jasem,
I have worked with the Hitechastrodc focuscontroller from Kstars 2.9.6 and on some occasions I did get a response. The strange thing is that on one occasion it would react and if I try again with a complete shutdown and restart of Kstars the focuscontroller indicates a step change in indi control panel but no movement of the actual focuser. The times it worked I managed to focus in and out, within ekos as well as the indi control panel. The fields for setting an absolute position are greyed out and not accessible. I have attached the logfiles as well as screenshots.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 2 months ago

Thanks Jasem. Appreciate all the work you’ve done. I will check on Github.
Kind regards.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 2 months ago

P.S. Just in order to be complete I have to mention that in earlier attemps with Kstars 2.9.5 I did get some movement in the focuser but it appeared to stop working after a few commands. I also attached the logfiles of that trial.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 2 months ago

Hi Jasem,

If it helps I have been assured by David Grennan in a recent mail that he would do anything to help you to get something up and running. He also appreciated your efforts.
Meanwhile I have been trying with the new Kstars 2.9.6 and have attached logfile. The odd thing is that although I get messages in INDI control panel saying that the focus controller is connected and moving in steps of e.g. 100 the focusser itself doesn't move at all.
When running under windows and the factory software with ASCOM driver it works fine.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 2 months ago

Thank you so much Jasem. Really appreciated.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 2 months ago

Hi Jasem,

I contacted David and explained. He sent me and you in Bcc the command protocol for the focus controller.
Hope that helps.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 2 months ago

Have you had any response from David regarding the communication protocol? Meanwhile I tried to use Kstars for Windows but don't seem to be able to install my gear locally. Only remote installation is possible. ("Local" is greyed out).
Do I have to install any drivers. The ascom drivers for my gear I have but do I need indilibrary drivers and how do I install those? Thx.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 3 months ago

Hi Jasem. Any progress regarding the Hitecastro DC focuser 2? Can't say I'm not patient right. ;-)

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 4 months ago

Yes, unfortunately that is a very unhappy choice of Hitecastro to provide only a cigarette adapter plug power supply.
I had to cut mine and adapt so I have both possibilities.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 4 months ago

Hi Jasem, Have you been able to do something about a driver for a Hitecastro DC focus controller 2 ?
Robert

Read More...

Robert replied to the topic 'New version of INDI Web Manager' in the forum. 6 months ago

That's ok. Sounds good. Looking forward and thanks for the work. ;-)

Greetz,

Robert

Read More...

Robert replied to the topic 'New version of INDI Web Manager' in the forum. 6 months ago

I understand that Jasem adapted the existing 'hitecastro-dc' driver so it would accept my hitecastro focuser controller. Am not sure. I haven't been sent an xml file. It would be helpful to have such a file and to know where to put it so I can work until the next version of kstars comes out.
This is what Jasem wrote "I added your PID to hitech focuser now, but you will need to compile INDI from source to be able to test that."
I believe from what I see on Github under indi issues that my focuser was added in the following file : 'libindi/drivers/focuser/hitecastrodcfocuser.cpp'
I suppose that is what should be 'compiled' into indi.

Read More...

Robert replied to the topic 'New version of INDI Web Manager' in the forum. 6 months ago

That is how I have been working so far. A remote Mac (OSX) is connected to my telescope. I have ekos/Kstars running on that remote computer and configured as shown on the screenshot below (capturefiles 1-2-3).
The Mac in my house is setup as seen in the screenshots (4 and 5) and connected via the internet to my remote Mac.
I think I had the principle of INDI Web manager completely misunderstood. I thought it was a way to get the drivers from a dedicated server somewhere online so that one would not have to use drivers on one's own computers. Silly me, of course. Reason why I wanted to use the Web Manager following that reasoning is to perhaps be able to access a driver for a focus controller I have (HitecAstroDC ver 2). The existing driver in INDI does not accept mine because of wrong Product ID. So Jasem was so kind as to adapt this driver so it would accept mine. Unfortunately I would need to compile INDI from source which is absolutely like "Chinese" to me. He is considering the need for a basic tutorial for OSX users how to compile for INDI. I guess that will take a while as the man has his hands full with all these questions. :-) I hope that explains my question a bit.

Read More...

Robert replied to the topic 'New version of INDI Web Manager' in the forum. 6 months ago

Hi,

I am looking for a tutorial on how to install/use the indi webmanager in ekos/kstars for OSX. Is there such a thing?
Thanks,

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 6 months ago

Okay, thanks I just did.

Greetz

Read More...

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!