×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

SOLVED: indi_asi_ccd fails to download image

  • Posts: 40
  • Thank you received: 3
SOLVED.

It seems that for one reason or another, the driver was changed from indi_asi_single_ccd to indi_asi_cdd.

Reverting to the the later solved the problem.

Sorry for the noise...



UPDATE:

I just noticed that a file named Image_2022-03-31T06-42-31.bin was saved in /home/stellarmate.

file Image_2022-03-31T06-42-31.bin
Image_2022-03-31T06-42-31.bin: FITS image data, 16-bit, two's complement binary integer

Another one in native format:

file Image_2022-03-31T06-45-35.bin
Image_2022-03-31T06-45-35.bin: Targa image data 16 x 16 x 16 +16 +16 " "

Am I the only one having this?

Hope this helps.


Hi,

On an fully update stellarmate system.

Yesterday, I did an upgrade and since then (it might be a coincidence because no package seem related to this issue, see list at the end of this post) when I try to capture a light frame from the capture tab with my asi 224mc, the duration counts down but no image is shown. This camera is on my guide scope and when I want to connect PHD2 and start calibration, I get:

Unknow image format: .bin

But, when I launch a live video, it works. So it seems that the actual driver is working. Logs when capturing a frame show:

[2022-03-28T15:04:17.735 CEST INFO ][ org.kde.kstars.ekos.capture] - "Capture 1,000 - secondes d'une image..."
[2022-03-28T15:04:17.835 CEST DEBG ][ org.kde.kstars.indi] - ZWO CCD ASI224MC : "[DEBUG] Frame ROI x:0 y:0 w:1304 h:976 "
[2022-03-28T15:04:17.841 CEST DEBG ][ org.kde.kstars.indi] - ZWO CCD ASI224MC : "[DEBUG] Setting frame buffer size to 2545408 bytes. "
[2022-03-28T15:04:17.842 CEST DEBG ][ org.kde.kstars.indi] - ZWO CCD ASI224MC : "[DEBUG] Pixel format 8 is supported by SER recorder. "
[2022-03-28T15:04:17.843 CEST DEBG ][ org.kde.kstars.indi] - ZWO CCD ASI224MC : "[DEBUG] Pixel format 8 is supported by RAW encoder. "
[2022-03-28T15:04:17.845 CEST DEBG ][ org.kde.kstars.indi] - ZWO CCD ASI224MC : "[DEBUG] Configuration successfully saved for CCD_CAPTURE_FORMAT. "
[2022-03-28T15:04:17.847 CEST DEBG ][ org.kde.kstars.indi] - ZWO CCD ASI224MC : "[DEBUG] StartExposure->setexp : 1.000s "
[2022-03-28T15:04:19.179 CEST DEBG ][ org.kde.kstars.indi] - ZWO CCD ASI224MC : "[DEBUG] Uploading file. Ext: bin, Size: 2545408, sendImage? Yes, saveImage? No "

Video stream log:

[2022-03-28T15:07:57.177 CEST INFO ][ org.kde.kstars.indi] - ZWO CCD ASI224MC : "[INFO] Starting the video stream with target exposure 0.100000 s (Max theoritical FPS 10) "


I tried different format (raw 16 bits, raw 8 bit, etc) an Native and FITS, no change.

I don't know if this is a side effect of the recent bias capture issue, but things are, without guiding, my setup is useless.

Best,
Steve

apt logs:

Start-Date: 2022-03-27 08:46:03
Commandline: apt upgrade
Requested-By: stellarmate (1000)
Upgrade: libcups2:armhf (2.2.10-6+deb10u4, 2.2.10-6+deb10u5), publicsuffix:armhf (20190415.1030-1, 20211109.1735-0+deb10u1), vim-common:armhf (2:8.1.0875-5, 2:8.1.0875-5+deb10u2), openssl:armhf (1.1.1d-0+deb10u8+rpt1, 1.1.1n-0+deb10u1), mariadb-common:armhf (1:10.3.31-0+deb10u1, 1:10.3.34-0+deb10u1), libicu63:armhf (63.1-6+deb10u2, 63.1-6+deb10u3), libgmp10:armhf (2:6.1.2+dfsg-4, 2:6.1.2+dfsg-4+deb10u1), cups-server-common:armhf (2.2.10-6+deb10u4, 2.2.10-6+deb10u5), cups-common:armhf (2.2.10-6+deb10u4, 2.2.10-6+deb10u5), libwavpack1:armhf (5.1.0-6, 5.1.0-6+deb10u1), rsyslog:armhf (8.1901.0-1, 8.1901.0-1+deb10u1), cups-ppdc:armhf (2.2.10-6+deb10u4, 2.2.10-6+deb10u5), libjbig2dec0:armhf (0.16-1, 0.16-1+deb10u1), vim-runtime:armhf (2:8.1.0875-5, 2:8.1.0875-5+deb10u2), vim:armhf (2:8.1.0875-5, 2:8.1.0875-5+deb10u2), libsdl1.2debian:armhf (1.2.15+dfsg2-4+rpt2, 1.2.15+dfsg2-6~deb10u1), xxd:armhf (2:8.1.0875-5, 2:8.1.0875-5+deb10u2), libxml2:armhf (2.9.4+dfsg1-7+deb10u2, 2.9.4+dfsg1-7+deb10u3), libmariadb3:armhf (1:10.3.31-0+deb10u1, 1:10.3.34-0+deb10u1), libflac8:armhf (1.3.2-3, 1.3.2-3+deb10u1), libpcap0.8:armhf (1.8.1-6, 1.8.1-6+deb10u1), vim-tiny:armhf (2:8.1.0875-5, 2:8.1.0875-5+deb10u2), cups-core-drivers:armhf (2.2.10-6+deb10u4, 2.2.10-6+deb10u5), cups-daemon:armhf (2.2.10-6+deb10u4, 2.2.10-6+deb10u5), libssl1.1:armhf (1.1.1d-0+deb10u8+rpt1, 1.1.1n-0+deb10u1), libcupsimage2:armhf (2.2.10-6+deb10u4, 2.2.10-6+deb10u5), cups:armhf (2.2.10-6+deb10u4, 2.2.10-6+deb10u5), cups-client:armhf (2.2.10-6+deb10u4, 2.2.10-6+deb10u5), cups-ipp-utils:armhf (2.2.10-6+deb10u4, 2.2.10-6+deb10u5), tzdata:armhf (2021a-0+deb10u3, 2021a-0+deb10u4)
End-Date: 2022-03-27 08:46:48
Mount: AZ-EQ6 GT
Scope: Skywatcher Esprit 100 super APO triplet
Guide: Tecnosky 60
Camera: Canon Ra
Camera guide: Zwo ASI 224MC
Stellarmate on RPI 4 8Gb
Last edit: 4 months 1 week ago by Steve.
4 months 2 weeks ago #81804

Please Log in or Create an account to join the conversation.

Time to create page: 0.287 seconds