×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Driver OnStep (LX200 like) for INDI

  • Posts: 304
  • Thank you received: 24
Here is where the problem is.

The time stamps tells the story ...

12:55:59.364911 indi:43846 -> onstep:9997 :rG#
12:55:59.584761 onstep:9997 -> indi:43846 0
12:55:59.584807 indi:43846 -> onstep:9997 :rI#
12:55:59.862703 indi:43846 -> onstep:9997 :rI#
12:55:59.864333 onstep:9997 -> indi:43846 0
12:56:04.866849 indi:43846 -> onstep:9997 :rM#
12:56:05.084834 onstep:9997 -> indi:43846 0
12:56:10.086962 indi:43846 -> onstep:9997 :rT#
12:56:10.518762 indi:43846 -> onstep:9997 :rT#
12:56:10.520447 onstep:9997 -> indi:43846 0
12:56:15.522832 indi:43846 -> onstep:9997 :rb#
12:56:15.888708 onstep:9997 -> indi:43846 0

It takes 5 seconds for most of the :rX commands, but not all of them.
1 year 3 weeks ago #77571

Please Log in or Create an account to join the conversation.

  • Posts: 304
  • Thank you received: 24
James,

Here is more info on the problem, while I am compiling your fix.

14:08:55.418538 indi:44530 -> onstep:9997 [AP] :GXE9#
14:08:55.458250 onstep:9997 -> indi:44530 [AP] 32#
14:08:55.458419 indi:44530 -> onstep:9997 [AP] :GXEA#
14:08:55.478244 onstep:9997 -> indi:44530 [AP] 32#
14:08:55.478390 indi:44530 -> onstep:9997 [AP] :rG#
14:08:55.698145 onstep:9997 -> indi:44530 [AP] 0
14:09:00.702843 indi:44530 -> onstep:9997 [AP] :rI#
14:09:01.078293 onstep:9997 -> indi:44530 [AP] 0
14:09:06.082921 indi:44530 -> onstep:9997 [AP] :rM#
14:09:06.498370 onstep:9997 -> indi:44530 [AP] 0
14:09:11.502891 indi:44530 -> onstep:9997 [AP] :rT#
14:09:11.937849 onstep:9997 -> indi:44530 [AP] 0
14:09:16.942820 indi:44530 -> onstep:9997 [AP] :rb#
14:09:17.258004 onstep:9997 -> indi:44530 [AP] 0
14:09:22.262843 indi:44530 -> onstep:9997 [AP] :GX9A#
14:09:22.478265 onstep:9997 -> indi:44530 [AP] 10.0#

One possible issue is that the first rotator command (rG) returns immediately, so INDI thinks we do have a rotator:

2021-11-14T19:05:39: [INFO] Rotator found.

But then all the following :rX commands take 5 seconds.

Will let you know when I test your branch.
1 year 3 weeks ago #77575

Please Log in or Create an account to join the conversation.

  • Posts: 332
  • Thank you received: 42
Yes,
really strange
the 5 sec time is not between command issue and response but between response and the next command
1 year 3 weeks ago #77576

Please Log in or Create an account to join the conversation.

  • Posts: 332
  • Thank you received: 42
and more strange is I see only :rG# once and then no subsequent :r commands
1 year 3 weeks ago #77577

Please Log in or Create an account to join the conversation.

  • Posts: 304
  • Thank you received: 24
Perhaps you don't see them because the detection works properly, and finds that there is no rotator. In my case, with what is in Jasem's PPA, I think what is happening is that detection thinks there is a rotator, then all its commands are issued, and it times out.

I build James's branch that he linked to. INDI LX200 OnStep does not connect over WiFi at all. I changed 0.1 second to 0.4 seconds to give it time, but it still does not connect at all. Also 0.8 seconds does not work.

Downloaded James' fork, with branch master, and it does not connect either.

So there is a discrepancy between what James has and what in Jasem's PPA packages that prevents INDI from working over WiFi completely.
1 year 3 weeks ago #77578

Please Log in or Create an account to join the conversation.

  • Posts: 332
  • Thank you received: 42
 

File Attachment:

File Name: telescope.tar.gz
File Size:36 KB
Khalid,yes it is exactly what I suspect strongly. (I lose my Latin :-)We have for sure different OnStep Versions, I don't see another explanation.I added my source ( github.com/indilib/indi ) so you can make a diff 
Last edit: 1 year 3 weeks ago by Alain Zwingelstein.
1 year 3 weeks ago #77579
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 304
  • Thank you received: 24
The versions I tested were:

- Latest from Jasem's PPA -> botched device detection leading to lots of timeouts.

- James Lancaster's branch linked above -> INDI does not connect over WiFi at all.

- With James' branch, but replacing the two files with yours, I can connect, but there are still the same issues that I see with Jasem's PPA:

Wrong values return because of timeouts.

2021-11-14T20:10:17: [INFO] Rotator found.
2021-11-14T20:10:17: [INFO] Focuser 2 found
2021-11-14T20:10:17: [INFO] Focuser 1 found
2021-11-14T20:10:17: [INFO] OnStep/OnStepX version could not be detected
2021-11-14T20:10:17: [WARNING] Could not process mount date and time: 2038-15-10T05:00:00
2021-11-14T20:10:17: [INFO] Mount has Latitude 00:00:0.0 (0) Longitude -43:22:0.0 (-43.3667) (Longitude sign in carthography format)
2021-11-14T20:10:16: [ERROR] Failed to get tracking frequency from device.
2021-11-14T20:10:16: [INFO] Telescope detected having Pier Side, adding that capability (many messages duplicated)
2021-11-14T20:10:16: [ERROR] Error setting site longitude coordinates
2021-11-14T20:10:16: [ERROR] Error setting UTC Offset.
2021-11-14T20:10:16: [INFO] Device configuration applied.
2021-11-14T20:10:16: [INFO] Pulse guiding is enabled.
2021-11-14T20:10:16: [INFO] Setting Max Slew Rate to 5 (8x)
2021-11-14T20:10:16: [ERROR] Error setting site latitude coordinates
2021-11-14T20:10:16: [INFO] Loading device configuration...
2021-11-14T20:10:16: [INFO] Initialization Complete
2021-11-14T20:10:16: [INFO] Mount is unparked.
2021-11-14T20:10:16: [INFO] No Rotator found.
2021-11-14T20:10:16: [ERROR] Unable to parse response.
2021-11-14T20:10:16: [INFO] No Focusers found
2021-11-14T20:10:16: [INFO] Function call failed, stopping Focuser probe, return: -4
2021-11-14T20:10:16: [INFO] Focuser 2 NOT found (Checking for OnStepX Focusers)
2021-11-14T20:10:16: [INFO] Focuser 1 NOT found
1 year 3 weeks ago #77581

Please Log in or Create an account to join the conversation.

  • Posts: 332
  • Thank you received: 42
Now I get completely crazy :-)
Here is what I have

2021-11-14T20:25:11: [INFO] Initialization Complete
2021-11-14T20:25:11: [INFO] Mount is unparked.
2021-11-14T20:25:10: [INFO] No Rotator found.
2021-11-14T20:25:10: [INFO] No Focusers found
2021-11-14T20:25:10: [INFO] Function call failed, stopping Focuser probe, return: -4
2021-11-14T20:25:10: [INFO] Focuser 2 NOT found (Checking for OnStepX Focusers)
2021-11-14T20:25:10: [INFO] Focuser 1 NOT found
2021-11-14T20:25:10: [INFO] =============== Parkdata loaded
2021-11-14T20:25:10: [INFO] Mount is unparked.
2021-11-14T20:25:10: [INFO] OnStepX detected, setting some defaults
2021-11-14T20:25:10: [INFO] Mount has Latitude 48:13:29.0 (48.2247) Longitude 07:38:51.0 (7.6475) (Longitude sign in carthography format)
2021-11-14T20:25:10: [INFO] Telescope detected having Pier Side, adding that capability (many messages duplicated)
2021-11-14T20:25:10: [INFO] Observer location updated: Latitude 48:13:29.0 (48.22) Longitude 7:38:51.0 (7.65)
2021-11-14T20:25:10: [INFO] Site location updated to Lat 48:13:29.00 - Long 7:38:51.00
2021-11-14T20:25:10: [INFO] Time updated, updating planetary data...
2021-11-14T20:25:10: [INFO] Initialization Complete
2021-11-14T20:25:10: [INFO] Mount is unparked.
2021-11-14T20:25:09: [INFO] No Rotator found.
2021-11-14T20:25:09: [INFO] No Focusers found
2021-11-14T20:25:09: [INFO] Function call failed, stopping Focuser probe, return: -4
2021-11-14T20:25:09: [INFO] Focuser 2 NOT found (Checking for OnStepX Focusers)
2021-11-14T20:25:09: [INFO] Focuser 1 NOT found
2021-11-14T20:25:09: [INFO] =============== Parkdata loaded
2021-11-14T20:25:09: [INFO] Mount is unparked.
2021-11-14T20:25:09: [INFO] OnStepX detected, setting some defaults
2021-11-14T20:25:09: [INFO] Mount has Latitude 48:13:0.0 (48.2167) Longitude 07:38:0.0 (7.63333) (Longitude sign in carthography format)
2021-11-14T20:25:09: [INFO] LX200 OnStep is online.
2021-11-14T20:25:09: [INFO] Connecting to 192.168.0.12@9998 ...
1 year 3 weeks ago #77582

Please Log in or Create an account to join the conversation.

  • Posts: 304
  • Thank you received: 24
That makes me crazy too.
It is completely different in my case.

Here is something crazier

See this image i.imgur.com/vC2TX60.png

This is as I start INDI, and the mount is actually at home, and not slewing nor tracking at all.
1 year 3 weeks ago #77583

Please Log in or Create an account to join the conversation.

  • Posts: 155
  • Thank you received: 37
Currently my branches are

As I just looked the PR JUST got merged, so
ppa = old indi master
my master == indi-master (was also 2021-fix-focuser-not-hidden)
network-timeouts == master + network/detection fixes

The network timeouts also includes the not succeeding on failure that seems to be your problem Khalid. It should have the line either: Non-Network based connection, detection timeouts set to 0.1 seconds or Network based connection, detection timeouts set to 2 seconds If neither shows, it's not the right branch.

That should override if you are on the right branch. I am away from my telescope at the moment to test, but I'll see about it when I can. If you see the ONSTEP_TIMEOUT_SECONDS & MICROSECONDS at the top of lx200_Onstep.cpp, it's the wrong branch.

(Apologies if I'm being confusing or am confused myself, I got little sleep last night and unfortunately it's not due to using telescopes.) I'd assumed it was through the SHC/ESP32 on that.
1 year 3 weeks ago #77585

Please Log in or Create an account to join the conversation.

  • Posts: 155
  • Thank you received: 37
For this what version were you on? X?

Aha, Yep. :rG# gets defined even if no focuser(aka no timeout) :rA# = 0 is no rotator, and :rA# = 1 rotator,

Psudocode logic for later:
if OSVersion == $ONSTEPX
if getSingleCharResponse :rA == 1
rotator1 = true
else
if (no timeout) :rG
rotator1 = true
1 year 3 weeks ago #77588

Please Log in or Create an account to join the conversation.

  • Posts: 332
  • Thank you received: 42
Yes I have OnStepX installed.
But With OnStep 4 I had also no issue
1 year 3 weeks ago #77589

Please Log in or Create an account to join the conversation.

Time to create page: 0.676 seconds