×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Driver OnStep (LX200 like) for INDI

  • Posts: 134
  • Thank you received: 20
I upgraded driver from the stable builds and it crashes as soon as client connects with this error:
Driver indi_lx200_OnStep: *** stack smashing detected ***: terminated
Has anyone seen this?
Last edit: 1 week 5 days ago by Alex Varakin.
1 week 5 days ago #75179

Please Log in or Create an account to join the conversation.

  • Posts: 32
  • Thank you received: 0
How do i roll back to a stable driver?  My current install on my rasberry pi indi server is not usable. Ekos does not stay connected.

I dont want to waste any clear skies if i can avoid it.

Some logs if that helps
[2021-09-07T21:50:04.180 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <911> "
[2021-09-07T21:50:04.237 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[DEBUG] Align: max_stars: 9 current star: 1, align_stars 1 "
[2021-09-07T21:50:04.248 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GX02#> "
[2021-09-07T21:50:04.285 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <0> "
[2021-09-07T21:50:04.285 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GX03#> "
[2021-09-07T21:50:04.332 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <0> "
[2021-09-07T21:50:04.348 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:FG#> "
[2021-09-07T21:50:04.566 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <50145> "
[2021-09-07T21:50:04.613 Eastern Daylight Time INFO ][     org.kde.kstars.ekos.focus] - "Focuser error, check INDI panel."
[2021-09-07T21:50:04.629 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[DEBUG] Current focuser: 50145, 50145.000000 "
[2021-09-07T21:50:04.629 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:FT#> "
[2021-09-07T21:50:04.707 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <S> "
[2021-09-07T21:50:04.754 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:FM#> "
[2021-09-07T21:50:04.769 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <100000> "
[2021-09-07T21:50:04.785 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:FI#> "
[2021-09-07T21:50:04.854 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <0> "
[2021-09-07T21:50:04.854 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[DEBUG] After update properties: FocusAbsPosN min: 0.000000 max: 100000.000000 "
[2021-09-07T21:50:05.857 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:10.862 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "Error reading RA/DEC. "
[2021-09-07T21:50:11.160 Eastern Daylight Time DEBG ][     org.kde.kstars.ekos.mount] - Mount status changed from  "Tracking"  to  "Error"
[2021-09-07T21:50:11.864 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:16.867 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "Error reading RA/DEC. "
[2021-09-07T21:50:17.862 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:22.181 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <00:43:57> "
[2021-09-07T21:50:22.228 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] VAL [0.7325] "
[2021-09-07T21:50:22.243 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GD#> "
[2021-09-07T21:50:27.179 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "Error reading RA/DEC. "
[2021-09-07T21:50:28.179 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:33.181 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "Error reading RA/DEC. "
[2021-09-07T21:50:34.190 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:39.195 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "Error reading RA/DEC. "
[2021-09-07T21:50:40.196 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:45.014 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <00:43:57> "

 
1 week 2 days ago #75267

Please Log in or Create an account to join the conversation.

  • Posts: 55
  • Thank you received: 1
I also had a lot of problems with the version that came with Indi 1.9.1.
I compiled the version of Azwing (github.com/azwing/indi), then just replaced indi_lx200generic in my existing installation (in /usr/bin/).
That works well.
I think it must be possible to also recompile version 1.9.0 and replace indi_lx200generic
6 days 37 minutes ago #75438

Please Log in or Create an account to join the conversation.

  • Posts: 32
  • Thank you received: 0
I gave this a shot and the driver does appear to be more stable. It recognizes if i have a focuser or not on my OnStep controller. That is new. The older drivers just loaded all parts and did not check the OnStep controller if they existed.

I still do not have good communication with the OnStep controller. My first problem i encounter is it says it cannot get site info and it cannot write UTC offset.2021-09-12T13:08:17: [ERROR] Error setting site longitude coordinates
2021-09-12T13:08:17: [ERROR] Error setting UTC Offset.

If i request a 3star align it says error.
2021-09-12T13:19:14: [INFO] Align Status response Error, response = >
2021-09-12T13:19:14: [INFO] Getting Max Star: response Error, response = >
2021-09-12T13:19:14: [INFO] Sending Command to Start Alignment
I am connecting to the web manager of OnStep and that website is running correctly.  It is only my local wifi network.

I also see that the driver has a blank page on OnStep status.
 
5 days 5 hours ago #75459
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 32
  • Thank you received: 0
My issue was i had port 9999 entered. This gave me a partial working interface.

The port really needs to be 9998. Can some text be placed on the driver page were people type this in to remind them that the default port is 9998.

Thanks!
4 days 19 hours ago #75483

Please Log in or Create an account to join the conversation.

Time to create page: 0.783 seconds