×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Driver OnStep (LX200 like) for INDI

  • Posts: 148
  • Thank you received: 35
Apologies for the long updates. Real life things I don't want to go into here.

There was a pull request which may help some cases regarding reporting status on V4

Right now testing my own-goto it's working well with git versions of Kstars.

I did discover an odd bug related to meridian flips on altaz: It would keep trying to do them, but in my branch I've removed the capability being reported by default and while it can trigger it only seems to once. Working on a patch to add detection to Kstars. Now the branch only reports if it's non altaz. Which seems to make it only do it once.

Right now I'm 2/6 through testing (working on 3/6) v3/4/5 EQ/Altaz before I make a pull request. Unfortunately power is out so the branch is not up to date right now. (Will probably see about X, but I don't think I have a near current pull) so far it and Kstars are working well, but Kstars still sometimes considers slew complete immediately. Fortunately it handles it ok now.  (Mind I've got updates at something like 25ms to try to reproduce that.) Earlier Kstars did not handle that well.

I would like to get this merged before 1.9.2, if possible given the fixes. Not sure when @knro plans to release that (I would imagine very soon.) So if people can test it asap when I post next, I would massively appreciate it. If not, that's fine. 

 
3 months 3 days ago #75088

Please Log in or Create an account to join the conversation.

The next INDI release is planned within a week, given no major issues.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 months 2 days ago #75092

Please Log in or Create an account to join the conversation.

  • Posts: 140
  • Thank you received: 21
I upgraded driver from the stable builds and it crashes as soon as client connects with this error:
Driver indi_lx200_OnStep: *** stack smashing detected ***: terminated
Has anyone seen this?
Last edit: 2 months 4 weeks ago by Alex Varakin.
2 months 4 weeks ago #75179

Please Log in or Create an account to join the conversation.

  • Posts: 44
  • Thank you received: 0
How do i roll back to a stable driver?  My current install on my rasberry pi indi server is not usable. Ekos does not stay connected.

I dont want to waste any clear skies if i can avoid it.

Some logs if that helps
[2021-09-07T21:50:04.180 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <911> "
[2021-09-07T21:50:04.237 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[DEBUG] Align: max_stars: 9 current star: 1, align_stars 1 "
[2021-09-07T21:50:04.248 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GX02#> "
[2021-09-07T21:50:04.285 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <0> "
[2021-09-07T21:50:04.285 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GX03#> "
[2021-09-07T21:50:04.332 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <0> "
[2021-09-07T21:50:04.348 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:FG#> "
[2021-09-07T21:50:04.566 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <50145> "
[2021-09-07T21:50:04.613 Eastern Daylight Time INFO ][     org.kde.kstars.ekos.focus] - "Focuser error, check INDI panel."
[2021-09-07T21:50:04.629 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[DEBUG] Current focuser: 50145, 50145.000000 "
[2021-09-07T21:50:04.629 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:FT#> "
[2021-09-07T21:50:04.707 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <S> "
[2021-09-07T21:50:04.754 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:FM#> "
[2021-09-07T21:50:04.769 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <100000> "
[2021-09-07T21:50:04.785 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:FI#> "
[2021-09-07T21:50:04.854 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <0> "
[2021-09-07T21:50:04.854 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[DEBUG] After update properties: FocusAbsPosN min: 0.000000 max: 100000.000000 "
[2021-09-07T21:50:05.857 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:10.862 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "Error reading RA/DEC. "
[2021-09-07T21:50:11.160 Eastern Daylight Time DEBG ][     org.kde.kstars.ekos.mount] - Mount status changed from  "Tracking"  to  "Error"
[2021-09-07T21:50:11.864 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:16.867 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "Error reading RA/DEC. "
[2021-09-07T21:50:17.862 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:22.181 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <00:43:57> "
[2021-09-07T21:50:22.228 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] VAL [0.7325] "
[2021-09-07T21:50:22.243 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GD#> "
[2021-09-07T21:50:27.179 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "Error reading RA/DEC. "
[2021-09-07T21:50:28.179 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:33.181 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "Error reading RA/DEC. "
[2021-09-07T21:50:34.190 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:39.195 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "Error reading RA/DEC. "
[2021-09-07T21:50:40.196 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] CMD <:GR#> "
[2021-09-07T21:50:45.014 Eastern Daylight Time DEBG ][           org.kde.kstars.indi] - LX200 OnStep : "[SCOPE] RES <00:43:57> "

 
2 months 3 weeks ago #75267

Please Log in or Create an account to join the conversation.

  • Posts: 55
  • Thank you received: 1
I also had a lot of problems with the version that came with Indi 1.9.1.
I compiled the version of Azwing (github.com/azwing/indi), then just replaced indi_lx200generic in my existing installation (in /usr/bin/).
That works well.
I think it must be possible to also recompile version 1.9.0 and replace indi_lx200generic
2 months 3 weeks ago #75438

Please Log in or Create an account to join the conversation.

  • Posts: 44
  • Thank you received: 0
I gave this a shot and the driver does appear to be more stable. It recognizes if i have a focuser or not on my OnStep controller. That is new. The older drivers just loaded all parts and did not check the OnStep controller if they existed.

I still do not have good communication with the OnStep controller. My first problem i encounter is it says it cannot get site info and it cannot write UTC offset.2021-09-12T13:08:17: [ERROR] Error setting site longitude coordinates
2021-09-12T13:08:17: [ERROR] Error setting UTC Offset.

If i request a 3star align it says error.
2021-09-12T13:19:14: [INFO] Align Status response Error, response = >
2021-09-12T13:19:14: [INFO] Getting Max Star: response Error, response = >
2021-09-12T13:19:14: [INFO] Sending Command to Start Alignment
I am connecting to the web manager of OnStep and that website is running correctly.  It is only my local wifi network.

I also see that the driver has a blank page on OnStep status.
 
2 months 3 weeks ago #75459
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 44
  • Thank you received: 0
My issue was i had port 9999 entered. This gave me a partial working interface.

The port really needs to be 9998. Can some text be placed on the driver page were people type this in to remind them that the default port is 9998.

Thanks!
2 months 3 weeks ago #75483

Please Log in or Create an account to join the conversation.

  • Posts: 283
  • Thank you received: 32
OnStep with <strong>OnStepX 10.03k</strong>

I am starting testing OnSteX and even if things seem to work so far there is an annoying thing with polling.
The polling interval stays at 16s whatever setting I use under "Options" "Polling Period".

The same driver does behave normally with <strong>OnStep 4.24j</strong> polling 1s or even 500ms if I want.

I would like to know if somebody else observed this or is working on that issue before I start changing the code.

here the log and in orange the long time after cmdDatehhmmsssecondsdelta stotal s  


Date           hh    mm  ss      seconds    delta s    total s        
[2021-10-01T    14    0    39,870    0        0,000     0,000   CMD    <:GR#> "
[2021-10-01T    14    0    39,887    1,887    1,887    1,887    RES    <19:29:46> "
[2021-10-01T    14    0    39,887    1,887    0,000    1,887    VAL    [19.4961] "
[2021-10-01T    14    0    39,887    1,887    0,000    1,887    CMD    <:GD#> "
[2021-10-01T    14    0    39,888    1,888    0,001    1,888    RES    <+90*00:00> "
[2021-10-01T    14    0    39,888    1,888    0,000    1,888    VAL    [90] "
[2021-10-01T    14    0    39,888    1,888    0,000    1,888    CMD    <:GU#> "
[2021-10-01T    14    0    39,891    1,891    0,003    1,891    RES    <nNpHEo150> "
[2021-10-01T    14    0    39,891    1,891    0,000    1,891    CMD    <:Gm#> "
[2021-10-01T    14    0    44,903    6,903    5,012    6,903    CMD    <:%BD#> "
[2021-10-01T    14    0    44,910    6,91     0,007    6,91    RES    <0> "
[2021-10-01T    14    0    44,911    6,911    0,001    6,911    CMD    <:%BR#> "
[2021-10-01T    14    0    44,920    6,92     0,009    6,92    RES    <0> "
[2021-10-01T    14    0    44,921    6,921    0,001    6,921    CMD    <:GX90#> "
[2021-10-01T    14    0    49,933    11,933   5,012    11,933    Guid    e Rate: 1.000000 "
[2021-10-01T    14    0    49,934    11,934   0,001    11,934    CMD    <:GX95#> "
[2021-10-01T    14    0    49,940    11,94    0,006    11,94    RES    <0> "
[2021-10-01T    14    0    49,941    11,941   0,001    11,941    CMD    <:GX96#> "
[2021-10-01T    14    0    54,946    16,946   5,005    16,946    CMD    <:GXE9#> "
[2021-10-01T    14    0    54,953    16,953   0,007    16,953    RES    <60> "
[2021-10-01T    14    0    54,954    16,954   0,001    16,954    CMD    <:GXEA#> "
[2021-10-01T    14    0    54,962    16,962   0,008    16,962    RES    <60> "
[2021-10-01T    14    0    54,962    16,962   0,000    16,962    CMD    <:GX9A#> "

 
Last edit: 2 months 3 days ago by Alain Zwingelstein.
2 months 3 days ago #76204

Please Log in or Create an account to join the conversation.

  • Posts: 295
  • Thank you received: 24
OnStepX is still really far away from being usable. Last time I tried it (a few months ago), it did not even compile. Howard made changes and it did compile, but did not work at all. Motors did not move.

That is on the S6, which is not the platform that Howard is using for development.

But as long as things are in flux, I would not bother with it.

Join the onstep-dev sub group and report what you find there. It is where Howard responds for OnStepX stuff.
2 months 3 days ago #76221

Please Log in or Create an account to join the conversation.

  • Posts: 148
  • Thank you received: 35
I can reproduce that, on the own-goto branch. I also have a faster-timeout-fixed, that have both been merged into my master, including swapping the :GX90# over to the new lower timeout commands:
github.com/james-lan/indi

I'll make a pull request indi main either later today, or next week.

One nice thing is that with this, the startup time seems limited mainly by Kstars/Ekos. As checking most (3,4, X) of them when kstars is up it's 3-7 sec after hitting start in Ekos to everything being good. When it's the first startup that's more like 10-20.

I'm on a current pull as of just a bit ago (10.03k), I don't see the :%BD# causing an issue. What version of OnStepX are you on? (Mind you this is all testing with a Mega not hooked up atm.)
2 months 3 days ago #76223

Please Log in or Create an account to join the conversation.

  • Posts: 283
  • Thank you received: 32
@ Khalid and James,

I am just playing around to test some things. If it can help to discover here and there some parts not working well I guess it could help.

In my logs the 5 sec time is more related to Gm#, :GX90# and :GX96# but the issue is for sure (but I may be wrong) related to the driver itself not to OnStep.
I will try to investigate around that.

Now one thing is sure, OnStepX is far from "production" state but looks very promising.
I experienced also a lot of thing and reported to Howard and he fixed vert quickly.
But here it is really Indi Driver related I believe.

 
2 months 3 days ago #76227

Please Log in or Create an account to join the conversation.

  • Posts: 295
  • Thank you received: 24
Because INDI is very chatty, sending lots of commands every poll interval, it may uncover things that would not be uncovered using another OnStep client.

I have no intelligent comment to add other than there are significant differences between 4.x and X.

For GX90, OnStepX does the following:
sprintF(reply, "%0.2f", rateSelectToRate(settings.pulseRateSelect));

While 4.x does:

dtostrf(guideRates[currentPulseGuideRate]/15.0,2,2,reply); boolReply=false; break;// pulse-guide rate

For GX96, OnStepX does the following:

case '6': reply[0] = "EWB"[preferredPierSide - 10]; reply[1] = 0; break; // preferred pier side

While 4.x does:

if (preferredPierSide == EAST) strcpy(reply,"E"); else
if (preferredPierSide == WEST) strcpy(reply,"W"); else strcpy(reply,"B");
2 months 3 days ago #76228

Please Log in or Create an account to join the conversation.

Time to create page: 1.669 seconds