×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii

9 months 2 weeks ago
phattire72
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #35249
This is a developer question:

I have a Pentax K-70 and an Olympus OM-D E-M5 Mark ii. Neither seem to work with Bulb mode correctly. They both take a short exposure, then the image is uploaded at the end of the programmed shutter time. I think both would work if there was a way to use the Live Time mode. So, if INDI could send a shutter command to initiate the shot, then another to end the exposure when in
Live Time mode it would allow the cameras that have bulb mode issues to work correctly.

Is there any way to add a Live Time option in the Gphoto camera interface for INDI?

There seems to be a number of cameras that have Bulb Mode issues and this could possibly solve the problem with these cameras.



Sent from my SM-N960U using Tapatalk

Derek Dailey

Equipment:
Olympus EPL-5
Pentax K-70
Celestron C6SE with 6.3 Focal Reducer
Celestron AVX mount
Celestron Nexstar SLT mount with homemade EQ wedge
ZWO ASI120MM Mono Guide Camera
Orion 50mm Mini Guide Scope

Software:
PHD2
Stellarmate OS
Deep Sky Stacker
Adobe Photoshop & LightRoom

Please Log in or Create an account to join the conversation.

9 months 2 weeks ago
phattire72
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #35297
I found out the Pentax K-70 Camera does not have a Live Time Mode, but it has a setting called Bulb Mode Type 2 which does the same thing under the Bulb mode menu setting. Either way if Ekos could have a setting added to enable a shutter release to start the exposure , then a second shutter release signal to end the exposure the bulb issues with Pentax and Olympus can be resolved. I hope this is the right forum for this question, Please let me know if it needs to be directed toward the GPhoto2 developers instead.

Thank you for all of your hard work getting all of these interfaces working!

Derek Dailey

Equipment:
Olympus EPL-5
Pentax K-70
Celestron C6SE with 6.3 Focal Reducer
Celestron AVX mount
Celestron Nexstar SLT mount with homemade EQ wedge
ZWO ASI120MM Mono Guide Camera
Orion 50mm Mini Guide Scope

Software:
PHD2
Stellarmate OS
Deep Sky Stacker
Adobe Photoshop & LightRoom

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago
berylius
Fresh Boarder
Fresh Boarder
Posts: 10
More
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #36209
Hi,

Happy to see somebody using an Olympus OMD with Ekos!
How have you managed to make it work, i'm trying but have no luck so far.
I use gphoto2 2.5.20, libgphoto2 2.5.22 and libgphoto2_port 0.12.0 on ubuntu mate 18.04. The OMD is running v4.0 firmware.
I put the camera in PC mode et try to run gphoto2 --summary (camera screen turns to liveview), but then it timeout after 1min with " ptp store not available "

Berylius

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago
berylius
Fresh Boarder
Fresh Boarder
Posts: 10
More
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #36216
Ok, now i have tested it directly with Ekos/Indi and it works! I don't why it doesn't with the gphoto2 version from the official github!

Speaking of your feature request for the a second type of bulb mode (live time or bulb 2), it would be very nice! Because as you said, the Bulb mode isn't usable.
The following user(s) said Thank You phattire72

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago
phattire72
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #36222
I am unable to properly control my Olympus camera for AP with INDI/Ekos. It does take a short exposure or I can use shutter mode and take up to 60 second exposures, but no ability to take bulb mode exposures.

Unfortunately I've not had any of the developers reply back regarding the feasibility of the bulb 2 mode. I also put a request in on the Gphoto2 forum, and I've gotten no response there yet either. It may help if more people show the need for the functionality, so I would encourage you to put in the same request as it may let them know it would be worthy to pursue. I'll try to find my other request and post it on here.

Thanks for your reply to this thread!

Sent from my SM-N960U using Tapatalk

Derek Dailey

Equipment:
Olympus EPL-5
Pentax K-70
Celestron C6SE with 6.3 Focal Reducer
Celestron AVX mount
Celestron Nexstar SLT mount with homemade EQ wedge
ZWO ASI120MM Mono Guide Camera
Orion 50mm Mini Guide Scope

Software:
PHD2
Stellarmate OS
Deep Sky Stacker
Adobe Photoshop & LightRoom

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2027
Karma: 19
More
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #36226
For Pentax, you can use PKTriggerCord along with INDI and KStars. We currently have a forum member working on getting that to work on Mac's as well. The member is talking about possibly working on a separate INDI Driver to work for Pentax due to the slow progress with changes to gphoto2.

I don't know about Olympus. I'm sorry.

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago
berylius
Fresh Boarder
Fresh Boarder
Posts: 10
More
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #36236
Hi,

The liveview mode or the bulb mode in two shutter releases I suppose could be managed by the indi driver. This could be done in the stop_bulb fonction ( github.com/indilib/indi/blob/741ab34041a...hoto_driver.cpp#L569 )
in case we selected the specific bulb mode it send a second shutter release.
I don't know how the driver works, this could be a could reason for me to dive into the code :p

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago
phattire72
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #36350

berylius wrote: Hi,

The liveview mode or the bulb mode in two shutter releases I suppose could be managed by the indi driver. This could be done in the stop_bulb fonction ( github.com/indilib/indi/blob/741ab34041a...hoto_driver.cpp#L569 )
in case we selected the specific bulb mode it send a second shutter release.
I don't know how the driver works, this could be a could reason for me to dive into the code :p


@KRNO do you know if it would be possible to do the 2 shutter release operation within INDI?

Derek Dailey

Equipment:
Olympus EPL-5
Pentax K-70
Celestron C6SE with 6.3 Focal Reducer
Celestron AVX mount
Celestron Nexstar SLT mount with homemade EQ wedge
ZWO ASI120MM Mono Guide Camera
Orion 50mm Mini Guide Scope

Software:
PHD2
Stellarmate OS
Deep Sky Stacker
Adobe Photoshop & LightRoom

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago
knro
Administrator
Administrator
Posts: 7391
Karma: 51
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #36373
What needs to be done exactly? I have no idea about this. The driver already support remote shutter release by a serial cable. Shouldn't this be added at the libgphoto2 level?

Can you edit the gphoto_driver.cpp to add the required changes and test them out?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You phattire72

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago
phattire72
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #36375
Hi Jasem,

I'm starting to lean towards the remote shutter option via serial port. I have had issues with the images downloading to the Pi in the desired resolution. Sometimes it works correctly and sometimes it doesn't.

Does the serial shutter work through Gphoto2, or is it a different interface? Can I make one, or do I need to get the Shoestring Astronomy version? I can't find where you would add the serial interface in Ekos. I have found the plans to make one and it looks pretty easy to make.

Sent from my SM-N960U using Tapatalk

Derek Dailey

Equipment:
Olympus EPL-5
Pentax K-70
Celestron C6SE with 6.3 Focal Reducer
Celestron AVX mount
Celestron Nexstar SLT mount with homemade EQ wedge
ZWO ASI120MM Mono Guide Camera
Orion 50mm Mini Guide Scope

Software:
PHD2
Stellarmate OS
Deep Sky Stacker
Adobe Photoshop & LightRoom

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago
berylius
Fresh Boarder
Fresh Boarder
Posts: 10
More
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #36418
Hi,

I don't know if it's to be done in Indi or libgphoto, maybe a little in both.
The bulb sequence seems to be done in Indi. (gphoto_start_exposure() and stop_bulb() functions)

But for libgphoto2, it seems that the bulb mode is working only for canon cameras. (I might be wrong)
Now for the function we are talking about (LiveTime or Bulb2) we need a function in libgphoto to only trigger the shutter, but the function "trigger-capture" is also not supported yet in libgphoto for pentax or olympus.
If we could add this in libgphoto and then manage a 2 shutter release in Indi that would be great. (First Trigger-capture then wait x sec and finally capture_image with download)

I'm just starting in this so i have a lot to process, I hope i can be of some help. ;)

Berylius

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago 8 months 3 weeks ago by berylius.
berylius
Fresh Boarder
Fresh Boarder
Posts: 10
More
Re:Bulb mode issues with my Pentax K-70 and Olympus OM-D E-M5 Mark ii #36467
I've analysed the usb trafic for the shutter fonction of the Olympus.

Here are my investigation for the camera in libgphoto2:

The variable for the camera trigger is:
/* Olympus OMD series commands */
#define PTP_OC_OLYMPUS_OMD_Capture			0x9481
In the function used for the image capture there is indeed
uint16_t
ptp_olympus_omd_capture (PTPParams* params)
{
/* these two trigger the capture ... one might be "shutter down", the other "shutter up"? */
PTP_CNT_INIT(ptp, PTP_OC_OLYMPUS_OMD_Capture, 0x3); // initiate capture
ret = ptp_transaction(params, &ptp, PTP_DP_NODATA, 0, NULL, NULL);

PTP_CNT_INIT(ptp, PTP_OC_OLYMPUS_OMD_Capture, 0x6); // initiate capture
ret = ptp_transaction(params, &ptp, PTP_DP_NODATA, 0, NULL, NULL);

}

In case of a normal capture the "ptp_olympus_omd_capture " function is correct but for the Bulb mode it's not because value 0x3 is shutter down
PTP_CNT_INIT(ptp, PTP_OC_OLYMPUS_OMD_Capture, 0x3)
and value 0x6 is shutter up
PTP_CNT_INIT(ptp, PTP_OC_OLYMPUS_OMD_Capture, 0x6)

so this initiate a short exposure.

We should made 2 differents function, so we could make the Bulb function operationnal.

I will try to make the changes in libgphoto2
The following user(s) said Thank You knro, phattire72

Please Log in or Create an account to join the conversation.

Time to create page: 0.670 seconds