×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Ekos + stellarium plate solve issue

  • Posts: 98
  • Thank you received: 5
Hi,

I've recently updated kstars/ekos/libindi to latest version (running on a rpi). I've noted a major difference while I'm using stellarium and connected to the indi server. When I slew to an object with stellarium and go to ekos and try to plate solve and sync, it solves, but also slews to the previous object I slewed in first instance (or parking, if none). With the previous version, it solved correctly and slewed to the current object, as expected.

Any ideas?

Miguel
5 months 4 days ago #84058

Please Log in or Create an account to join the conversation.

This is a known issue. Unless the GOTO is issued from Ekos, it doesn't know the last object slewed to. Wolfgang tried to submit a solution to this so that Ekos would be able to detect the GOTO from INDI state changes alone, but it was dropped after it was deemed difficult to implement correctly.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
5 months 3 days ago #84063

Please Log in or Create an account to join the conversation.

  • Posts: 98
  • Thank you received: 5
Thanks for the feedback Jasem. I hope you can modify it again. I don't remember the version I had before but it was working fine. I guess a lot of code has changed and recovering this behavior may not be trivial. Thanks for your effort.
I will pay attention to the next updates, but if you are aware of the fix and remember this thread, please post :)
5 months 3 days ago #84065

Please Log in or Create an account to join the conversation.

  • Posts: 98
  • Thank you received: 5
Jasem, has been this issue, by chance, solved in this last update?
4 months 6 days ago #84948

Please Log in or Create an account to join the conversation.

Unfortunately no. It's a complex issue and no one had time to fix it.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 months 5 days ago #84953

Please Log in or Create an account to join the conversation.

  • Posts: 98
  • Thank you received: 5
Jasem, just to my understanding. Why did this feature stop working? It worked in some previous version (I don't remember which one sorry). What has changed that makes so difficult to fix it? Just out of curiosity
4 months 5 days ago #84956

Please Log in or Create an account to join the conversation.

The following user(s) said Thank You: Miguel
4 months 5 days ago #84960

Please Log in or Create an account to join the conversation.

Time to create page: 0.908 seconds