×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

KStars icon missing in my LXDE environment.

  • Posts: 1029
  • Thank you received: 301
I was about to write an answer :) it's a bit difficult to tell precisely, but I think installing (or reinstalling) "libkf5iconthemes-dev" restored all icons on my lubuntu installs #2 and #3 that were missing them. The lubuntu install #1 had all kstars development dependencies already installed, and had expected icons. Probably this package has too much data, but it seems to pull enough requirements, such as the breeze theme, and KDE tools to link that with kstars.

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
4 years 6 months ago #26016

Please Log in or Create an account to join the conversation.

  • Posts: 1279
  • Thank you received: 222
Thanks for the tip. But it did not work for me.
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
4 years 6 months ago #26028

Please Log in or Create an account to join the conversation.

Well, one solution is to use Plasma desktop instead of LXDE :D
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 years 6 months ago #26031

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
Didn't work for me also.
I have installed Ubuntu Desktop 16.04 LTE and there it works but not in 18.04.
4 years 6 months ago #26036

Please Log in or Create an account to join the conversation.

  • Posts: 1942
  • Thank you received: 418
Same here. Abelink and I tried running different flavours and versions of Ubuntu in virtual machines and whatever we try, the KStars icon doesn't appear in the bottom panel (where all running applications appear) nor in the workspace switcher. When I run Firefox, it does show the Firefox icon in those two places. See the attached screenshot. It looks like something ay have changed with Ubuntu Bionic preventing the icon from showing up or needing the icon to be added to a directory where it isn't now.

However, when I compare the output of "dpkg -L firefox | grep icon" and "dpkg -L kstars-bleeding-data | grep icon" then the only differences I see are
- Firefox uses an SVG icon and KStars SVGZ
- Firefox places the icons in /usr/share/icons/hicolor/symbolic and KStars in /usr/share/icons/hicolor/scalable

Simply copying the kstars.svgz file to /usr/share/icons/hicolor/symbolic didn\'t solve the issue though...

EDIT: Sorry for hijacking this topic. Just to be clear, I am using Ubuntu Mate and the icon is missing in Bionic (18.04).

EDIT 2: The icons also are missing in Ubuntu Mate 17.10 which I have been using for some time but I never noticed this before...
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
Last edit: 4 years 6 months ago by Wouter van Reeven.
4 years 6 months ago #26040
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1029
  • Thank you received: 301
Apologies I realize I offered a solution for the wrong issue. The OP has a problem with the KStars icon, while I was referring to the problem with *all* icons missing *inside* the KStars application and replaced with text, as reported by @sywong2000.

During installation, I had one such issue with the KStars icon, but it was transitory: after building and installing, the icon remained a white square in the menu and in the Taskbar. I just had to restart X11 for it to appear properly. Probably related to the icon cache, but possibly unrelated to your issue, sorry.

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
4 years 6 months ago #26045

Please Log in or Create an account to join the conversation.

  • Posts: 1942
  • Thank you received: 418
<text deleted>

Forget what I wrote before. I am facing the same issue: there is a blank square in the task bar and workspace switcher where there should be a KStars icon.
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
Last edit: 4 years 6 months ago by Wouter van Reeven.
4 years 6 months ago #26046

Please Log in or Create an account to join the conversation.

  • Posts: 1279
  • Thank you received: 222
This issue has never been solved. But I may have found a reason why. Within the icon folder /usr/share/icons/hicolor/scalable/apps
Among the icons is a scalable version of the kstars icon. However it is in a Gzipped compressed format (.svgz), while every other icon is a standard .svg file. Could it be the compressed form is not supported on our systems?
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
3 years 8 months ago #35785

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
I can confirm that on a fresh Ubuntu 20.04, that icons do show up after you install the breeze-icon-theme package.

sudo apt install breeze-icon-theme
2 years 2 months ago #59724

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
I know it's an old subject, however, I was having the same issue and I found a solution. I'm making an article about KStars for my astronomy website ( Astrosigma ), so I tried to do some screenshots.

Using Debian 9 Stretch, the KStars version is 2.6.0. A lof of buttons are missing, even in the main toolbar. I tried to fix it changing some long texts for abbreviatures. However, it was ugly. I tried to install some libraries about KDE and LXDE. I have to say I'm not using KDE, I'm using i3wm (it uses part of LXDE).

Moreover, I wanted the text buttons in Spanish ('cause my article will be for Spanish readers), but with my KStars default version was not even possible to change the language for the GUI.

Solution: install it via snap. Use the command `sudo apt-get install snap` to install snap, then install the core snap with `sudo snap install core`, and finally install KStars with the command `sudo snap install kstars`. You can now execute the new version with the command `snap run kstars`. It's the version 3.5.7 Stable.

PS. The language switcher was not working. I had to change the Spanish language of my computer with the command `sudo dpkg-reconfigure locales`.

And now I have the 3.5.7 Stable version in Spanish, without having to do a disto upgrade. Snap and AppImages are a very interesting way to install software.
Last edit: 3 months 5 days ago by gbm.
3 months 5 days ago #85606

Please Log in or Create an account to join the conversation.

  • Posts: 1279
  • Thank you received: 222
Interesting workaround. But I'm afraid it won't apply to many of us. For instance I compile KStars on my local system because I can not use the repositories on Raspberry OS.
Still hoping for a solution some day. But it's just an icon, so it's not really a priority.
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
3 months 5 days ago #85615

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
Since Raspberry OS is Debian-based, why you can't use the repositories? It even uses APT. (I don't know Raspberry Pi OS enough).
Last edit: 3 months 5 days ago by gbm.
3 months 5 days ago #85617

Please Log in or Create an account to join the conversation.

Time to create page: 0.896 seconds