×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

ASTAP astrometry integration

1 month 4 weeks ago
avarakin
Senior Boarder
Senior Boarder
Posts: 73
More
ASTAP astrometry integration #46396
Just to report results of my testing - I used ASTAP couple of nights and so far no issues, except if I try to go to an image, taken from previous session which has long exposure of 1200s. Looks like ASTAP is finding too many stars and gets lost.
My work around is - if I plan to shoot same object multiple nights (which I normally do), I save a "go to" Lum image with bin 2 and 5s exposure and then use it for targeting during subsequent sessions.

Many thanks to Han and Jasem for integrating ASTAP! So far it seems more reliable and much faster at solving, as long as you dont ask it to do blind solving.

Alex

Please Log in or Create an account to join the conversation.

1 month 4 weeks ago
papaf76
Senior Boarder
Senior Boarder
Posts: 51
More
ASTAP astrometry integration #46403
From which kstars release is the problem of the guide scope focal length solved? I'd like to check before I go out. I'm using the stable ppa in Ubuntu.

Thanks!

Please Log in or Create an account to join the conversation.

1 month 4 weeks ago
tkottary
Expert Boarder
Expert Boarder
Posts: 125
More
ASTAP astrometry integration #46421
Thanks Han. Auto and tolerance did the trick! Plate solved in 1 sec .

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
han.k
Gold Boarder
Gold Boarder
Posts: 203
Karma: 6
More
ASTAP astrometry integration #46428
Good. Auto is only intended to find the image scale. It will just go trough all image scales. Once you know the image height, adapt focal length accordingly.

There was a problem with image scale of the guide scope focal length which was fixed two weeks ago. I don't know which version this is:

>> knro wrote:
>>I believe I found the issue. INDI::CCD was always using the primary focal length when calculating CDELT1,2. It's now fixed in GIT.
>>It's not set in the driver, it's calculated. So they need to use INDI Nightly or update from GIT. Since this is a major bug, I will also publish it to the stable channel.


Normally you don't have to worry about the values once they are set correctly. If you load an image in ASTAP, you can read the image dimensions in degrees in the viewer statusbar or in the alignment tab the image height as calculated from the header info. So below as indicated 1.32 degrees. You can overwrite this value (fro solving) by entering a manual value there. This is also handy if you try to solve a jpeg or raw file. This value is stored (save settings or by a solve) until new info is read from the header or command line overrides.

If you select in ASTAP temporary the external local Astrometry.net solver, there is a small calculator included intended for Astrometry.net commandline but could be used to check the values. In the example below, I typed a focal length of 580 mm and pixel size of 5 micrometer resulting in an pixel scale of 1.78" and image dimensions 1.15 x0.869 degrees. The correct pixel size should have been 7.8 micrometer and then the image height will match with the header value above of 1.32 degrees. The calculator values or only used for Astrometry.net command line not for the internal solver.

Han



The image scale should be correct within 5% for best performance but offsets of 30 or 40% could still produce a valid solution.
Attachments:

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
papaf76
Senior Boarder
Senior Boarder
Posts: 51
More
ASTAP astrometry integration #46480
Hi Han,
I'm trying by clicking on load and solve from ekos, but it always fails. I see that when I do this, the image vertical dimension is always 1 degree, even if my FOV is different. It seems all my settings, like focal lenght and CCD data, are not taken into account when using load and solve. Is this the expected behaviour?

Thanks!

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago 1 month 3 weeks ago by tkottary.
tkottary
Expert Boarder
Expert Boarder
Posts: 125
More
ASTAP astrometry integration #46487
Go to the mount tab (tripod icon) on ekos and make sure your focal length is correctly set up there. Try saving the config , move back to align tab switch between the camera's and confirm the FOV is correct in Ekos before you hit solve.

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
han.k
Gold Boarder
Gold Boarder
Posts: 203
Karma: 6
More
ASTAP astrometry integration #46494
If the suggestion of tkottary doesn't work, then you should install the latest nightly build INDI. What I understand is that there was a bug in the pixel scale reporting (keywords CDELT1, 2). Unfortunately there is no way to add an additional command line command in EKOS to override the FOV

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
han.k
Gold Boarder
Gold Boarder
Posts: 203
Karma: 6
More
ASTAP astrometry integration #46509
There is a simple way to override the FOV setting (my previous remark was incorrect) . You can just enter it in the command line as show below. Just add something like :

-fov 1.6

This will override and other FOV (focal length, sensor size) setting. So once you found out the image height in degrees just add this value in the command line. Note that -fov auto doesn't work. This only works in the viewer. If the solver is more then 2 degrees from the start position the popup notifier will show the FOV used.

Han

Attachments:

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
papaf76
Senior Boarder
Senior Boarder
Posts: 51
More
ASTAP astrometry integration #46510
Thanks Han, I'll try as soon as possible and report back.
If this works though, wouldn't it be possible to automate it when the image loaded doesn't have any info into its header?

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
papaf76
Senior Boarder
Senior Boarder
Posts: 51
More
ASTAP astrometry integration #46513
It doesn't work for me. It seems like any options specified in the field are not actually passed to the solver, which still shows 1 degree in its little window.
Mind, I'm using the "Load & Slew" button, unlike your screencap which shows you're using "Capture & Solve". I don't think Ekos/Kstars is doing the same things when using the two buttons.

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago 1 month 3 weeks ago by han.k.
han.k
Gold Boarder
Gold Boarder
Posts: 203
Karma: 6
More
ASTAP astrometry integration #46514
Something strange is happening. The -fov command works only for the Ekos "Capture & solve " button, not for the Ekos "Load & slew" button. That's why I initially reported it doesn't work. This requires further investigation.

The command line option "-fov auto" works for Windows but not for Linux. I have to investigate why that doesn't happen. Note that this option is not ideal. I created it to because I was fed up with finding the image scale for some images without any data. ASTAP goes through all image scales from 9.5 degrees height down to 0.5 degrees with a stepsize of 33% less height each time. Due to the step size this works only for images of reasonable good quality. The option was intended to analyse images from an unknown source, not as a permanent setting.

Han
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
han.k
Gold Boarder
Gold Boarder
Posts: 203
Karma: 6
More
ASTAP astrometry integration #46517
The "-fov auto" work also in Linux. I didn't see that because in my test virtual machine it was using an old ASTAP version. Note that "-fov auto" disappears as soon you go to an other screen. Then you have to type it again. In the popup window you will see the word "auto". If you see height is 0°, the ASTAP version is too old. It doesn't work for "load and slew" only "capture & solve". It's highly inefficient since it has to search maybe ten times before it finds a match. It helps if you reduce the search area to maybe 10 degrees

The fixed 1 degrees is related to an INDI problem. Maybe Jasem/ @knro can clarify from which INDI version this is fixed.

Han

Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 1.749 seconds