×

INDI Library v1.8.0 is Released (27 Jul 2019)

INDI Library v1.8.0 is mostly a maintenance release to fix a few bugs in several drivers.

Networking issues

  • Posts: 14
  • Thank you received: 0

Networking issues was created by rcpilotjohn

I have read everything I can find including the github notes on reconfiguring the network, and I cannot figure out how to get the wifi hotspot name or password changed from astroberry . Here is what happens. (I am using Raspberry Pi 3 and 3+ units.)

1) I am using the latest Astroberry system prebuild download as of 6 August 2019 on the github site. I did an apt-get update and upgrade, and then installed xrdp to add remote desktop access. So far, so good.
Now I want to change the wifi name and password. I tried the scripts listed in the FAQ, as well as looking for the /etc/wpa_supplicant/wpa_supplicant.conf file which did not exist.
2) Whenever I add anything to a file /etc/wpa_supplicant/wpa_supplicant.conf (by clicking on the wireless icon on the top screen panel), after a reboot the system locks out all remote access - remote desktop, browser, and ssh. I can only use a keyboard and mouse connected to the Pi. Deleting that file and rebooting again restores remote access.
3) I can run the control center as administrator, and select network connections and see a Wi-Fi connection set up on vap0 with my new name and password. This information is ignored by the Ubuntu system even after reboots. The wireless is still astroberry.
4) The system also locks out remote access if I set the wifi up as a client to try to connect to another wifi network (instead of the wired LAN port). When I do this,I can use the network as superuser from the Pi but not as the astroberry user and not for any remote connections in. For instance, I can do 'sudo apt-get' and do system updates, but as user astroberry I cannot ping another computer. 'Sudo ping' works however.
5) I keep resetting the country code to 'US' but it keeps reverting to 'PL'. I am not sure where I have to set it to make it stay.

Please help if you have solved these. I am getting frustrated.

I am keeping a log of the things I have to do to make this work, and I expect to post it here when I finally get this running in hopes it can make life easier for others going through this.

John
2 weeks 1 day ago #41791

Please Log in or Create an account to join the conversation.

Time to create page: 0.306 seconds