Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 2 years ago

Sorry for the late reply. No time to get my gear set up till now.
I tried both devices the DC focuser controller (see picture in Damien's post):
- works fine when connected to ekos., however even without a motor attached it keeps saying that it moved outward by x steps even though the motor doesn't react because not attached.
- the other model I have, the DC2 focuser controller and also the original problemmaker, seems to connect normally to ekos (green lights allover) but it does not pass anything to the motor when attached (at least the motor doesn't react). It also says " focusing outward/inward by x steps" even though the motor doesn't react.

Read More...

Thanks guys. Found it. Works fine now.
:-)

Read More...

Thx for the info but I do not have this problem on my Macbook with OSX 10.11.6 on which I installed Kstars 2.9.8 without any problems.
I have exactly the same security and privacy settings on my iMac running 10.13.6
I included a screencapture of my settings in my original post.
I just recently upgraded to High Sierra (OSX 10.13.6). I never had any problems installing Kstars with OSX 10.11.6
I am not sure where to find this "enable kstars to be opened anyway" option.
The only options I get are " Allow apps downloaded from:
-Mac App store
-Mac App store and identified developers
-Anywhere

Read More...

I get this message although I have allowed apps from anywhere to be downloaded.
Any ideas?

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 2 years ago

Hi Damien, thx for sharing your findings on the Hitecastro DC focusercontroller. I have the DC2 focuscontroller which does not work at all in Ekos but meanwhile bought the original edition of the DC controller which works fine except for absolute position choice which is greyed out in Ekos. So I can not ask the controller to go to a position of my choice. Autofocus is also erratic but that is probably due to the fact that I have a focuser without steppermotor. Justlike you I miss a minimm and maximum travel stop. I use the driver of Ekos 2.9.7.

Read More...

Robert created a new topic ' Hitechastro DC 2 focuser controller' in the forum. 3 years ago

Hi,

I was wondering whether anybody else owns a HitechAstro DC focuscontroller 2. Did anybody manage to make this controller work with the existing driver indi_hitecastrodc_focus?
Jasem has been looking into it but couldn't fix it.

Thanks,

Robert

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 3 years ago

Hi Jasem. Looks like I'm stuck with my 'cursed' Hitechasto focuscontroller. No one was seems to be interested in having a go into finding a solution.
Have you contacted David Grennan since? He said he would help any way he could.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 3 years ago

Two more logs attached.

Read More...

Robert replied to the topic 'Hitech Astro DC focuser problem' in the forum. 3 years ago

Jasem,
I have worked with the Hitechastrodc focuscontroller from Kstars 2.9.6 and on some occasions I did get a response. The strange thing is that on one occasion it would react and if I try again with a complete shutdown and restart of Kstars the focuscontroller indicates a step change in indi control panel but no movement of the actual focuser. The times it worked I managed to focus in and out, within ekos as well as the indi control panel. The fields for setting an absolute position are greyed out and not accessible. I have attached the logfiles as well as screenshots.

Read More...