Wonder if this would work for your white balance problem:
gphoto2 --list-all-config (to find the label/s regarding white balance.. and look for the option number you might want to set it to)
gphoto2 --set-config <the_name_of_the_white_balance_label>=<option_number>
eg. gphoto2 --set-config whitebalance=3
gphoto2 --list-all-config (to see if the change was saved)

Raised the following over at Gphoto github..

Hi Marcus,

Ive had a chance to test GPhoto2 with my Fuji X-T2 and unfortunately theres some weird things happening, but hopefully nothing that cant be fixed.

**Camera setup:**
My camera has a physical dial with 3 shooting modes: A (auto), B (bulb), T (timed), and also a way to shoot in either MS (mechanical shutter) or ES (electronic shutter), or MS&ES (both).

**Testing method:**
I tested image capture from the command line, and then if that worked, also in Ekos capture module and noted the results.

**Saving the image:**
In all cases though, the image was only stored on the Pi and that was only when capturing in Ekos (after i specified the output folder within Ekos).
If there is a way using the console command to save to a specific folder then that may have worked, however i wasnt aware of the syntax to do that.

**Data Indicator Lamp:**
The whole time the Fuji was plugged in the 'indicator lamp' on it flashed orange and green, as if data transfer was taking place, even long after images had been captured. It actually never stopped.
Even after I had turned power off to the camera (which didnt actually power off the camera) the indicator lamp went solid orange as if data transfer was even still taking place. Only when i removed the USB cable did the camera finally completely turn off.

**PC Connection Modes:**
I tested all 3 camera tether modes on the Fuji X-T2 under 'PC Connection Mode' menu:
- USB Card Reader: This causes the ERROR: 'Sorry your camera does not support generic capture' when running from command line. Ekos didnt work obviously.
- USB Tether Shooting AUTO: Saves only to the Pi, and thats when shot from within Ekos after specifying a save directory (as aforementioned). Running the 'gphoto2 --capture-image' command line in Pi terminal did say 'downloading' and when the progress bar for that reached 100%, it said 'image saved to card', however it actually hadnt as far as I could tell.
- USB Tether Shooting Fixed: Same as the above, however a warning message appears stating 'waiting for data transfer to complete, Press OK to cancel', which doesnt appear using the above PC Connection Mode.

(B)ulb mode ONLY works with the ES shutter and it only shoots 1s images (which is a Fuji limitation on the BULB/ES combo anyway). However if MS shutter or MS&ES shutter is selected, BULB mode stops working altogether and wont capture an image. (logfile attached below)
(A)utomatic mode works (MS, ES, both) but cannot control the shutter speed at all (as the camera controls that for what it considers to be an optimal exposure). This happens for all MS, ES, MS&ES shutters.
(T)imed mode works (MS, ES, both) in the following way:
- Pi Terminal command line: Takes the image and uses the shutter speed that was set on the camera prior to connecting it to the Pi. Image not saved to the camera or the Pi (unless its in a default directory unknown to me on the Pi).
- Ekos capture module: Requested exposure time entered was 120 seconds, and a 1.3s image was taken, however you do need to wait the following ~118 seconds before the image is saved to the Pi directory (directory specified in Ekos). Image is not saved to the camera. The orange and green lights flash continuously. I tested a number of different exposure times and noticed that 'requested' times vs 'actual' times (according to the metadata in Lightroom) are seen to be divisable by around 100, actually somewhere between 90-110. (eg. 60s requested = 0.6s actual, 180s = 2.0s actual, 900s = 8.0s actual, 10s = 0.1s actual).
I have attached the logfile for this also.

[BULB Mode Mechanical Shutter not working]( github.com/gphoto/gphoto2/files/4776138/...chanical.Shutter.txt )
I also created a logfile for BULB Mode with Electronic Shutter (that shot the 1s image successfully) but its 220MB in size. Let me know if you might want that for any comparison.
[KStars Timed mode out by a factor of 90 to 110]( github.com/gphoto/gphoto2/files/4776410/...tor.of.90.to.110.txt )

**Additional info:**
Also, the 'Preset' time values on the Ekos tab:'Gphoto CCD' had very high & unusual looking values.

GPhoto version: 2.5.23, libgphoto2: (even though i did upgrade to 2.5.25 it still says, libgphoto2_port 0.12.0. The X-T2 camera was in the mentioned above modes, connected to a Raspian Raspberry Pi 4B.

Hopefully, the BULB mode issue when set to MS / MS&ES can be fixed.
As an alternative, the TIMED mode might be a secondary solution but somehow have to fix the 'out by a factor' issue (in GPhoto or KStars/Ekos.. pls let me know if i should raise that there).

Many thanks,


I have just the command line running on the Pi4B, and only the camera connected via USB cable.

gphoto2 --auto-detect
shows the Fuji Fujifilm X-T2 connected on Port usb:001,003

all looking promising..

gphoto2 --summary
tells me: No image capture, No open capture, No vendor specific capture

not looking so good..

gphoto2 --debug-logfile=mylogfile.txt --capture-image
tells me: ERROR
'Sorry, your camera does not support generic capture'

Any help here is very appreciated.


Thanks.. I'll have a look for a GPhoto test application, is that just a command line driven part of gphoto? ..and yes actually that was just the camera only connected, nothing else.


Hi guys,

Hoping you can help.

Running v2.0.1 of Astroberry
The current version of KStars 3.4.2
Only a Fuji X-T2 connected via USB cable
Ekos running the camera with the GPhoto CCD driver (GPhoto version: 2.5.20, libgphoto2:, libgphoto2_port 0.12.0)

I'm yet to be able to take a photo at all.

The X-T2 camera was in Bulb mode, connected to the Pi 4B via a working USB cable (it can control the mount no problem) with the LCD screen showing black with 'USB Mode' displayed.

Error below:

[2020-06-11T10:49:23.447 AEST INFO ][ org.kde.kstars.indi] - GPhoto CCD : "[INFO] Starting 1 seconds exposure. "
[2020-06-11T10:49:23.447 AEST DEBG ][ org.kde.kstars.indi] - GPhoto CCD : "[DEBUG] No exposure widget found. Can not expose! "

The full

File Attachment:

File Name: logfile.txt
File Size: 21 KB

I've also tried using the Snap Port (on the EQ6R Pro mount) which does activate on the initial selection of 'snap port enable' in Ekos, but then I have to manually press the shutter release on the camera physically to close the shutter again.
And after that, I can't see how to control that again, as using the capture module won't trigger it. (But that's a problem for future me perhaps).

Hope you can help,