Update Kstars?

  • Posts: 3
  • Thank you received: 0

Update Kstars? was created by StephenS

Hi,

The github Astroberry page says:

“Starting from version 1.1.0 you need to ref lash your microSD card with the latest image file to upgrade the system. To upgrade your operating system use regular procedure by running apt, apt-get, aptitude or Software Updater.”

Does this mean that I cannot update, for instance , Kstars without breaking something?

Thanks for the help.

Stephen S.
1 week 4 days ago #34756

Please Log in or Create an account to join the conversation.

  • Posts: 545
  • Karma: 6
  • Thank you received: 204

Replied by Kaczorek on topic Update Kstars?

No, feel free to update the system and it's components (including KStars and INDI drivers) with standard "apt-get update; apt-get upgrade".
The previous versions of Astroberry Server included independent update scripts, so Astroberry Server itself could be updated. Now, when you flash version X you can only update & upgrade with standard "apt-get update; apt-get upgrade" and if an Astroberry Server version Y is released, you have to reflash SD card to use it. In other words when you start using version X you can update system components but cannot upgrade to version Y. This can be accomplished only by reflashing SD card.
Answering your (next) question - what's could be a difference between version X and Y of Astroberry Server - specific configuration, custom drivers not distributed with apt-get updates, new applications etc.
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
1 week 4 days ago #34761

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0

Replied by StephenS on topic Update Kstars?

Great! Thanks for the help and especially for making Astroberry available.

Cheers,

Stephen
1 week 4 days ago #34762

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0

Replied by yoandresmza on topic Update Kstars?

Hi Kaczorek. I has updated and upgrated from version 1.1.0 and now many things stoped work. I can't start VAP, hwclock and bind the serial port to the Bluetooth adapter anymore from rc.local. When I run the commands in the terminal I get the messages "permission denied".
Any suggestion? Thanks
5 days 14 hours ago #35026

Please Log in or Create an account to join the conversation.

  • Posts: 545
  • Karma: 6
  • Thank you received: 204

Replied by Kaczorek on topic Update Kstars?

Did you update by standard "apt-get update; apt-get upgrade"? or by any chance you ran "do-release-upgrade"?
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
5 days 14 hours ago #35027

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0

Replied by yoandresmza on topic Update Kstars?

Only by the standar apt-get update and apt-get upgrade.
5 days 13 hours ago #35028

Please Log in or Create an account to join the conversation.

  • Posts: 545
  • Karma: 6
  • Thank you received: 204

Replied by Kaczorek on topic Update Kstars?

None of the custom components of the Astroberry Server is updated nor changed with update commands. I suppose something wrong happened with your system during update.
Try reflashing your SD card and updating the system again. Otherwise the only thing I can suggest is a remote TeamViewer session.
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
5 days 11 hours ago #35033

Please Log in or Create an account to join the conversation.

Moderators: Kaczorek
Time to create page: 0.600 seconds