×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Is my QHY still any good or is it dying?

  • Posts: 26
  • Thank you received: 1
Hello,I have a QHY-10 and I have to admit I'm not using it that often... (almost never)I just took it out of the cupboard a few days ago to test some stuff and took a deeper look at the camera and the darks I took with them.I'm no CCD expert, and I know that's a rather old cam but the darks look odd to me. When visualizing the dark frame in Siril and setting the display to linear it of course looks all black, but when setting it the display mode to auto-adjust I can see a gradient of colors from purple to green.More interesting, if I set the qhy_ccd driver to USB=1 of USB=0, the gradient direction moves from vertical to horizontal...Bellow are screenshots from both darks, in slow (~20s to get the frame) and fast (~1s to get the frame) modes:

Slow:

Fast:

I would be curious to understand:
* why am I getting different gradients depending on that setting of the qhy_ccd driver(USB speed)
* If that's something with the driver, what's the right way to configure the camera?
* Are these gradients normal or is it a proof of something wrong with my cam?

P.S: FITS are available fits darkshere
2 months 2 weeks ago #86246
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 415
  • Thank you received: 99
Do you have any older dark frames to compare to?
2 months 2 weeks ago #86247

Please Log in or Create an account to join the conversation.

  • Posts: 152
  • Thank you received: 10
Very interesting. The first frame appears somewhat normal. The second (fast) USB frame is too fast and requires a change of delay time to correct the timing error.

It was always a QHY recommendation to use the slower transfer speed to insure correct timing. My first suggestion would be to try some dark frames using a larger (slower) USB delay.
The following user(s) said Thank You: Sonny Cavazos
2 months 2 weeks ago #86251

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
Hi Kevin, thanks for your reply.

Unfortunately I could not find any older dark frame. As I mentionned in my post the camera was sleeping in a cupboard for quite some time and I must have freed up some space at some point.
Last edit: 2 months 2 weeks ago by Alexandre Chapellon.
2 months 2 weeks ago #86259

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
Hi Dan,

All previous frames were taken with the buffer already set to the 4096 max.
I have tried taking different frames bellow at 512, 2048 and 4096 but I can't see much difference.


Can you tell me more about this timing error and the qhy recommendation of using slow usb. I find it quite painful that I have to wait around 20s after the actual exposure and I really wonder why.
If I understand you correctly the dark (at least the slow one) is fine and the camera is working ok as long as I use the slow mode?
2 months 2 weeks ago #86261
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 152
  • Thank you received: 10
I still think your camera is working just fine. I'd put a 50mm DSLR lens on it and take some pictures inside. I looked at the specs for a QHY10 and see its using a progressive ccd from Sony, this means it should take images down to .001 second. Set INDI gain to 1 and see what you get. If it keeps coming out all white, try setting the offset down.

At the time the QHY10 was being developed, USB2.0 was the standard for interface transfer speed. The camera specs call for a 1x1 image to download in 18 seconds. If its possible on your INDI control panel, try experimenting with the USB polling times. The setting is located under the Options tab. The buffer settings should go, hand in hand, with the image binning. A binning of 1x1, 2x2, and 4x4 should work best with a buffer of 4096, 2048, and 512 respectively. The setting can range down to 10 and up to seconds.

If you are using a Pi or powered USB hub which allows selection of USB2.0 or USB3.0 ports, experiment with different transfer speeds and cables. Delays from outside noise and cable 'ringing' all come into how fast a camera can transfer.

Lastly, expecting a stream of 10meg images to transfer in 1 second intervals... is well.... going to be a challenge. If they are binned down to 4x4 and the buffer size matches the USB transfer speed, well....
The following user(s) said Thank You: Alexandre Chapellon
2 months 2 weeks ago #86266

Please Log in or Create an account to join the conversation.

  • Posts: 152
  • Thank you received: 10
Perhaps one more comment to assist you in testing your camera. Progressive scan ccds do not have a mechanical shutter. This means, the driver software must purge accumulated electrons from the ccd and its buffer before taking an actual image. In the rush for speedy images, this factor is frequently overlooked by developers seeking to have fast cameras. It is best for your testing if you loop or take a sequence of images for comparison. Thus, you may find a first, second, or even third image of a series does not appear the same as earlier images. In a similar sense be careful when making settings changes, then taking a single image. You must assure the change has occurred on a cleared ccd.

I always suggest testing in room light with a camera lens. A working QHY camera will take a very normal image, if IR filtered. Dark frames can easily be obtained with a lens cap.
2 months 2 weeks ago #86270

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
I'll first need to get a M42 lens before I can test that but thanks the the hint! :)
2 months 2 weeks ago #86275

Please Log in or Create an account to join the conversation.

  • Posts: 152
  • Thank you received: 10
You may find this software will work with your QHY10. It was developed for stand alone testing of QHY cameras.
github.com/OpenSkyProject/OpenSkyImager

Dan
2 months 2 weeks ago #86279

Please Log in or Create an account to join the conversation.

Time to create page: 0.548 seconds