×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

Sony camera SIGSEGV fault

  • Posts: 29
  • Thank you received: 0
Hello.
I been using INDI for two or three years
Anyway i have and still use it with various ZWO and canon cameras with zero issues, but i cannot get it to play nicely with my sony A7RIII. I also tried it with a sony A7 and I had the issues.
It will run for a while but sooner or later (usually sooner) i will get a message stating indi_sony_ccd has stopped working and then kstars crashes.
If anyone can offer any insight or a solution i would be grateful.
I just did a quick 100 x 10sec sequence and it crashed after image 47.
Log attached,
Thanks in advance.

Robert.

File Attachment:

File Name: indi_debug...4-10.txt
File Size:5 KB

File Attachment:

File Name: indi_app_l...4-10.txt
File Size:4 KB
Last edit: 1 year 2 months ago by robert.
1 year 2 months ago #90372
Attachments:

Please Log in or Create an account to join the conversation.

Looks like the crash is in libgphoto2 itself. The version is slightly old, can you use a newer version? In StellarMate, it's 2.5.30.1 while in your log it's 2.5.28.1. Not sure if the upgrade to a more recent libgphoto2 would help but perhaps worth a try.
1 year 2 months ago #90384

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 0

Replied by robert on topic Sony camera SIGSEGV fault

yup, that resolved the issue.I have been re-testing all evening with zero failures.Thanks.
1 year 2 months ago #90409

Please Log in or Create an account to join the conversation.

Time to create page: 0.353 seconds