Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: Pentax K-5 capture failed

Pentax K-5 capture failed 5 months 3 weeks ago #25274

Yes this is very weird.. I just tried to replicate it with Canon 600D, but it took all sequences with different ISOs fine without any glitches.. not sure what's going on there.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Pentax K-5 capture failed 5 months 3 weeks ago #25291

I just thought I would add some confusion...

I think the fits viewer is got some buffering problems. I was playing with the preview again because I wasn't understanding what was happening with the histogram display. So I was going from one ISO to another and frankly I couldn't corroborate what I was seeing with the settings. Also, I got the impression, looking at the histogram, that the fits viewer was adding two, even three captures together. Finally I closed the viewer and did a couple more previews and things appeared to be. This isn't a feature is it?

See in images two and three histogram peaks. This is because I left the fits viewer open and I went through 3 exposure settings.
Attachments:

Please Log in or Create an account to join the conversation.

Pentax K-5 capture failed 5 months 3 weeks ago #25340

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
I was not yet there, but indeed I do not understand the view in the FITS viewer. If I take 2 frames, I expect that I get twice the same view but that is not the case. The intensity seems to change from one to the next frame. The viewer is not adding I think but need to look closer into it.
In the meantime in order to analyse the issue I reconnected my ZWO camera that worked fine months ago. Now I can launch the driver and start a sequence but it loops without end and without vizualising the frame. I do not understand what is happening. I use the FITS format. From the other side, I thought something was wong with my camera but under windows it works fine. I tried to take a log but did not succeed. :S :evil: :sick:

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC
Last Edit: by noste99.

Pentax K-5 capture failed 5 months 3 weeks ago #25343

I think it was just not syncing the GUI while visible. Can you check.. close the histogram, take a photo, then open it up, is it updated now? If yes, then problem should be fixed in next version. If not, then the problem is elsewhere.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Pentax K-5 capture failed 5 months 3 weeks ago #25345

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
I took a sequence of 2 frames exposure of 1s delay 2s FITS format.
The first frame is vizualised in the FITS viewer. I looked at the statistics and found a mean of 525.
For the second frame the colors change and the mean becomes 12.581. The two frames are saved and I have attached them.
Attachments:

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC
Last Edit: by noste99.

Pentax K-5 capture failed 5 months 1 week ago #25817

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
Hi,
I resumed after a few days testing of my K5. In the production version the GPhoto DSLR driver works fine but the PENTAX DSLR driver not.
The frame visualized in the FITS viewer is a line with width 277 and height 2. In the CCD tab of EKOS Size is limited to 277x2.
Could this be corrected?
The issue with the old frames showing up in the FITS viewer is still not solved I have the impression.

Thanks for the help!

Stefan

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Pentax K-5 capture failed 5 months 1 week ago #25823

That's the weird things. It never happen on my K5IIs til now. Hmmmm......

Please Log in or Create an account to join the conversation.

Pentax K-5 capture failed 2 months 1 week ago #28239

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5

File Attachment:

File Name: indi_gphoto_ccd_191908.log
File Size: 0 KB

File Attachment:

File Name: log_20-51-04.txt
File Size: 104 KB
Hi,
After a few months inactivity I resumed again working with my PENTAX K-5.
Indiserver with EQMod mount, ZWO AS120MC works perfectly.
PENTAX DSLR is still a big problem. What worked months ago with GPHOTO DSLR does not even work anymore today neither with the PENTAX DSLR driver.
I get really hopeless.
I use KSTARS 2.9.7 Build 2018-08-03T18:03:22Z 6:2.9.7+201808030814~ubuntu18.04.1
KDE Frameworks 5.44.0
Qt 5.9.5 (built against 5.9.5)
The xcb windowing system
Indi-full cersion 1.7.4~201808031039~ubuntu18.04.1
I am using stable upgrading
GHPOTO2 Version 2.5.15-2
In EKOS it is impossible to set W and H of the frame higher than 3000x3264
I launched the GPHOTO DSLR via the device manager but EKOS asked to shutdown the running one before launching a new one.
When taking a sequence of pictures I get and automatic and prompt Abort and the message "KStars detected INDI driver indi_gphoto_ccd crashed. Please check INDI server log in the Device Manager."

The Camera is on Bulb mode and USB MSC.

File Attachment:

File Name: log_20-51-04.txt
File Size: 104 KB

Could someone report back whar should work and what not today?
I tried the PENTAX DSLR driver and that also blocks.

I went back to Entangle controlling my PENTAX K-5 and that works fine when changing the ISO but no effect can be seen if the exposure time is doubled.

Thanks for the help,

Stefan
Attachments:

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC
Last Edit: by noste99.

Pentax K-5 capture failed 2 months 1 week ago #28248

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
The Pentax K-5 firmware version is 1.16 (last version).
This morning, when updating and upgrading I saw that indi-gphoto was upgraded.
In order to be sure that the issues were not caused by some settings I changed myself, I reset all settings to factory settings.
When starting the indiserver a warning is shown: [WARNING] Shutter speed widget does not have any valid data (count=0).
The driver name is GPhoto CCD and the Exec is indi_pentax_ccd, version 2.3, interface 10.
I saved a series of capturing sequences in a file for upload when starting.
After uploading the saved sequences and the first start, all sequences go quickly to status complete. The indi_pentax_ccd process continues running.
Resetting the status to Idle for all lines and starting the list of sequences changes the status of the first sequence to "in progress", beside expose an indicator starts turning and the message window opens and informs that the indi_pentax_ccd driver crashed. The indi_pentax_ccd process on the linux machine was initially in a status Sl+ meaning S=uninterruptible sleep, l=is multithreaded and +=is in the foreground process group. After the message that the driver crashed theprocess status was S+ so the multi-threading disappeared.
The driver log did not revealed any issue.
In the KSTARS log the following error appears: INDI Server: "2018-08-05T08:36:36: Driver indi_pentax_ccd: indi_pentax_ccd dispatch error: Property CCD_ABORT_EXPOSURE is not defined in Pentax DSLR K5D 0." from which I deduce that it is not possible to abort the exposure in the PENTAX K5D0. In any case when starting the exposure I would expect the countdown to start and the indicator starts turning.
When disconnecting and reconnecting (without stopping and restarting the indi server) the status of the indi_pentax_ccd process becomes again multi-threaded. Restarting the sequence puts the first sequence again in "in progress" status, the driver does not crash but the linux process is again not multi-threaded anymore, just as the driver would crash but this is not reported.
Remark that after that the driver crashed, the DSLR does not remain blocked. When restarting the indiserver and reconnecting the DSLR the exposure button of the DSLR does not respond when pushing it. The DSLR seems to be under full control of EKOS.

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Pentax K-5 capture failed 2 months 1 week ago #28264

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
When launching KSTARS under sudo the following error message is printed:

Dispatch command error(-1): INDI: Could not find property CCD_EXPOSURE in GPhoto CCD
<setNumberVector device="GPhoto CCD" name="CCD_EXPOSURE" state="Idle" timeout="60" timestamp="2018-08-05T12:06:38">
<oneNumber name="CCD_EXPOSURE_VALUE" min="0.001" max="3600" step="1">
1
</oneNumber>
</setNumberVector>

Further, I started exploring the command line interface for gphoto2 and this worked marvelously well for my PENTAX K-5, demonstrating that the issues are clearly inside EKOS.

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Pentax K-5 capture failed 2 months 1 week ago #28269

I sent you a private message on how to proceed with this, please check it out.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Pentax K-5 capture failed 2 months 1 week ago #28335

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
Jasem, good morning. Could you please drop me a message when the driver is updated? Thanks for the help. Stefan

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC
Time to create page: 0.167 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica