×

INDI Library v1.9.5 Released (08 Mar 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Sony A7III / A7RII, which driver?

  • Posts: 19
  • Thank you received: 1
Hi all,
I'm trying to connect my Sony A7III (ILCE-7M3) and A7RII (ILCE-7RM2) to my Raspberry Pi, which driver in INDI should I select?
It works (somewhat) with GPhoto CCD (but I couldn't get it to capture anything other than 1 second, maybe I will try again), but does not work at all with Sony DSLR (gives error about not being able to communicate with camera).
Am I missing something?
3 years 5 months ago #31757

Please Log in or Create an account to join the conversation.

Please attach the verbose logs. Check my signature.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 years 5 months ago #31758

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Alright, I will do that later when I get back. Thanks!
3 years 5 months ago #31759

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Hi,
I did the following:
Enable logging on INDI (CCD module)
Use GPhoto CCD instead of Sony DSLR
Set up a sequence of 5 frames of 5 seconds each, with a 10 second delay in between
Format: Native
Set the camera to BULB

It seems to release the shutter for the correct 5 seconds, but it gives up with an error after the 3rd frame.
Is there a way to keep the photos on the camera? I'm running Ekos on a Raspberry Pi and the transfer is really slow...
Last edit: 3 years 5 months ago by Wong Sy Ming.
3 years 5 months ago #31774
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
Hi,
Feel nice to find you i am an owner of a7iii too.
I wonder if finally the sony A7iii work right with the drivers indi on Stellarmate.
Its better to know before i buy the stellarmate

Thank you
3 years 3 weeks ago #38348

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Hi there,
Stellarmate works fine with my A7III, using native "Sony DSLR" driver. But remember to set the camera to "RAW" only first...
3 years 3 weeks ago #38396

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
Wow!! Thank you! You save me! i made a mistake and tried with Gphoto without success.
i Didnt saw the Sony Driver.
Now everything works right and i feel ready for the the night fields...
3 years 3 weeks ago #38405

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
Hi guys
I am a new user of sony A7S with the indi driver under raspbian (I usually use the ASCOm driver under W7).
Everything is going well with Bulb mode but when I use M mode and choose a shutter speed the driver crashes.
Have you ever managed to use M mode?
Thank you
Mount : Avalon Fast Linear
FSQ 106 + Lakerside focuser
CCD : QHY290 MM Cool Guider : QHY5L-II
DSRL : Sony A7S Baader Mooded
1 year 5 months ago #63381

Please Log in or Create an account to join the conversation.

Time to create page: 0.967 seconds