×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Enable Autohome for the EQ8-R PRO

  • Posts: 56
  • Thank you received: 7
Autohome is a great function but it looks like it is not enabled for the skywatcher EQ8-R PRO in the indi-eqmod-driver. I found an issue about this and offered my help but got no answer, maybe since the issue is closed since June: github.com/indilib/indi/issues/1162

So I played bit with the code an got autohome running on my mount. You can see the changes I´ve made here: sternenkarten.com/2020/11/23/umstellung-auf-die-eq8-r-pro/

I wrote this article in German but the part for enabling autohome is written in English. Maybe this can help the devs to enable autohome or the EQ8-R PRO.
Last edit: 1 year 11 months ago by Edgar Scholz.
2 years 1 week ago #63316

Please Log in or Create an account to join the conversation.

  • Posts: 183
  • Thank you received: 23
@knro fixed this on my mount as a test earlier this year, if you go to the GitHub you will see it, because of a concern over safety it has not been made part of the core release - personally it;'s been fine for me, I think it's time to add it!

Also note that there's a PPEC bug, again see GitHub issues, if you can reproduce it woudl be helpful to know it's not just me
GSO Ritchey Chretien 12" Truss | SkyWatcher ED72
ZWO ASI 2600MC Pro, 1600MM Pro, ASI290MM and ASI224MC all-sky | ZEO EFW | ZWO OAG
Moonlite V2.5 CSL | DeepSkyDad AF3
EQ8-R | Paramount ME & MX
Nexdome | SQM LE | AAG CloudWatcher and Solo | Ultimate Power Box V2 | Spike-a-Flat
Angry missus
2 years 5 days ago #63562

Please Log in or Create an account to join the conversation.

  • Posts: 522
  • Thank you received: 103
Auto-home for the EQ8 is still marked experimental in the INDI control panel as well. It has been working well for me thus far.

Jim
12" pier with HDX110 using EQMod
ASI 1600 mono/color mains with ASI290MM in off-axis
ASI filter wheel
Moonlite focusers for the sharpening
AT115EDT w/.8x for the light
Fedora Linux, 100% INDI
2 years 5 days ago #63564

Please Log in or Create an account to join the conversation.

  • Posts: 183
  • Thank you received: 23
Same but different. The EQ8-R returns a different response to the driver than the EQ8 and will not work without being patched. Jassem patched it as a test, but the new code was never committed. I think it's probably time it was done given the mount is more widely used now.
GSO Ritchey Chretien 12" Truss | SkyWatcher ED72
ZWO ASI 2600MC Pro, 1600MM Pro, ASI290MM and ASI224MC all-sky | ZEO EFW | ZWO OAG
Moonlite V2.5 CSL | DeepSkyDad AF3
EQ8-R | Paramount ME & MX
Nexdome | SQM LE | AAG CloudWatcher and Solo | Ultimate Power Box V2 | Spike-a-Flat
Angry missus
2 years 4 days ago #63596

Please Log in or Create an account to join the conversation.

  • Posts: 56
  • Thank you received: 7

I guess you mean the mountcode with different response. If I understand the code correct, there are only two mounts enabled to do autohome. That´s the EQ8 with the mountcode 0x04 and the AZEQ6 with mountcode 0x05. Btw. I have an AZEQ6, but never realized it has a autohome funktion. Testing is a bit complicated atm due to a corona-quarantäne of me, a collegue was positive, but if thats gone, I will test my AZEQ6 with autohome.

I never found a testing-patch in indi 3rd-party-git. so I did it my way to get my EQ8-R running with autohome. I added the mountcode of the EQ8-R to related functions. This mountcode can easily be found in indi in the firmware-tab. No clue, if this a good way, but it works for me.

About the PPEC-bug:
I never used PPEC. But I will do a test next week.

Edgar
The following user(s) said Thank You: Paul Muller
2 years 4 days ago #63632

Please Log in or Create an account to join the conversation.

  • Posts: 183
  • Thank you received: 23
Edgar - here is the old Githib issue log github.com/indilib/indi/issues/1162, is the correct one - I've added a link to your fix int eh solution. I might re-open it.

Are you going to submit your fix to integrate into the trunk?
GSO Ritchey Chretien 12" Truss | SkyWatcher ED72
ZWO ASI 2600MC Pro, 1600MM Pro, ASI290MM and ASI224MC all-sky | ZEO EFW | ZWO OAG
Moonlite V2.5 CSL | DeepSkyDad AF3
EQ8-R | Paramount ME & MX
Nexdome | SQM LE | AAG CloudWatcher and Solo | Ultimate Power Box V2 | Spike-a-Flat
Angry missus
Last edit: 2 years 14 hours ago by Paul Muller.
2 years 14 hours ago #63839

Please Log in or Create an account to join the conversation.

  • Posts: 56
  • Thank you received: 7
Paul, Thankyou for the link. Yes that´s the issue, I found in the web.

If you or some other guy want to submit the patch, please feel free to do so. I can do a pull request as well, but you must give me some time. I cannot do this before Christmas.

Edgar

Edit:
Fixed by Jasem: github.com/indilib/indi-3rdparty/commit/...1c5d8a2f046c33795da5
Last edit: 1 year 11 months ago by Edgar Scholz.
1 year 11 months ago #63970

Please Log in or Create an account to join the conversation.

  • Posts: 183
  • Thank you received: 23
it seems there's a bug in the device itself or I've been training it incorrectly. See here;
groups.io/g/GSS/topic/eq8r_pro_ppec_proc...ky,,,20,2,0,78799913

Be interested to see if you encounter the same problem.
GSO Ritchey Chretien 12" Truss | SkyWatcher ED72
ZWO ASI 2600MC Pro, 1600MM Pro, ASI290MM and ASI224MC all-sky | ZEO EFW | ZWO OAG
Moonlite V2.5 CSL | DeepSkyDad AF3
EQ8-R | Paramount ME & MX
Nexdome | SQM LE | AAG CloudWatcher and Solo | Ultimate Power Box V2 | Spike-a-Flat
Angry missus
1 year 11 months ago #64435

Please Log in or Create an account to join the conversation.

  • Posts: 56
  • Thank you received: 7
Sorry, but I can not do any testing in my observatory before Christmas. Waiting for holiday ...
Edgar
The following user(s) said Thank You: Paul Muller
1 year 11 months ago #64497

Please Log in or Create an account to join the conversation.

Time to create page: 0.167 seconds