Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: Polar Align Assist never completes its run

Polar Align Assist never completes its run 1 year 4 months ago #17789

  • kbahey
  • kbahey's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 135
  • Thank you received: 10
It crashed for me with simulators only. That is good news in a way since I can test it without being outside.

Here is the backtrace when it crashed:
#0  0x00005555557ec7d5 in FITSData::loadWCS (this=0x555559740780)
    at /build/kstars-bleeding-pB0aYi/kstars-bleeding-17.04+201707072129~ubuntu16.04.1/kstars/fitsviewer/fitsdata.cpp:2216
#1  0x00005555557ecd62 in QtConcurrent::StoredMemberFunctionPointerCall0<bool, FITSData>::runFunctor (
    this=0x555558d46100) at /usr/include/x86_64-linux-gnu/qt5/QtConcurrent/qtconcurrentstoredfunctioncall.h:183
#2  0x00005555556250f5 in QtConcurrent::RunFunctionTask<bool>::run (this=0x555558d46100)
    at /usr/include/x86_64-linux-gnu/qt5/QtConcurrent/qtconcurrentrunbase.h:102
#3  0x00007ffff306a2d3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007ffff306d7be in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007ffff47ac6ba in start_thread (arg=0x7fffd8ea5700) at pthread_create.c:333
#6  0x00007ffff18c93dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Please Log in or Create an account to join the conversation.

Polar Align Assist never completes its run 1 year 4 months ago #17793

  • kbahey
  • kbahey's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 135
  • Thank you received: 10
Since the crash is related to WCS, I tried again with WCS disabled, both in the Solver, and in the CCD Simulator in INDI.

Still, PAA does not complete. It takes the final image, solves it, and then hangs there with the 'Capture' button greyed out.

Below the PAA, it has the following. Sitting there for 8 minutes now and nothing happening:
2017-07-11T15:54:34 Error: Failed to load WCS data in file: No world coordinate systems found.
2017-07-11T15:54:34 WCS data processing is complete.
2017-07-11T15:54:11 Please wait while WCS data is processed...
2017-07-11T15:54:11 Solution coordinates: RA (22h 54m 22s) DEC ( 89° 19' 37") Telescope Coordinates: RA (22h 53m 44s) DEC ( 89° 19' 57")
2017-07-11T15:54:11 Solver completed in 17 seconds.
2017-07-11T15:53:54 Starting solver...
2017-07-11T15:53:54 Image received.

Strange that it tries to do WCS despite me disabling them.

In the terminal where I started kstars from gdb, I see the following:
Found one coordinate representation.
Found one coordinate representation.
Found one coordinate representation.
FITSIO status = 104: could not open the named file
failed to find or open the following file: (ffopen)
/tmp/fitsn19301
Found one coordinate representation.
Found one coordinate representation.
Found one coordinate representation.
Found one coordinate representation.
Found one coordinate representation.
Found one coordinate representation.

Any clues?

Please Log in or Create an account to join the conversation.

Polar Align Assist never completes its run 1 year 4 months ago #17796

This last one is also with simulators? If you have TeamViewer, I can login and check it out. Send me a private message.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Polar Align Assist never completes its run 1 year 4 months ago #17797

  • kbahey
  • kbahey's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 135
  • Thank you received: 10
Both runs are with simulators (CCD and Telescope). Only difference is WCS enabled and WCS disabled. Both fail to complete. First one crashes, the second one just stalls indefinitely.

No, I don't use TeamViewer.

Please Log in or Create an account to join the conversation.

Polar Align Assist never completes its run 1 year 4 months ago #17847

  • kbahey
  • kbahey's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 135
  • Thank you received: 10
Jasem worked on this issue and correctly diagnosed it, and create a fix for it in KStars.

It had to do with WCS on slower machines.

The fix is in KStars git, so you have to compile from source, or wait for a package to appear including this fix.

Please Log in or Create an account to join the conversation.

Polar Align Assist never completes its run 1 year 2 months ago #18899

Was the fix for this issue rolled out yet?

Please Log in or Create an account to join the conversation.

Polar Align Assist never completes its run 1 year 2 months ago #18911

I tried to use the polar alignment tool with the mount and ccd simulator, on both OS X and RPi and it keeps getting stuck:

2017-08-29T17:14:57 Error: Failed to load WCS data in file: No world coordinate systems found.
2017-08-29T17:14:57 WCS data processing is complete.
2017-08-29T17:14:56 Please wait while WCS data is processed...
2017-08-29T17:14:56 Solution coordinates: RA (22h 56m 19s) DEC ( 89° 19' 52") Telescope Coordinates: RA (22h 54m 39s) DEC ( 89° 19' 59")
2017-08-29T17:14:56 Solver completed in 39 seconds.
2017-08-29T17:14:19 Upload complete. Waiting for astrometry.net solver to complete...
2017-08-29T17:14:17 Uploading file...
2017-08-29T17:14:17 Image received.
2017-08-29T17:14:12 Capturing image...
2017-08-29T17:14:12 Mount second rotation is complete.
2017-08-29T17:14:08 Please wait until mount completes rotating to RA (22h 54m 39s) DE ( 89° 19' 59")
2017-08-29T17:14:08 Solution coordinates: RA (00h 56m 15s) DEC ( 89° 19' 43") Telescope Coordinates: RA (00h 54m 39s) DEC ( 89° 19' 59")
2017-08-29T17:14:08 Solver completed in 35 seconds.
2017-08-29T17:13:35 Upload complete. Waiting for astrometry.net solver to complete...
2017-08-29T17:13:33 Uploading file...
2017-08-29T17:13:33 Image received.
2017-08-29T17:13:28 Capturing image...
2017-08-29T17:13:28 Mount first rotation is complete.
2017-08-29T17:13:24 Please wait until mount completes rotating to RA (00h 54m 39s) DE ( 89° 19' 59")
2017-08-29T17:13:21 WCS data processing is complete.
2017-08-29T17:13:20 Please wait while WCS data is processed...
2017-08-29T17:13:20 Solution coordinates: RA (02h 55m 40s) DEC ( 89° 19' 39") Telescope Coordinates: RA (02h 54m 39s) DEC ( 89° 19' 59")
2017-08-29T17:13:20 Solver completed in 42 seconds.
2017-08-29T17:12:39 Upload complete. Waiting for astrometry.net solver to complete...
2017-08-29T17:12:38 Uploading file...
2017-08-29T17:12:38 Image received.
2017-08-29T17:12:33 Capturing image...

Please Log in or Create an account to join the conversation.

Polar Align Assist never completes its run 1 year 2 months ago #18912

  • kbahey
  • kbahey's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 135
  • Thank you received: 10
Yes, this fix has been in the daily build for quite some time. If you are not using the daily build, then any package from more than one and a half months ago has the bug. The bug only occurs on slower machines though.

Please Log in or Create an account to join the conversation.

Polar Align Assist never completes its run 1 year 2 months ago #18913

Thanks kbahey! I must have something configured incorrectly then because I have 2.8.2 and my MacBook Pro should be fast enough. I’ll keep tinkering.

Please Log in or Create an account to join the conversation.

Last Edit: by dsidote.

Polar Align Assist never completes its run 1 year 2 months ago #18915

I found the problem... I can't read ! I missed this message

2017-08-29T17:58:33 World Coordinate System (WCS) is enabled. CCD rotation must be set either manually in the CCD driver or by solving an image before proceeding to capture any further images, otherwise the WCS information may be invalid.

Once I plate solved an image and tried again it worked.

Please Log in or Create an account to join the conversation.

Polar Align Assist never completes its run 1 year 2 months ago #18946

I was actually able to replicate this issue, it was intermittent but I identified the cause and it is now fixed in GIT.
The following user(s) said Thank You: dsidote

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Polar Align Assist never completes its run 9 months 2 weeks ago #22694

Hey there!
Found this thread through the search function.
I have exactly the same problem. EQ6-R Canon DSLR. No connection problems. Very old HP Pavillon Notebook with direct USB connection to EQ and Canon.
After i was succesful to solve an image (Polaris) i tried to use the Polar alignment.
I go through the points. Picture-solving-WCS-turn scope-picture-solving-wcs-turn again picture-solve-wcs AND HERE the whole program crashes and just closes without any error message. Does anyone know whats the problem?
And what does "GIT" mean? ´Cause you said its fixed in GIT?

cheers
Niki

Please Log in or Create an account to join the conversation.

Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Skywatcher 6" Newton | Moravian G2 8300 color | ASI120mm guiding cam | ASI 60280 guiding scope | KSTARS NIGHTLY 3.0.0. on Remotemachine | KSTARS v. 2.9.8 on iMac
Time to create page: 0.297 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica