×

INDI Library v1.7.9 Released (23 Jun 2019)

INDI Library v1.7.9 is mostly a maintenance release to fix a few bugs in several drivers.

Ekos profile editor does not save guiding [SOLVED]

  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Ekos profile editor does not save guiding [SOLVED] was created by Kaczorek

Hi guys

I'm going through thorough testing after release of new version of Astroberry Server and noticed that Ekos profile editor does not save guiding option selected by a user. Whatever you select i.e. Internal/PHD2/LinGuider a profile shows Internal after save. This applies both for local and remote profiles. Anybody faced this issue? Cannot find any reports on the forum.

KStars 2.9.8 built 2018-8-18T08:14:53Z
Ubuntu Mate 16.04 @Raspberry Pi
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
Last edit: 8 months 1 week ago by Kaczorek.
8 months 2 weeks ago #31268

Please Log in or Create an account to join the conversation.

  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Ekos profile editor does not save guiding

Anybody?
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
8 months 1 week ago #31326

Please Log in or Create an account to join the conversation.

Replied by knro on topic Ekos profile editor does not save guiding

I cannot reproduce this issue. Try clearing ~/.local/share/kstars/userdb.sqlite and try again.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Kaczorek
8 months 1 week ago #31334

Please Log in or Create an account to join the conversation.

  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Ekos profile editor does not save guiding

This is the fix! After removing ~/.local/share/kstars/userdb.sqlite and recreating profiles everything works OK.
Thanks Jasem

BTW. I checked the file permission before removing it and they were ok, so it's not about write access to the file. Is it a case that the newest KStars cannot use userdb.sqlite from previous versions? I left the old file to preserve profiles, so maybe this is a reason?
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
8 months 1 week ago #31359

Please Log in or Create an account to join the conversation.

  • Posts: 1715
  • Karma: 19
  • Thank you received: 516

Replied by rlancaste on topic Ekos profile editor does not save guiding

If I had to take a guess, you had a really old database file that had some incompatibility with a feature that was added or changed . I had a similar issue a few months ago where a setting was originally misspelled in the database, then it got corrected, but my database was old and had the wrong spelling in it for the feature. So the feature did not get saved and work properly. One solution is to delete the database and have it recreate itself. I think my solution was that I figured out what was wrong and I edited my database to correct the issue using a database editor.
The following user(s) said Thank You: Kaczorek
8 months 1 week ago #31367

Please Log in or Create an account to join the conversation.

Time to create page: 0.203 seconds