×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Missing Ekos Tab in KStars 3.5.3 Linux Upgrade

  • Posts: 14
  • Thank you received: 4
Hi All,

I just did the standard upgrade:
(repository ppa:mutlaqja/ppa):
  sudo apt-get update
  sudo apt-get install indi-full kstars-bleeding

The software is updated to 3.5.3 (kstars-bleeding), but after starting kstars, the Ekos option is not found in the Tools tab.  Scratching my head, I removed and re-installed but still no EKOS.  Was the option missed during the build process?  I am running Linux Mint 20  and was upgrading from kstars 3.5.2 to latest.  After the installation the help/info shows:     KStars
     Version 3.5.3 Stable
     Build: 2021-04025T15:57:41Z
Cheers,

Chris
 
5 months 3 weeks ago #70538

Please Log in or Create an account to join the conversation.

  • Posts: 28
  • Thank you received: 2
Greetings Chris,

I have the same problem after upgrading to 3.5.3. Running Ubuntu 20.04 LTS.
I cant find EKOS and INDI tab even if I try to configure the icons shown on the toolbar.

Best regards,
George.
AAVSO/SILSO - Sun Observer - Sunspot Counting
ESA ARIEL Exoclock Project & NASA Exoplanet Watch Project - Exoplanet Observer

Specca Observatory
Ioannina, Greece

Sky-Watcher Black Heavy Duty EQ6 mount
Sky-Watcher 254/1200 mm Newtonian
Bresser Skylux 70/700 mm
ATIK 320E Mono
QHY 6 Mono
5 months 3 weeks ago #70539

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
same for me (Ubuntu 20.04. LTS)
5 months 3 weeks ago #70540

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 0
Same here all  icons missing from kstars to connect to indi is there a fix ?
5 months 3 weeks ago #70544

Please Log in or Create an account to join the conversation.

Going to rebulild KStars now, should be fixed soon.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Christopher Kovacs
5 months 3 weeks ago #70545

Please Log in or Create an account to join the conversation.

  • Posts: 310
  • Thank you received: 13
I am running Kstars 3.5.3 on an Rpi4 with an Ubuntu 20.1 64 bit OS.  I have the EKOS icon in Kstars, but I seem to have a missing tab in the Indi Control Panel. In my profile I have an SX CCD and I get no errors about the driver crashing in the log, but I get no tab for the SX CCD in the Indi control Panel, so I cannot connect. The camera runs fine in PHD2 as a stand alone. As I mentioned in another thread I have tried to make sure I have all the xml files in the right locations, but that has not restored the tab in the control panel.



 
Last edit: 5 months 3 weeks ago by Ronald Scotti. Reason: corrections
5 months 3 weeks ago #70560

Please Log in or Create an account to join the conversation.

  • Posts: 310
  • Thank you received: 13
spoke too soon, I just did an upgrade (after I saw that Jasem was working on a new rebuild and now Ekos is missing from Kstars on Ubuntu 20.1 on Rpi-4.
I will reboot and try again.

Nope, no joy.  Ekos is even missing from Kstars settings.

Is there a was to recover Kstars 3.5.0 for Linux on Rpi-4?
 
Last edit: 5 months 3 weeks ago by Ronald Scotti. Reason: corrections
5 months 3 weeks ago #70566

Please Log in or Create an account to join the conversation.

  • Posts: 172
  • Thank you received: 33
Same problem on RPi4 4GB running Ubuntu 20.1, decided to finally try the stable version after having a locked-in nightly version from a couple of months ago that was working fine. Looks like Jasem is sorting it out as we speak.
Interestingly I did a stable KStars upgrade on another Rpi only two days ago and that was perfect but that said it was 3.5.3 trial version (not stable) although I was accessing the stable ppa ?
I suppose we just wait or roll back to a previous version. No worries either way for me lots of cloud on the way over the next few days. :)

Mike
iOptron CEM40G, SharpStar CF90IIApo with Moonlight focuser, ASI294MCpro, ASI120MM-S, DIY MyFocuserPro2, RPi4 8Gb 120SSD running KStars/Ekos/Indi under Ubuntu Mate 20.10, DIY flat box
Skywatcher Flextube 12" Dob, Meade LX75 8SCT, Skywatcher NEQ6Pro

5 months 3 weeks ago #70569

Please Log in or Create an account to join the conversation.

  • Posts: 310
  • Thank you received: 13
How do we roll back to a previous version? Unfortunately, I did not save the SD card image (like I should have) when I was running Kstars 3.5.0.
5 months 3 weeks ago #70572

Please Log in or Create an account to join the conversation.

  • Posts: 172
  • Thank you received: 33
Hmm, I feel sure that there is a repository of previous versions ? github. You could try using the KStars snap package which is often an older version. Here is a link snapcraft.io/install/kstars/ubuntu
This enables a roll back if you install another later using the same method I think.
I always have a cloned SD card just for this eventuality as I have been bitten before.

Mike
iOptron CEM40G, SharpStar CF90IIApo with Moonlight focuser, ASI294MCpro, ASI120MM-S, DIY MyFocuserPro2, RPi4 8Gb 120SSD running KStars/Ekos/Indi under Ubuntu Mate 20.10, DIY flat box
Skywatcher Flextube 12" Dob, Meade LX75 8SCT, Skywatcher NEQ6Pro

5 months 3 weeks ago #70573

Please Log in or Create an account to join the conversation.

  • Posts: 310
  • Thank you received: 13
"snap" does not seem to work on ARM64 (Rpi) hardware? I burned the SD card to and SSD, but there is no way to get the OS off the SSD as it is too large for the SD card (I should have made a smaller partition). Anyway I think I am stuck until Jasem fixes the latest release.

thanks,
5 months 3 weeks ago #70574

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 1
I also have the same result of not being able to access Ekos after updating to the latest KStars.

I can't seem to find a way to roll back. It looks like the PPA package listing only contains the most recent version. The same is true for Snap.

I might be missing something with the PPA package listing though. 

Anyone else have any luck on a rollback? I suppose I could build from source.

 
5 months 3 weeks ago #70575

Please Log in or Create an account to join the conversation.

Time to create page: 1.027 seconds