×

INDI Library v1.7.8 Released (11 May 2019)

Mid year release of INDI Library v1.7.8 comes with a few drivers and improvements to to existing drivers.

unmet dependencies on Odroid XU4 arm ubuntu mate 16.04

  • Posts: 33
  • Thank you received: 2

unmet dependencies on Odroid XU4 arm ubuntu mate 16.04 was created by HoHr

I just installed and upgraded latest ubuntu mate and kernel 4.14 following instructions from hardkernel without errors.

However can't install indi-full as it depends on indi-fli which depends on libfli1 and that on fliusb-dkms which is not available (or ... but it is not installable, E: Unable to correct problems, you have held broken packages.)

??

is it INDI or ODROID issue?
1 year 2 months ago #23760

Please Log in or Create an account to join the conversation.

  • Posts: 513
  • Karma: 1
  • Thank you received: 90

Replied by Ihoujin on topic unmet dependencies on Odroid XU4 arm ubuntu mate 16.04

I had similar issues with recent changes made to the repository. Try fixing it with this.
sudo apt-add-repository ppa:mutlaqja/ppa
INDI/KStars on Raspberry Pi 3B+
Lubuntu 16.04
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG @280mm Guide Scope
PHD2
Adafruit Motor Hat shield
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
1 year 2 months ago #23763

Please Log in or Create an account to join the conversation.

Replied by knro on topic unmet dependencies on Odroid XU4 arm ubuntu mate 16.04

It's a problem with the repo, I am building indi-fli now. Give it an hour or two.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 2 months ago #23768

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 2

Replied by HoHr on topic unmet dependencies on Odroid XU4 arm ubuntu mate 16.04

still same...
1 year 2 months ago #23783

Please Log in or Create an account to join the conversation.

Replied by knro on topic unmet dependencies on Odroid XU4 arm ubuntu mate 16.04

code.launchpad.net/~mutlaqja/+recipe/indi-fli-daily

It's built just fine. Also, it depends now on libfli2, not libfli1. Make sure to run sudo apt-get update && sudo apt-get -y dist-upgrade
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: HoHr
1 year 2 months ago #23786

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 2

Replied by HoHr on topic unmet dependencies on Odroid XU4 arm ubuntu mate 16.04

My fault, it works now. I was trying to establish remote access to odroid and short after I got it working the router died. Now I came up with ingenious idea to use RPi3's hotspot as an access point and it works.
1 year 2 months ago #23788

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 2

Replied by HoHr on topic unmet dependencies on Odroid XU4 arm ubuntu mate 16.04

Now i have other problem. Asi183mc connects, I can chance all settings but capture is looping without showing or saving anything. Can't take preview or live video either. Log doesn't show any error, exposing one frame after another until I hit stop. Can't see "downloading" message. Camera works fine on laptop. Can it do something with rights? I'm running kstars as superuser now. User cannot connect the camera on odroid.
1 year 2 months ago #23790

Please Log in or Create an account to join the conversation.

Replied by knro on topic unmet dependencies on Odroid XU4 arm ubuntu mate 16.04

There is a new option under "Options" call "Rapid Looping".. Make sure it's set to Disabled. Also, never run KStars as root unless there is a very good reason to.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 2 months ago #23804

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 2

Replied by HoHr on topic unmet dependencies on Odroid XU4 arm ubuntu mate 16.04

first I thought it's download issue but when I hit "pause" instead of "stop" it keeps looping saying 'shall pause after finishing current exposure'. It doesn't even proceed to downloading step and repeats exposing the very same frame.

Rapid looping makes no difference.
1 year 2 months ago #23811

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 2

Replied by HoHr on topic unmet dependencies on Odroid XU4 arm ubuntu mate 16.04

I can connect ASI183MC pro on my laptop (ubuntu mate 16.04) only as root too. If I do it as a user I get immediately "[ERROR] Error connecting to the CCD (5)". As root it connects normally and works as expected. On Odroid I expanded user's rights to admin and still cannot connect.
1 year 2 months ago #24047

Please Log in or Create an account to join the conversation.

Time to create page: 0.230 seconds