×

INDI Library v1.7.6 Released. (27 Feb 2019)

First release of 2019 comes with quite a few new drivers across the board along with significant performance improvements to INDI camera and live streaming performance. Many drivers received significant updates to improve performance & stability, while a few were re-written from scratch to be in line with INDI standards. Here are some of the highlights:

Flip Flat odd behavior using ESQ

  • Posts: 55
  • Thank you received: 3

Flip Flat odd behavior using ESQ was created by kamisan

I have a bad habit of droning on and on, so let me present these bullet-points and then if anyone is interested you can read on:
  • Dialog pops up telling me to cover my telescope to capture calibration frames. Odd, I have Flip Flat and I told it so in the Calibration settings.
  • When a ESQ step orders the flap to move, it does so but immediately returns to the previous position.
  • The 'delay' property apparently has no effect, none that I can see at least.

I have been using INDI for just over a month. I've already used it with great success about 3 weeks ago which was the last bit of good weather. It worked flawlessly. At that time I was running INDI/Ekos on my Linux laptop (Ubuntu 16.04). Since then I installed Astroberry on a RasPi Model B. I've been practicing with it, preparing for a couple of clear nights beginning tomorrow. Tonight I practiced building Ekos Sequence Queues (ESQ). I employed these three weeks ago using my Flip Flat. I captured every type of calibration frame flawlessly.

During these past three weeks Software Updater has alerted me to patches to 1.7.6 that included INDI drivers and KStars. Without thinking I installed them. Now I suspect that there is a gremlin in the works. Tomorrow I'll test this out on my Linux laptop just to eliminate the possibility that RasPi is responsible.

Thank you.
2 weeks 19 hours ago #36372

Please Log in or Create an account to join the conversation.

  • Posts: 55
  • Thank you received: 3

Replied by kamisan on topic Flip Flat odd behavior using ESQ

All right, progress.

I am looking at the KStars repo. On March 5th there was a lot of code added to kstars/ekos/capture/capture.cpp with commit comment: "Improve behavior for dark and flat frames capture when it comes to covering the mount." Now I see new message boxes that I hadn't seen before:

+ } else if (activeJob->getFrameType() == FRAME_DARK && m_TelescopeCoveredManually == false)
+ {
+ QStringList shutterfulCCDs = Options::shutterfulCCDs();
+ QStringList shutterlessCCDs = Options::shutterlessCCDs();
+ QString deviceName = currentCCD->getDeviceName();
+
+ bool hasShutter = shutterfulCCDs.contains(deviceName);
+ bool hasNoShutter = shutterlessCCDs.contains(deviceName) || ISOCombo->count() > 0;
+
+ // If we have no information, we ask
+ if (hasShutter == false && hasNoShutter == false)
+ {
+ if (KMessageBox::questionYesNo(nullptr, i18n("Does %1 have a shutter?", deviceName),
+ i18n("Dark Exposure")) == KMessageBox::Yes)
+ {
+ hasNoShutter = false;
+ shutterfulCCDs.append(deviceName);
+ Options::setShutterfulCCDs(shutterfulCCDs);
+ }
+ else
+ {
+ hasNoShutter = true;
+ shutterlessCCDs.append(deviceName);
+ Options::setShutterlessCCDs(shutterlessCCDs);
+ }
+ }
+
+ // If camera was flagged before as shutterless, or if it is a DSLR, then it is for sure shutterless.
+ if (hasNoShutter)
+ {
+ if (KMessageBox::warningContinueCancel(
+ nullptr, i18n("Cover the telescope in order to take a dark exposure."), i18n("Dark Exposure"),
+ KStandardGuiItem::cont(), KStandardGuiItem::cancel(),
+ "cover_scope_dialog_notification", KMessageBox::WindowModal | KMessageBox::Notify) == KMessageBox::Cancel)
+ {
+ return IPS_ALERT;
+ }
+
+ m_TelescopeCoveredManually = true;
+ }
}

This is the first time I ever saw the message: "Does %1 have a shutter?". I've never been asked that question before.
That was followed by this: "Cover the telescope in order to take a dark exposure."

Doesn't it see that I have Flip Flat?

It must see it at some level because the flap does move but the open/close movements are activated and then immediately reverted. The only way to get the ESQ to continue is to launch INDI control panel and manually click the Park/Unpark buttons to the target state.

Just a thought -- do you see this line:

+ } else if (activeJob->getFrameType() == FRAME_DARK && m_TelescopeCoveredManually == false)

shouldn't it be:

+ } else if (activeJob->getFrameType() == FRAME_DARK && m_TelescopeCoveredManually == true)

Thanks.
2 weeks 12 hours ago #36390

Please Log in or Create an account to join the conversation.

  • Posts: 55
  • Thank you received: 3

Replied by kamisan on topic Flip Flat odd behavior using ESQ

Don't lose any sleep over this issue. I am starting to think that it has something to do with the Raspberry Pi. I am going to switch over to running everything off my Linux laptop. INDI/Ekos worked perfectly on it a couple weeks ago. I'll let you know how it goes.
2 weeks 5 hours ago #36416

Please Log in or Create an account to join the conversation.

Time to create page: 0.729 seconds