×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

Issues with Filter and Focus in EKOS (not only 3.3.9)

3 weeks 6 hours ago
mworion
Senior Boarder
Senior Boarder
Posts: 75
More
Topic Author
Issues with Filter and Focus in EKOS (not only 3.3.9) #47604
Hi,

during the last days I recognized some strange behavior in EKOS (it is not related to 3.3.9 only and not to a platform as I experience this on Mac as well as on Ubuntu):

EKOS Focus Tab:
I use the QSI internal filter wheel. This is set and GUI reloads that from persistence correctly, but when accessing the filter settings itself (see arrow):

Please Log in or Create an account to join the conversation.

3 weeks 6 hours ago
mworion
Senior Boarder
Senior Boarder
Posts: 75
More
Topic Author
Issues with Filter and Focus in EKOS (not only 3.3.9) #47605
... second part as it went off without the pics and explanation:



when pressing the filter settings, the popup opens, but there is not QSI selected, but the CCD Simulator:



If I got to the previous picture and select the already selected QSI FW again, the popup shows the QSI filter wheel correctly. This happens in every lifecycle again.

Secondly, please have a look to the offsets, which are in some case calcluated corrwectly (absolute values), in some not. Changing these values in Column offset does not change the absolute value at all, nor the absolute values could be edited.

If there are any questions about this behaviour, please let me know. It's reproducable for both cases, so easy to monitor.

Michel
Attachments:

Please Log in or Create an account to join the conversation.

3 weeks 6 hours ago
mworion
Senior Boarder
Senior Boarder
Posts: 75
More
Topic Author
Issues with Filter and Focus in EKOS (not only 3.3.9) #47606
..and the missing 2. picture with the wrong choice of filterwheel, when first clicking on the button shown with the arrow:

Attachments:

Please Log in or Create an account to join the conversation.

3 weeks 6 hours ago
mworion
Senior Boarder
Senior Boarder
Posts: 75
More
Topic Author
Issues with Filter and Focus in EKOS (not only 3.3.9) #47608
In addition which might be related to the first issue:

When starting Kstars / EKOS, I have always no persistency in Imaging tab for the filterwheel selection:

When setting QSI for CCD and Filter:



A new start of EKOS leads to have CCD Simulator as filterwheel selected:



Michel
Attachments:

Please Log in or Create an account to join the conversation.

2 weeks 6 days ago
knro
Administrator
Administrator
Posts: 7556
Karma: 51
Issues with Filter and Focus in EKOS (not only 3.3.9) #47642
Thank you for your report. This is now fixed in KStars GIT. Please check from GIT or nightly release.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

Time to create page: 0.600 seconds