×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Re:Display bug ... AND responsivity bug!

2 months 2 weeks ago
TallFurryMan
Platinum Boarder
Platinum Boarder
Posts: 873
Karma: 13
More
Re:Display bug ... AND responsivity bug! #50870
Filed phabricator.kde.org/D28117 to restore stability to Ubuntu 16.04 build. That diff is a no-brainer, of course.

HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
The following user(s) said Thank You escriban

Please Log in or Create an account to join the conversation.

2 months 2 weeks ago 2 months 1 week ago by escriban.
escriban
Senior Boarder
Senior Boarder
Posts: 51
Karma: 1
More
Re:Display bug ... AND responsivity bug! #50871
Great!! I'm waiting eagerly for the nightly build.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
escriban
Senior Boarder
Senior Boarder
Posts: 51
Karma: 1
More
Re:Display bug ... AND responsivity bug! #50915
kstars-bleeding - 6:3.4.2+202003180916~ubuntu16.04.1 didn't made it once again! :(

Please Log in or Create an account to join the conversation.

2 months 1 week ago
TallFurryMan
Platinum Boarder
Platinum Boarder
Posts: 873
Karma: 13
More
Re:Display bug ... AND responsivity bug! #50929
Stupid me missed one place to fix... Sorry for the delay!

-Eric

HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access

Please Log in or Create an account to join the conversation.

2 months 1 week ago
TallFurryMan
Platinum Boarder
Platinum Boarder
Posts: 873
Karma: 13
More
Re:Display bug ... AND responsivity bug! #50962
Pushed phabricator.kde.org/D28177 to fix that second issue.

-Eric

HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
The following user(s) said Thank You escriban

Please Log in or Create an account to join the conversation.

2 months 1 week ago 2 months 1 week ago by escriban.
escriban
Senior Boarder
Senior Boarder
Posts: 51
Karma: 1
More
Re:Display bug ... AND responsivity bug! #50965
Thanks for your effort!

Meanwhile I tried to compile KStars from source with Qt 5.9.9 on Ubuntu 16.04 with success.:cheer: The display bug is gone, BUT the responsivity bug persists! I suppose it is a KStars/indi bug: The option buttons for the serial/ethernet connection are all dead*. Shall I open a ticket in KStars bugtracking systems?
*) Surprisingly they are all working when I'm debugging an INDIdriver with QtCreator.:blink:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
TallFurryMan
Platinum Boarder
Platinum Boarder
Posts: 873
Karma: 13
More
Re:Display bug ... AND responsivity bug! #50995
(all Green on launchpad now for Ubuntu 16.04)

-Eric

HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access

Please Log in or Create an account to join the conversation.

2 months 1 week ago
escriban
Senior Boarder
Senior Boarder
Posts: 51
Karma: 1
More
Re:Display bug ... AND responsivity bug! #51088
Some news regarding this bug!

It is present in Ubuntu 16.04 AND 18.04 and I could trace a really strange behaviour in both: As I stated before the "Connection Mode" buttons of the INDIDrivers is always working under debugging. The spooky thing is, that after the very first start of EKOS (after a new startup of the OS) the buttons are working too! But if you start Ekos once again these buttons get unresponsive! :blink:

It there a crack out there, who has more insight? I haven't got a clue.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
knro
Administrator
Administrator
Posts: 7990
Karma: 51
Re:Display bug ... AND responsivity bug! #51092
If you restart KStars, they are unresponsive as well? or it needs a complete restart of the OS?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 months 1 week ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 87
Karma: 2
More
Re:Display bug ... AND responsivity bug! #51098
I had mentionned about unresponsive buttons in another thread (#49172) and what I had found was that if I deleted the xml files related to the driver (in ~/.indi) the buttons would be responsive again, until the xml files were created again.

Hope that info contributes to the solution.

Please Log in or Create an account to join the conversation.

2 months 1 week ago 2 months 1 week ago by escriban.
escriban
Senior Boarder
Senior Boarder
Posts: 51
Karma: 1
More
Re:Display bug ... AND responsivity bug! #51100
@knro: First, I didn't believe it either! But yes, it's true: Starting the OS (16.04 or 18.04) from zero, does it!
But only for the first invocation of the driver (by EKOS or by Device Manager). All subsequent calls render the Connection Mode buttons unresponsive.

@G_Gagnon: I spotted this thread and I can confirm your note. There has to be a relation! Alas, until now I could not spot the part of the source code, where the problem is located. Besides, I think that it is not a practicable way to erase the XML-File every time you want to change something.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
knro
Administrator
Administrator
Posts: 7990
Karma: 51
Re:Display bug ... AND responsivity bug! #51102
is this only for Connection Mode? If yes, can you post your XML config file?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

Time to create page: 0.439 seconds