INDI Library v2.0.6 is Released (02 Feb 2024)

Bi-monthly release with minor bug fixes and improvements

Meridian Flip issues: LX200 driver can't go past zenith

  • Posts: 49
  • Thank you received: 0
I have been progressively trying to make my rig more autonomous so I can leave it out a whole night unattended, and one of the hurdles I need to overcome is the meridian flip.
My mount is an EQ-5 with Onstep, and I run Astroberry on a RPi4.

It seems like the LX200 driver only allows the mount to go to HA=0, but not past. It just stops tracking once it reaches that point. This means that the criterion in the mount module in Ekos is never reached, so the meridian flip never happens, even when I set a meridian flip at HA=0 or degrees=0. In the indi panel, it's possible to set an offset to stop the mount from tracking BEFORE it reaches HA=0, but this offset does not allow negative values to let the mount go past HA=0.

What I can do, however, is to set 'AutoFlip=on' in the LX200 indi panel, but the issue there is that it doesn't communicate with Ekos at all. That means the mount does not wait until the exposure is done, and it does not check alignment once the flip is performed.

Anyone else with this issue, or someone who has found a way around this issue?
2 months 3 weeks ago #97438

Please Log in or Create an account to join the conversation.

  • Posts: 110
  • Thank you received: 17

Have a look at this document on setting up Kstars Indi for Onstep, docs.google.com/document/d/11NlWvWyI5RxN...91M/edit?usp=sharing

Also in the Onstep config.h file set these limits there

#define AXIS1_LIMIT_MIN -195 // -180, n. Where n= -90..-270 (degrees.) Minimum "Hour Angle" for Eq modes. Adjust
// n. Where n=-180..-360 (degrees.) Minimum Azimuth for AltAzm mode.
#define AXIS1_LIMIT_MAX 195 // 180, n. Where n= 90.. 270 (degrees.) Maximum "Hour Angle" for Eq modes. Adjust
// n. Where n= 180.. 360 (degrees.) Maximum Azimuth for AltAzm mode.

Works for me

2 months 3 weeks ago #97460

Please Log in or Create an account to join the conversation.

Time to create page: 0.434 seconds