×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

INDI Driver for SVBONY cameras

  • Posts: 149
  • Thank you received: 31
Hi Jasem,

Sorry about that.

You have the SV305 Pro (color), not the SV305M Pro (mono), right ?
Which version of the driver do you have ?
On Intel or on Arm ?

I noticed that some settings (ROI, Binning and gain) don't apply to LiveView, unless you trigger a normal capture before.
Could you push the gain at max, and record a couple of frame in a ".ser" file ?

Could you also send me the driver logs ?

Thanks a lot,

Best regards,

Thx8411

 
9 months 3 weeks ago #78208

Please Log in or Create an account to join the conversation.

Sure, this is the color version.
[2021-12-02T10:39:53.048 +03 DEBG ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 : "[DEBUG] Taking a 1 seconds frame... "
[2021-12-02T10:39:54.145 +03 DEBG ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 : "[DEBUG] Wait... "
[2021-12-02T10:39:54.173 +03 DEBG ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 : "[DEBUG] Uploading file. Ext: fits, Size: 4152960, sendImage? Yes, saveImage? No "
[2021-12-02T10:39:54.307 +03 DEBG ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 : "[DEBUG] BLOB transfer took 0.103718 seconds "
[2021-12-02T10:39:54.310 +03 DEBG ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 : "[DEBUG] Upload complete "
[2021-12-02T10:39:54.795 +03 DEBG ][           org.kde.kstars.indi] - Image received. Mode: "Normal" Size: 4152960
[2021-12-02T10:40:22.628 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] Starting video record (Frame count): 3. "
[2021-12-02T10:40:22.628 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] Record file is /home/stellarmate/indi_2021-12-02/indi_record_2021-12-02@07-40-22.ser "
[2021-12-02T10:40:22.637 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] framing "
[2021-12-02T10:40:22.637 +03 DEBG ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 : "[DEBUG] Pixel format 9 is supported by SER recorder. "
[2021-12-02T10:40:22.637 +03 DEBG ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 : "[DEBUG] Pixel format 9 is supported by RAW encoder. "
[2021-12-02T10:40:23.044 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] Camera normal mode "
[2021-12-02T10:40:23.045 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] Subframe set "
[2021-12-02T10:40:23.048 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] Streaming started "
[2021-12-02T10:40:23.447 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] Waiting for all buffered frames to be recorded "
[2021-12-02T10:40:23.449 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] stop framing "
[2021-12-02T10:40:23.854 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] Camera soft trigger mode "
[2021-12-02T10:40:23.855 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] Subframe set "
[2021-12-02T10:40:23.858 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] Streaming stopped "
[2021-12-02T10:40:23.858 +03 INFO ][           org.kde.kstars.indi] - SVBONY SV305PRO 0 :  "[INFO] Record Duration: 810.253 millisec / 3 frames "


Took 3-frame SER file, however SER player complain of 0 width file: www.dropbox.com/s/d66cnlj94inrzg2/indi_r...%4007-40-22.ser?dl=1

I didn't do any ROI, took full frame. The video looked fine when streaming when I adjusted the gain, so that's taken care of.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Last edit: 9 months 3 weeks ago by Jasem Mutlaq.
9 months 3 weeks ago #78243

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hello Jasem,

Thanks.
Right, in your ser file, frame size fields are empty (0).
Weird...

I can't reproduce the issue, with both the 1.2.6 (actually available in your launchpad) and the 1.2.9 (my last version) versions.

Do you know what could produce this issue :

<< ROI, Binning and gain don't apply to LiveView, unless you trigger a normal capture before >>

Am I doing something wrong ?

Best regards,

Thx8411
9 months 3 weeks ago #78266

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
I'm trying to get my SV305M Pro working with an astroberry setup and I'm pulling my hair.
I've tried building and installing the lib and drivers from your repo, running the indiserver seperate and from ekos with no success, the output I get is always2021-12-28T21:53:33: [ERROR] Error, get camera pixel size failed2021-12-28T21:53:27: [INFO] Attempting to find the SVBONY SV305 CCD...

And then nothing more, any pointers on what to try next?

Many thanks!
8 months 3 weeks ago #78895

Please Log in or Create an account to join the conversation.

  • Posts: 120
  • Thank you received: 16
Hi Joakim, have you tried the latest release version of INDI? I have the same camera and with INDI v1.9.3 it is working properly
8 months 3 weeks ago #78903

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
I built the latest from source in effort to get it working, but maybe a fresh install would do it, I'll give that a go after new years. 

The camera works with the raspberry using AstroDMx (and Sharpcap on windows) so the camera seems fine. 
Are you using 32 or 64 bit OS? 
Also I'm using the raspberry pi 4 8GB, what have you tried it on? 
Cheers
8 months 3 weeks ago #78944

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hi Joakim,

Your error is a bug from the previous SDK. It as been  fixed since.

It looks like a library/package conflict issue.
I think you have the old broken version (standard package installation ?) and the one working installed side by side.
But sadly, your setup uses the wrong one.

Try to identify the old packages, and to remove it.

Best regards,

Thx8411
 
The following user(s) said Thank You: Joakim
8 months 3 weeks ago #78945

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hi folks,

"Don't let nerds have some spare time..."

Let me show you my SV305 Pro F (F stands for "Frankenstein"), my cooled SV305 Pro.

 

 

 

It didn't saw the stars yet, still a prototype.

Happy new year !

Thx8411

 
Last edit: 8 months 3 weeks ago by Collin.
8 months 3 weeks ago #78946
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Max delta is 25°C below ambiant temperature.
Stable delta is about 20°C.

"Hot" dark is at 22°C
"Cold" dark is at -1°C

Gain at 360 (half max), 180s.
Amp glow at bottom right.

Best regards,

Thx8411
Last edit: 8 months 3 weeks ago by Collin.
8 months 3 weeks ago #78947
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Pretty sure I tried it before, but now it worked:
sudo apt update
sudo apt upgrade

On the plus side I got the complete dev environment installed in the process 
Many thanks!
8 months 3 weeks ago #79027

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Well, that happiness was unfortunately short-lived :/
Pulled an update today (sudo apt-get update && sudo apt-get -y dist-upgrade) and now the sv305 driver crashes when I try to connect. Pretty sure the sv305 driver didn't change, but it upgraded some indi packages (my Canon DSLR started working)
I've attached the logs, and this line seems worrying 
<code>INDI Server:  "2022-01-05T00:17:03: Driver indi_sv305_ccd: Impossible IPState 1598309187"</code>
Any idea on what to do?
Cheers!

Edit:
I was after these upgrades the sv305 stopped working (I looked in the apt-get history):
Upgrade: indi-bin:armhf (1.9.2-1, 1.9.3), libindi-data:armhf (1.9.2-1, 1.9.3), libindi-dev:armhf (1.9.2-1, 1.9.3), libindi1:armhf (1.9.2-1, 1.9.3), indi-weather-mqtt:armhf (1.1-1, 1.1-2)
Last edit: 8 months 2 weeks ago by Joakim. Reason: More info
8 months 2 weeks ago #79076
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Update from today's effort

I tried with purging all indi and astroberry packages and then reinstalled them (apt-get, purge, autoremove and install) with the same result as previous, the sv305 driver crashed on connection.

What I tried after that was to purge everything again and compile indi (core and drivers) from source (master branches). After that I can connect to the camera, live stream works but it always crashes when I try a capture. Log attached 

File Attachment:

File Name: sv305-2022-01-05.txt
File Size:186 KB
.

So close..., anyone with any ideas on what to try next?
8 months 2 weeks ago #79092
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.506 seconds