Yes, I am at 106.155 West. Thanks for pointing out the calculation. However, something else must be wrong then. Because BEFORE I launch EKOS, KStars is pointing correctly. But after it launches and updates KStars, then the sky map is way off. I have to go back in and update my location manually. I'll double check tonight and see if it's the location or date/time that is off.

Read More...

After upgrading to KStars 3.5 and a new mount (CEM120) I have an issue that has continued to stump me. It never occurred before with 3.4 or my other mount. The issue is that KStars pulls location and time data from my mount, which is good, but it grabs bad data. See the screen shot which shows that while the Latitude is correct for my New Mexico home, the Longitude is completely wrong. I checked the mount and the handset shows the correct data. Also, the data is read correctly for "site location" and "observer location" but not "mount location". I have no idea where longitude "253:50:42" is, but its not near me!

Can anyone shed some ideas here? Is the CEM120 driver at fault?

Peter



Read More...

Has this work been postponed indefinitely? I too would be interested in this driver as I have to purchase either the ESATTO or a Moonlight focuser, and the ESATTO is much less expensive. Thanks for any update.

Read More...

EKOS 3.5 OSX forced auto focus at the start of imaging.

I was starting an image sequence tonight, the first time with 3.5 on the Mac.
I did not want to have the imager start an autofocus process, but it kept trying. I made sure the filter setting was NOT set to autofocus, but it still kept trying to focus at the start of my imaging session.
I only got it to stop when I changed my profile to remove the focuser. Once I restarted INDI it worked, and did not try to focus.

In the past, EKOS would only focus if I had the filter autofocus set, or if I had set the auto focus option in the CCD imaging module.
Now it seems autofocus can't be turned off if EKOS detects that you have an electronic focuser.

Read More...

Thanks for posting these instructions. However, I just tried it and got this error:

CMake Error at CMakeLists.txt:212 (find_package):
By not providing "FindStellarSolver.cmake" in CMAKE_MODULE_PATH this
project has asked CMake to find a package configuration file provided by
"StellarSolver", but CMake did not find one.

Could not find a package configuration file provided by "StellarSolver"
with any of the following names:

StellarSolverConfig.cmake
stellarsolver-config.cmake

Add the installation prefix of "StellarSolver" to CMAKE_PREFIX_PATH or set
"StellarSolver_DIR" to a directory containing one of the above files. If
"StellarSolver" provides a separate development package or SDK, be sure it
has been installed.


-- Configuring incomplete, errors occurred!
See also "/home/astroberry/kde/build/CMakeFiles/CMakeOutput.log".
See also "/home/astroberry/kde/build/CMakeFiles/CMakeError.log".
astroberry@astroberry:~/kde/build $
astroberry@astroberry:~/kde/build $ make
make: *** No targets specified and no makefile found. Stop.

Read More...

Peter Kennett replied to the topic 'Parking after polar alignment' in the forum. 5 days ago

It would actually be very helpful to have an option to have the mount go back to the zero position - especially when you need to redo the alignment to fine tune it.
As it stands now, I always have to go back into the INDI control panels and manually direct the mount to go to the zero (home) position since that option does not exist in KStars or EKOS.
Not a deal-breaker, but just a few more steps then desired since I have to do this every time I use this feature.

Read More...

Peter Kennett replied to the topic 'Kstars 3.5.0 OSx' in the forum. 6 days ago

With the release of 3.5 for OSX yesterday, will there be an update after these issues here are fixed?

Read More...

Tried again tonight. Nothing I did would allow my mount's GPS to update KStars.
I tried "allow mount to update KStars" and I tried the option to update via the GPS.
Neither worked. I could see the correct longitude that my mount put out - but KStars refuel to act to update with it.
Each time I had to go into KStars and manually update the location. And worse - KStars would not keep this proper Longitude after launching EKOS.
So every time I start EKOS I have then go in to KStars and update the location, as EKOS erases the correct location and over rights it with an erroneous one (and not the one it says it is writing)!

The mount is the iOptron CEM120.

Can anyone suggest how to fix this?

Peter

Read More...

KStars 3.5 not updating from my mount. I'm not sure if this is my error, or a new bug in 3.5.
I have the option in EKOS set to update KStars from the Mount. I have been using that setting with my mounts with no problem, but with KStars 3.5 it stopped.



Here's the pertinant part of the log, but the whole log is also attached.
This looks like KStars was updated - but in fact it was not. I had to go in and set my location manually.

[2020-11-20T16:52:36.067 MST INFO ][ org.kde.kstars.indi] - iOptron v3 : "[INFO] Mount UTC: 2020-11-20T23:52:38 "
[2020-11-20T16:52:36.068 MST INFO ][ org.kde.kstars.indi] - iOptron v3 : "[INFO] Mount UTC Offset: -7.00 "
[2020-11-20T16:52:36.068 MST INFO ][ org.kde.kstars.indi] - Setting UTC time from device: "iOptron v3" "Fri Nov 20 23:52:38 2020 GMT"
[2020-11-20T16:52:36.122 MST DEBG ][ org.kde.kstars] - Daylight Saving Time inactive
[2020-11-20T16:52:36.123 MST DEBG ][ org.kde.kstars] - Next Daylight Savings Time change (Local Time): "Sun Mar 14 01:59:59 2021 GMT"
[2020-11-20T16:52:36.123 MST DEBG ][ org.kde.kstars] - Next Daylight Savings Time change (UTC): "Sun Mar 14 01:59:59 2021 GMT"
[2020-11-20T16:52:36.123 MST INFO ][ org.kde.kstars.indi] - iOptron v3 : "[INFO] Mount Daylight Savings: OFF "
[2020-11-20T16:52:36.124 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] CMD <:GLS#> "
[2020-11-20T16:52:36.124 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] RES <-3821580045014100200731> "
[2020-11-20T16:52:36.124 MST INFO ][ org.kde.kstars.indi] - Setting location from device: "iOptron v3" Longitude: "-106° 09' 18\"" Latitude: " 35° 02' 21\""
[2020-11-20T16:52:36.125 MST INFO ][ org.kde.kstars.indi] - iOptron v3 : "[INFO] Mount Location: Lat 35:02:21 - Long 253:50:42 "
[2020-11-20T16:52:36.125 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] Configuration successfully saved for GEOGRAPHIC_COORD. "
[2020-11-20T16:52:36.125 MST INFO ][ org.kde.kstars.indi] - iOptron v3 : "[INFO] Mount is parked. "
[2020-11-20T16:52:36.126 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] InitPark Axis1 0.00 Axis2 35.04 "
[2020-11-20T16:52:36.126 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] Setting Default Park Axis1 to 0.00 "
[2020-11-20T16:52:36.126 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] Setting Default Park Axis2 to 35.04 "
[2020-11-20T16:52:36.126 MST INFO ][ org.kde.kstars.indi] - iOptron v3 : "[INFO] Loading device configuration... "
[2020-11-20T16:52:36.127 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] Toggle Debug Level -- Scope Verbose "
[2020-11-20T16:52:36.127 MST INFO ][ org.kde.kstars.indi] - iOptron v3 : "[INFO] Dome Policy set to: Dome ignored. Mount can park or unpark regardless of dome parking state. "
[2020-11-20T16:52:36.128 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] Active Snoop, driver: NexDome, property: DOME_PARK "
[2020-11-20T16:52:36.128 MST INFO ][ org.kde.kstars.indi] - Setting location from device: "iOptron v3" Longitude: "-106° 09' 18\"" Latitude: " 35° 02' 21\""
[2020-11-20T16:52:36.128 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] CMD <:SLO-38215800#> "
[2020-11-20T16:52:36.128 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] RES <1> "
[2020-11-20T16:52:36.128 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] CMD <:SLA+12614100#> "
[2020-11-20T16:52:36.128 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] RES <1> "
[2020-11-20T16:52:36.129 MST INFO ][ org.kde.kstars.indi] - iOptron v3 : "[INFO] Site location updated to Lat 35:02:21 - Long -106:09:18 "
[2020-11-20T16:52:36.129 MST INFO ][ org.kde.kstars.indi] - Setting location from device: "iOptron v3" Longitude: "-106° 09' 18\"" Latitude: " 35° 02' 21\""
[2020-11-20T16:52:36.129 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] Configuration successfully saved for GEOGRAPHIC_COORD. "
[2020-11-20T16:52:36.130 MST INFO ][ org.kde.kstars.indi] - iOptron v3 : "[INFO] Observer location updated: Longitude (-106.155) Latitude (35.0392) "
[2020-11-20T16:52:36.130 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] CMD <:SR7#> "
[2020-11-20T16:52:36.130 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] RES <1> "
[2020-11-20T16:52:36.131 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] CMD <:SDS0#> "
[2020-11-20T16:52:36.131 MST DEBG ][ org.kde.kstars.indi] - iOptron v3 : "[DEBUG] RES <1> "

Any ideas?

File Attachment:

File Name: log_16-52-09.txt
File Size: 127 KB


Peter

Read More...

Peter Kennett replied to the topic 'Kstars 3.5.0 OSx' in the forum. 2 weeks ago

I just tried to use KStars 3.5 for OSX on my Macbok Air (running Catalina). I found that the app seems to work when not connected to anything, and also logged into my Linux INDI server at the scope VIA WIFI.
But if I try to connect to the INDI server via Ethernet it crashes to the desktop as soon as it starts loading up the drivers.

I wasted two hours last night trying to figure out why. I rebooted everything multiple times. Every-time I try to connect (via Ethernet) it simply kills KStars.

But, if I go back and try again and connect via WIFI - it connects and starts up the INDI drivers on the Linux macj9ine with no issue.

However - even then it was unstable and crashed at random times. I couldn't see a specific cause. I couldn't waste the lively night anymore and skipped using the Mac and just used the Linux machine only.
I may try again later this week and post logs. But it is so frustrating to go from a stable version before to suddenly having troubles with 3.5.

Read More...

I installed the latest version (2.7 Beta x64 Linux) and everything installed smoothly, and a shortcut was created as well.
But when i launch it, I get this:

astro@nanopct4:/opt/FireCapture_v2.7beta$ ./start.sh
./start.sh: line 32: ./jre/bin/FireCapture: cannot execute binary file: Exec format error


Any ideas?

Line 32 reads:

./jre/bin/FireCapture -Xms${heap}m -Xmx${heap}m -XX:+UseCompressedOops -classpath "$cp" de.wonderplanets.firecapture.gui.FireCapture

I am running Armbian 20.08 on a NanoPC T4.

Read More...

Any I’ve ever seen this before?
I just installed the AAG Cloudwatcher to the outside of my observatory, There is no Moon, and no ambient lights. Nice and dark out.

But I get this reading from the unit.



Read More...

Ok, I have a new but related issue. Whenever I power up my observatory, and launch EKOS, everything connects ok, but the dome will not slave until I first UNPARK the mount, then I have to let it track for a second before PARKing it again. Then one I UNPARK the mount, the dome will slave.

If I just UNPARK the mount after power on, it will not slave. I have to do the routine above.

Is this the normal routine?

Read More...