×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

RPI4 GPS dongle

  • Posts: 1942
  • Thank you received: 418

Replied by Wouter van Reeven on topic RPI4 GPS dongle

Adding to that, using GPS on your phone may quickly drain the battery. In principles only a first update from the phone to KStars is needed. The internal clock of the pi is stable enough to not drift too much over one night. Plus your telescope will not travel so once the location and time are known you can stop the app on the phone. GPS Nmae will complain (and therefore so will Ekos) but you may ignore that.


Wouter
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
2 years 10 months ago #48538

Please Log in or Create an account to join the conversation.

  • Posts: 749
  • Thank you received: 69

Replied by maxthebuilder on topic RPI4 GPS dongle

Great - thank you very much!
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS D1 clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
iOptron CEM40G
2 years 10 months ago #48552

Please Log in or Create an account to join the conversation.

  • Posts: 749
  • Thank you received: 69

Replied by maxthebuilder on topic RPI4 GPS dongle

It took me over 8 months to get back to this but I got NetGPS working with Ekos!
Will soon be travelling to a remote/dark location 400mi/650km away - will see how it works in the wild.
Thanks for your help!
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS D1 clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
iOptron CEM40G
2 years 1 month ago #61225

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0

Replied by Ian Nelson on topic RPI4 GPS dongle

Hi where is Site Management to manually set GPS co-ords... Just started with Astroberry, really floundering on getting it going.... when I click on GPS on indi tab it shows Warsaw in Poland and the latitude and longitude are not editable?
2 years 1 month ago #61268

Please Log in or Create an account to join the conversation.

  • Posts: 1117
  • Thank you received: 182

Replied by Jose Corazon on topic RPI4 GPS dongle


You can also set the geographic location where you are going ahead of time in Kstars > Settings > Geographic and save the location. Then all you need to do is set the clock on the Pi4 after firing it up and select that particular location. You should be synchronized then.
That's what I did when I went to a dark site in New Mexico a couple of years back over New Year. Worked like a charm for me then, without a GPS.
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
2 years 1 month ago #61276

Please Log in or Create an account to join the conversation.

  • Posts: 749
  • Thank you received: 69

Replied by maxthebuilder on topic RPI4 GPS dongle

Funny thing - I did exactly that when travelled to Mexico a couple of years back over New Year : )
I just wanted to try GPS in case I might need to use it some day for some reason.
Coordinates/time can be synced via SM app anyway. I keep forgetting about this app's existence.

Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS D1 clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
iOptron CEM40G
2 years 1 month ago #61287

Please Log in or Create an account to join the conversation.

  • Posts: 219
  • Thank you received: 40

Replied by Rafa Barberá on topic RPI4 GPS dongle

The Set button on the GPS NEMA driver's Connection page is not working. As I press it, nothing happens. Are there any solution to this annoying bug? I have suffered it on macOS before, but I thought that it was a macOS related thing, but now it's happening again on the raspi

2 years 1 month ago #61290
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 749
  • Thank you received: 69

Replied by maxthebuilder on topic RPI4 GPS dongle

I had the same yesterday. Not sure what happened but after I restarted the INDI server and KStars/Ekos, the address/port changed to the correct one by itself.
I guess, if NMEA server configured correctly and runs, Ekos connects to it and picks up the right numbers...
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS D1 clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
iOptron CEM40G
Last edit: 2 years 1 month ago by maxthebuilder.
2 years 1 month ago #61291

Please Log in or Create an account to join the conversation.

  • Posts: 219
  • Thank you received: 40

Replied by Rafa Barberá on topic RPI4 GPS dongle

Yep, after restarting KStars multiple times it's working. Now my next doubt with this setup. I'm using a OnStep mount, so I need to set time and location to the mount on each boot, so I've KStars configured as:



But as soon as I add the GPS aux it changes automatically to:



So, now my Raspberry / KStars has the correct time / location, but my OnStep mount is not updated. Any solution? Or should I boot KStars first to fix location/date and then change the configuration to update the mount?
2 years 1 month ago #61292
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0

Replied by Juan on topic RPI4 GPS dongle

Hi, this is amazing tip about GPS with phone, just one question, how to solve the UTC difference, because all works fine, ekos get the coordinates and time, but is one hour less then i have on my location.

Kind regards!
1 year 11 months ago #64285

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0

Replied by Juan on topic RPI4 GPS dongle

And another thing, i can found the "time and location" menu, how i can get it?

kind regards!
1 year 11 months ago #64286

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0

Replied by Juan on topic RPI4 GPS dongle

To fixe the timezone i tryed to reconfigure on the pi timezone, but this don't fixed the data i get from netGPS. :(
Last edit: 1 year 11 months ago by Juan.
1 year 11 months ago #64287

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.351 seconds