Jose Corazon replied to the topic 'For those with focus issues' in the forum. 23 hours 47 minutes ago

I also use FCUSB, did so just last night with the latest stable version and did not have that problem. What is your initial step size, what's the maximal step size, what is the maximal travel and what is the tolerance setting? Which algorithm did you choose? Linear v3, polynomial, iterative?
What focuser are you using? Can you provide logs?

Read More...

Jose Corazon thanked giorgio in topic Platform stability 2 weeks ago

Jose Corazon replied to the topic 'Incorrect coordinates in FITS header' in the forum. 2 weeks ago

Thanks, Chris!

Weird, though, as the simulator is not even loaded.

So would I have to enter iEQ or indi_ieq_telescope then in the options tab of the camera?

Read More...

Jose Corazon replied to the topic 'Running Kstars / ekos / INdI from SSD with rpi4' in the forum. 2 weeks ago

AstroNerd wrote: You say your rpi is connect to WiFi by both 2.4 and 5ghz at the same time, and that is impossible, it can only connect via one connection at a time, how can it possibly connect to both with just one internal WiFi card....??


As I had stated earlier, my Pi4 will not spontaneously connect to the network on the 5 GHz band. I don't know why, but when I plug in a 2.4GHz dongle, it will connect through BOTH at the same time with two separate IP addresses. I need to disconnect the 2.4 GHz dongle then to run on 5 GHz only.

Clearly not the same situation you have. And also my Pi4 is not running in hotspot mode, which may use more resources than running in client mode, I don't know. All I can say is that I have barely perceptible lagginess on VNC, but big delays when the 2.4 GHz network is connected at the same time. Not surprising. That's why I wonder whether you may have a problem with data collision.

What happens when you run $ ifconfig -a in the terminal on your desktop and on the Pi4. That might give you a clue.

Read More...

Jose Corazon replied to the topic 'Incorrect coordinates in FITS header' in the forum. 2 weeks ago

knro wrote: In your CCD driver, check that the "mount" in options is set to your mount driver name.


Thanks, Jasem. So should I enter there 'iEQ' or 'indi_ieq_telescope'? I presume that's under Snoop Devices where it currently shows the Simulator?



I am not certain that that is the root of the problem, however, since I also imaged M42 during the same evening session and there the coordinates are stated correctly:

www.dropbox.com/s/1e2dwbi80rdxzq7/M42_Li...-28-23_183.fits?dl=0

Please note in the FITS header that it also lists the 'Telescope Simulator' there.

There must be something else that has happened between imaging the California Nebula (link to FITS file in my first post) and M42 (next target of the evening) that affects how the coordinates are written to the FITS file.

I wonder whether the coordinates of Polaris have carried over somehow from polar alignment which was done just prior to imaging the California Nebula. What I also noticed was that when I was trying to fine adjust the position of the image frame in the dashboard window using the crosshairs to move the center of the image by a few arc minutes to center the nebula that the mount took off and went pointing to Polaris. In both cases the solver had run successfully and positioned the telescope to point towards the California Nebula and M42, respectively, and the correct coordinates were shown in the solver module in both cases. Yet, the coordinates of Polaris where retained in memory when imaging the first target, but no longer when I imaged the second target.

I hope this description helps reproducing the problem. The wrong coordinates are not a problem when stacking and processing the images, but they make it impossible to use a FITS image to precisely center the frame when imaging the same target over multiple nights, which is how I noticed it. The solver invariably fails then for obvious reasons.

Jo

Read More...

Jose Corazon replied to the topic 'Memory Leak' in the forum. 2 weeks ago

El Corazon wrote:

hy wrote: I was wondering, for the folks with the memory leak--do you have the option "Single Preview Tab" checked? (I think you should have it checked).
You find that under the KStars options, then FITS, then it's a checkbox on that page.
I believe that KStars/fitsviewer would leak tabs if you had it unchecked (perhaps it should limit the number of tabs, I don't know if it does or doesn't).
Hy


I was about to make the same comment. That box needs to be checked to prevent consecutive tabs from opening.
In addition, I always leave my FITS viewer minimized. I also use an SSD with swap enabled, that might also make a difference.
I had the memory overflow a couple of times, but only when I ran KStars from a microSD card. Unsure how to explain that, though.



I should have kept my big mouth shut! I did not have these out of memory problems for a long time - until last night.
I had made no changes to my configuration from the night before, when the system performed flawlessly and collected over 300 frames. Last night it ran out of memory after 113. I woke up to the message on the desktop that there was not enough free memory to report the cause of the crash. KStars had shut down.
I have no clue what is causing this, but I did not change any of the parameters I had highlighted earlier. And as I said, the system performed great the night before, no changes made, no updates, nothing....

Read More...

Jose Corazon replied to the topic 'Memory Leak' in the forum. 2 weeks ago

hy wrote: I was wondering, for the folks with the memory leak--do you have the option "Single Preview Tab" checked? (I think you should have it checked).
You find that under the KStars options, then FITS, then it's a checkbox on that page.
I believe that KStars/fitsviewer would leak tabs if you had it unchecked (perhaps it should limit the number of tabs, I don't know if it does or doesn't).
Hy


I was about to make the same comment. That box needs to be checked to prevent consecutive tabs from opening.
In addition, I always leave my FITS viewer minimized. I also use an SSD with swap enabled, that might also make a difference.
I had the memory overflow a couple of times, but only when I ran KStars from a microSD card. Unsure how to explain that, though.



Read More...

Jose Corazon thanked Hy Murveit in topic Memory Leak 2 weeks ago

Jose Corazon created a new topic ' Incorrect coordinates in FITS header' in the forum. 2 weeks ago

Most, but not all, of the FITS files of various objects I have been imaging over the last few months have incorrect coordinates in their FITS headers. Usually Polaris, but sometimes the coordinates of other objects I have been imaging that night.

Has anyone else had that experience?

Here a link to an image of NGC1499 aka California Nebula:

www.dropbox.com/s/bvon7s4r67dgpwe/Califo...-08-09_014.fits?dl=0

It would be great to solve that issue. I have been trying to use these FITS files on subsequent nights to take more images of the exact same frame, but was stymied by the fact that the solver could never come to a solution until I saw that the coordinates in the FITS header are blatantly wrong.

Thanks

Jo

Read More...

Jose Corazon replied to the topic 'Running Kstars / ekos / INdI from SSD with rpi4' in the forum. 2 weeks ago

AstroNerd wrote:

El Corazon wrote: Possible that he lagginess comes from 4K resolution, but there may be another explanation: When you are connecting through WiFi, is your Pi seeing your network through the 2.4 GHz AND through the 5 GHz connection? If it is connected through both, you will get extreme lagginess, due to data collision.
I have that as well, and sometimes the Pi becomes unresponsive for 20 s or longer. After I disconnect the 2.4 GHz network, it is snappy, with almost no lag.
The same would happen when you connect via Ethernet, that might explain why you have these issues. Naturally, you would not see any of this when you control the Pi via keyboard and mouse.


I have the hotspot set to 5GHz, and connect to that from my PC...but my PC sees both 5ghz and 2.4ghz on my home WiFi network, but if hotspot is set to 5ghz, then that should be ok..??? Or not..??
with network cable it only sees 2.4 as the wifi network plug it connects to only has 2.4ghz, and laggy on them both...
So when you say you “disconnect the 2.4ghz” what do you mean turn it off in the router settings...?


When you look up your connection information, what are you seeing? Is your PC then connected to your Pi only (i.e. does it only have one IP address) or is it connected to your Pi with one IP address and to your home network with another? If you have multiple IP addresses on the same machine, it greatly slows down data transfer.
In my configuration, the Pi is connected to a WiFi extender, which then connects to my main WiFi router. So not on Hotspot mode. The Pi connects through both 5 GHz and 2.4 GHz to the extender. For reasons unknown to me, it will not connect if there is only a 5 GHz network available. So what I need to do is connect to the Pi via Remmina on the 2.4 GHz network, ensure that the 5 GHz network is present and connected, then disconnect the 2.4 GHz network in the Pi network manager. Now the Pi is running on 5 GHz only with a single IP address. My desktop is connected to the home WiFi router via Ethernet (old Cat5 cables that top out at ~ 10 MB/s transfer speed) and through another (!) router .

With that (definitely suboptimal) constellation, I experience almost no lagginess, certainly not more than 300 - 400 ms occasionally, barely perceptible, even though the entire traffic is routed through an extender and slow cables(!). But again, that is at 1920x1080 resolution. 4K resolution results may be different.

However, whenever I try to move data while the Pi4 is connected via both 2.4 and 5 GHz to my WiFi network, everything slows down dramatically. I suspect that you have something similar going on and that data are colliding on your network. I suggest making sure that there is only a single route that connects your Pi with your desktop.

Read More...

Jose Corazon replied to the topic 'Running Kstars / ekos / INdI from SSD with rpi4' in the forum. 2 weeks ago

Possible that he lagginess comes from 4K resolution, but there may be another explanation: When you are connecting through WiFi, is your Pi seeing your network through the 2.4 GHz AND through the 5 GHz connection? If it is connected through both, you will get extreme lagginess, due to data collision.
I have that as well, and sometimes the Pi becomes unresponsive for 20 s or longer. After I disconnect the 2.4 GHz network, it is snappy, with almost no lag.
The same would happen when you connect via Ethernet, that might explain why you have these issues. Naturally, you would not see any of this when you control the Pi via keyboard and mouse.

Read More...