×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

New INDI Atik driver - Feedback requested

10 months 3 weeks ago
mastria
Fresh Boarder
Fresh Boarder
Posts: 15
More
New INDI Atik driver - Feedback requested #31884
psjshep,

Yes, it's not on 3rdparty building script.
I managed this (on raspbian) with following (as root, adapt with 'sudo' if you need):

ps: I cloned git repository in my home directory.
# build libatik

cd ~/indi/3rdparty/
mkdir build_libatik
cd build_libatik
cmake -DCMAKE_INSTALL_PREFIX=/usr . ../libatik
make
make install
# build driver

cd ~/indi/3rdparty/indi-atik/
mkdir build 
cd build 
cmake -DCMAKE_INSTALL_PREFIX=/usr .. 
make 
make install

Please Log in or Create an account to join the conversation.

10 months 3 weeks ago
psjshep
Expert Boarder
Expert Boarder
Posts: 85
Karma: 2
More
New INDI Atik driver - Feedback requested #31885
Yeah.. I managed to build it manually as you have ..... was just wondering why it wasn't on the 3rdparty build script yet...
Thanks...
Phil

Please Log in or Create an account to join the conversation.

10 months 3 weeks ago
knro
Administrator
Administrator
Posts: 7289
Karma: 51
Topic Author
New INDI Atik driver - Feedback requested #31894
I just added them to the 3rd party CMake. At any rate, the new libatik package should resolve the build issue. Launchpad builds for armhf are now VERY slow and it could take a day or more before they're available.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

10 months 3 weeks ago
psjshep
Expert Boarder
Expert Boarder
Posts: 85
Karma: 2
More
New INDI Atik driver - Feedback requested #31895
Thanks, Jasem...
I did make a local mod for my CMakeLists.txt... but good to know you have added it to the repository.
Phil

Please Log in or Create an account to join the conversation.

10 months 3 weeks ago
hen
Fresh Boarder
Fresh Boarder
Posts: 6
More
New INDI Atik driver - Feedback requested #31912
Thank you very, very much Jasem!
I have an Atik One with an internal filter wheel and the GP guider, I got two issues (I am not on the nightly channel):
- I can not change the name of the filters [ERROR] Error updating names of filters.
- GP is not visible (normaly connected via internal Atik one Hub, an SX Ultra can connect via the hub)

Hope this can help
Hen

raspberry pi 3; Temma EM 200; Atik one 9.0; Atik GP; SBIG STF8300c, ST-i, SX Ultrastar

Please Log in or Create an account to join the conversation.

10 months 3 weeks ago
Jurgenk
Senior Boarder
Senior Boarder
Posts: 43
More
New INDI Atik driver - Feedback requested #31919
It's working: tested in KStars Version 2.9.8 Build: 2018-08-18T06:12:27Z

root@user-desktop:~# apt list | grep atik

indi-atik/bionic,now 2.0~201811232105~ubuntu18.04.1 amd64 [installed,automatic]
indi-atik-dbg/bionic 2.0~201811232105~ubuntu18.04.1 amd64
libatik/bionic,now 2.0.0~201811232107~ubuntu18.04.1 amd64 [installed,automatic]

2018-11-25T00:48:57: [INFO] Setting CCD temperature to -10.00 C
2018-11-25T00:48:49: [INFO] Device configuration applied.
2018-11-25T00:48:49: [INFO] Upload settings set to client only.
2018-11-25T00:48:49: [INFO] Loading device configuration...
2018-11-25T00:48:49: [INFO] Detected camera ARTEMIS CCD ATIK-314L with firmware 769

2018-11-25T00:42:58: Driver indi_atik_ccd: snooping on Telescope Simulator.EQUATORIAL_EOD_COORD
2018-11-25T00:42:58: Driver indi_atik_ccd: snooping on Telescope Simulator.TELESCOPE_INFO
2018-11-25T00:42:58: Driver indi_atik_ccd: snooping on Telescope Simulator.GEOGRAPHIC_COORD
2018-11-25T00:42:58: Driver indi_atik_ccd: snooping on Focuser Simulator.ABS_ROTATOR_ANGLE
2018-11-25T00:42:58: Driver indi_atik_ccd: snooping on CCD Simulator.FILTER_SLOT
2018-11-25T00:42:58: Driver indi_atik_ccd: snooping on CCD Simulator.FILTER_NAME
2018-11-25T00:42:58: Driver indi_atik_ccd: snooping on SQM.SKY_QUALITY
2018-11-25T00:42:58: Driver indi_atik_ccd: snooping on EQMod Mount.EQUATORIAL_EOD_COORD
2018-11-25T00:42:58: Driver indi_atik_ccd: snooping on EQMod Mount.TELESCOPE_INFO
2018-11-25T00:42:58: Driver indi_atik_ccd: snooping on EQMod Mount.GEOGRAPHIC_COORD

captured an image of 300 seconds

Please Log in or Create an account to join the conversation.

10 months 3 weeks ago
pch
Gold Boarder
Gold Boarder
Posts: 160
Karma: 2
More
New INDI Atik driver - Feedback requested #31928
Jurgen,
We use the same camera, do you also remark a difference in the image size between v1 and v2 driver?
For me with v1 the maximum frame size was 1392x1040, now with v2 it is 1391x1039. With v2 this is now the same size as given by Artemis capture or the Ascom driver on Windows.
Not a big problem but in this case you must be careful to redo your calibration frame with v2.

Please Log in or Create an account to join the conversation.

10 months 3 weeks ago
Jurgenk
Senior Boarder
Senior Boarder
Posts: 43
More
New INDI Atik driver - Feedback requested #31933
yes, I've noticed it too:
it is 1391x1039 now, but it is not a deviation from the previous versions of Ekos and or Indilib. I have dark images captured by Ekos from 2014 that have the same 1391x1039 frame size. I had problems with the frame size being 1392x1040 when I captured flats using APT.

Please Log in or Create an account to join the conversation.

10 months 3 weeks ago
jpaana
Gold Boarder
Gold Boarder
Posts: 205
Karma: 5
More
New INDI Atik driver - Feedback requested #31941
On 383L+ the frame size changed as well to match what Windows tools give, 3326x2504 to 3362x2537 so had to redo calibration frames. There are a couple of rough edges, temperature reading seems to interfere with image download but adding a mutex there fixed it. Another thing is that subframing is not enabled on my camera as the driver is checking for a capability which presumably means something else, but enabling the capability unconditionally fixed this too.

Remote observatory running Ubuntu 19.04 x64 with ScopeDome 2M, Skywatcher EQ8 and HEQ5, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, USB_Focus V3, Gemini SnapCap, USB_DewPoint, KomaHub
The following user(s) said Thank You knro

Please Log in or Create an account to join the conversation.

10 months 3 weeks ago
knro
Administrator
Administrator
Posts: 7289
Karma: 51
Topic Author
New INDI Atik driver - Feedback requested #31946
A PR is appreciated! :D

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

10 months 3 weeks ago
mastria
Fresh Boarder
Fresh Boarder
Posts: 15
More
New INDI Atik driver - Feedback requested #31950
Mine is 383L+ too.
I've notice the same behavior with sub-framing not allowed while testing auto-focus.
I believe that donwload time get slower too, but maybe it's only a "felling", I don't have numbers to compare.

Please Log in or Create an account to join the conversation.

10 months 3 weeks ago
pch
Gold Boarder
Gold Boarder
Posts: 160
Karma: 2
More
New INDI Atik driver - Feedback requested #31951
Subframe work with the 314L.

I compare the time need to take a bias with a previous session log and it is not slower. From old log 4.6 s, from new log 4.5 s. This is total time from start of exposure until the file is saved by the client.

Please Log in or Create an account to join the conversation.

Time to create page: 1.501 seconds