×

INDI Library v1.9.1 Released (26 Jun 2021)

Bi-monthly INDI Library v1.9.1 is released bringing a few new drivers and improvements to existing drivers.

indi_canon_ccd crash: latest update

  • Posts: 222
  • Thank you received: 17
Unfortunately, it does not work:
$ sudo apt-get -y install libraw20 kstars-bleeding indi-full
 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
kstars-bleeding is already the newest version (6:3.4.3+202007200529~ubuntu18.04.1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
 libraw20 : Conflicts: libraw19 but 0.19.6~202002010817~ubuntu18.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.
 
11 months 2 days ago #58621

Please Log in or Create an account to join the conversation.

Sorry I rebuilt KStars for 20.04 only as a test and verified that, now rebuilding for 18.04 as well.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
11 months 2 days ago #58622

Please Log in or Create an account to join the conversation.

  • Posts: 106
  • Thank you received: 4
Thank you, Jasem!
Everything is back to normal.
I changed the ppa back to the stable branch. Purged kstars and indi, then reinstalled it.
I had to type in the size of the camera sensor and forgot to fill in the pixel pitch.
From then on I had some hickups, because kstars crashed, when ekos tried to connect to the equipment.
There was no clue in the log files, what could cause the problem. So I reinstalled indi-full and filled in the pixel pitch.
I have a working system.
I must admit that I tried to build the programs from source. There might be some remnants because unfortunately there is no sudo make uninstall (or I missed it?).
By the way: on your facebook site there is a really nice picture of the heart and soul nebula.
Powered by

GNU / Linux
Git
KDE neon
KStars | EKOS | INDI

and some cheap hardware
Last edit: 11 months 2 days ago by Heiko.
11 months 2 days ago #58627

Please Log in or Create an account to join the conversation.

  • Posts: 222
  • Thank you received: 17
Cerro,

This is 20.04 or 18.04?

If it is the latter, can you please expand on what you did to get it to work?
11 months 2 days ago #58668

Please Log in or Create an account to join the conversation.

  • Posts: 222
  • Thank you received: 17
Never mind ...

Just got the new packages from the PPAs for 18.04.
They use libraw20 for kstars-bleeding, and remove libraw19, so all is good now.

Will test tonight.
11 months 2 days ago #58669

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
I also have this problem, if someone has a solution, please tell me
11 months 2 days ago #58670

Please Log in or Create an account to join the conversation.

  • Posts: 106
  • Thank you received: 4
Hi kbahey,

my Astro NUC is driven by Ubuntu Mate 20.04 - because of the terrible weather in central Europe I built this device in the last few days. It is controlled over my network via vncserver.
Until now it has not seen the stars.

My workhorse is my Raspberry Pi4 with Stellarmate OS, which is a formidable fallback.
I would be pleased to see Jasem putting together Stellarmate OS for x86-64 PCs.
Powered by

GNU / Linux
Git
KDE neon
KStars | EKOS | INDI

and some cheap hardware
Last edit: 11 months 2 days ago by Heiko.
11 months 2 days ago #58672

Please Log in or Create an account to join the conversation.

  • Posts: 1936
  • Thank you received: 414
Doesn't work for me. I uninstalled kstars etc using
sudo dpkg -P indi-full indi-gphoto indi-pentax kstars-bleeding kstars-bleeding-dbg libraw19 libraw-dev
and then tried to reinstall using
sudo apt-get update && sudo apt-get -y install indi-full indi-gphoto indi-pentax kstars-bleeding kstars-bleeding-dbg libraw20
and I get
The following packages have unmet dependencies:
 indi-gphoto : Depends: libraw19 (>= 0.19.0) but it is not going to be installed
 indi-pentax : Depends: libraw19 (>= 0.16.0) but it is not going to be installed
 kstars-bleeding : Depends: libraw19 (>= 0.16.0) but it is not going to be installed

This is on Ubuntu (server) 20.04 on a Raspberry Pi 4 with 4 Gb of memory.


Wouter
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
11 months 1 day ago #58700

Please Log in or Create an account to join the conversation.

  • Posts: 1936
  • Thank you received: 414
I forgot to add: that is with the nightly builds. If I do
sudo apt-get update && sudo apt-get -y install indi-full indi-gphoto indi-pentax kstars-bleeding kstars-bleeding-dbg libraw19
then all goes well.

Wouter
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
Last edit: 11 months 1 day ago by Wouter van Reeven.
11 months 1 day ago #58702

Please Log in or Create an account to join the conversation.

  • Posts: 54
  • Thank you received: 1
I use Ubuntu 20.04 and it also use too libraw19.
I cannot install kstars-bleeding with libraw20 without breaking my distro.
Last edit: 11 months 1 day ago by Serge CLAUS.
11 months 1 day ago #58706

Please Log in or Create an account to join the conversation.

  • Posts: 1936
  • Thank you received: 414
Funny enough the distro doesn't need libraw19. But kstars-bleeding seems to do so.


Wouter
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
11 months 1 day ago #58714

Please Log in or Create an account to join the conversation.

  • Posts: 730
  • Thank you received: 56

Hi
It builds fine against libraw20.
Cheers,
Steve
kubuntu 20.04
700d, eq6, t7m
11 months 1 day ago #58718

Please Log in or Create an account to join the conversation.

Time to create page: 0.689 seconds