×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Error in Flag manager

  • Posts: 964
  • Thank you received: 128
I just ran a cross an error in the input parsing of the flags manager of KStars:

If you create a new flag, the RA coordinate gets filled in as degrees (e.g., 268 20 52), and I can change numbers there and select 'save changes' to update values. However, if I select an existing flag, it fills in the RA position in hour notation (e.g., 17h 52m 04s). If I press the save button, this entry gets parsed wrongly, obviously trying to interpret that as degrees, and the table ends up with an entry of
01h 11m 29s.
It seems consistent with the tooltip that doesn't list the hour notation as valid entry. But as the table uses this format, it should either be supported, or converted to degrees in the input field when selecting a table entry.

Edit: Forgot to mention, I'm using a recent git version of KStars
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
Last edit: 5 months 1 week ago by Gonzothegreat. Reason: edit: subject
5 months 1 week ago #83759

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 2

Replied by David Wing on topic Error in Flag manager

I get a similar issue with the Flag Manager, attached pics shows an example. Only the RA field seems to generate the wrong value. I noticed this issue after I upgraded astroberry on my RPi4 on 2022-09-02.

Image1 shows the RA value of "21 14 1.8" keyed in, and when the add button is clicked the resulting value is "01h 24m 56s" (image2) which isn't close. I tried other formats such as "21h 14m 1.8s" and "21.23383" but also produced the same incorrect result. Clicking on the recorded entry causes the input fields to be refreshed, and that results in the same erroneous RA value of "01h 24m 56s" being displayed (image3). At this point, it is not possible to create flags.

Thanks, David W
2 months 3 weeks ago #86210
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 749
  • Thank you received: 69

Replied by maxthebuilder on topic Error in Flag manager

I ran into this just a couple of days ago too
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS D1 clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
iOptron CEM40G
2 months 3 weeks ago #86215

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 2

Replied by David Wing on topic Error in Flag manager

I figured out the magic formula to key in RA values to work around this bug with the Flag Manager. Enter the hour, min and sec values each multiplied by 15. For example, "150 300 450" will create an entry of "10d 20m 30s" for RA. No change is needed for DEC. A screen shot is attached.
2 months 3 weeks ago #86239
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.474 seconds