Welcome, Guest
Username: Password: Remember me
14 Nov 2018
Glad to announce of release of INDI Library v1.7.5 on 2018-11-14. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...
  • Page:
  • 1

TOPIC: [SOLVED] Ekos|PHD2 connection time out for AZGTI

[SOLVED] Ekos|PHD2 connection time out for AZGTI 4 months 8 hours ago #28450

  • tkottary
  • tkottary's Avatar Topic Author
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 86
  • Thank you received: 16
[cross posted this to phd2 forums as well ]

Mount ; Skywatcher AZ GTI
GuideCamera : ZWO 120mm-s

I am trying to connect the new skywatcher AZ GTI in EQ mode to Phd2 . When I run the wizard and chose indi mount, I do not get any option to chose the indi mount drive; the drop down is empty/disabled.
Even trying to start Phd2 from ekos, PHD2-mount connection fails. Mount connection window in Phd2 shows that indi is connected . When the indi button is clicked it loads all the indi properties including the mount. Enabled verbose logging also shows me the mount commands, yet phd2 doesn't connect to mount.

I am using indi_synscan_telescope as mount driver and do not have troubles controlling the mount via ekos.

This is from phd2 debug logs.I am not sure if this error with indi or ekos. Any suggestions?

00:00:51.977 00.001 1691349600 device ZWO CCD ASI1600MM Pro interface(s) CCD|GUIDER
00:00:51.977 00.000 1691349600 exclude device ZWO CCD ASI1600MM Pro not a mount
00:00:52.285 00.308 1691349600 INDIConfig: newDevice SynScan
00:00:52.461 00.176 1691349600 device SynScan interface(s) TELESCOPE
00:00:52.461 00.000 1691349600 exclude device SynScan not a mount
00:02:59.779 127.318 1958732352 INDI Mount connecting to device [INDI Mount]
00:03:14.840 15.061 1958732352 INDI Mount bg connection failed canceled=0
00:03:14.841 00.001 1958732352 Alert: Cannot connect to mount INDI Mount: Connection timed-out
00:03:14.927 00.086 1691349600 INDI Mount: serverDisconnected
00:03:14.928 00.001 1958732352 INDI Mount: serverDisconnected
00:03:14.929 00.001 1958732352 Error thrown from /build/phd2-tqHHV0/phd2-2.6.5.rev20180723/scope_indi.cpp:835->INDI Scope: cannot get side of pier when not connected
00:03:14.929 00.000 1958732352 INDI Mount: SideOfPier returns -1
00:03:14.930 00.001 1958732352 INDI Mount: connectServer done ready = 0
00:03:14.930 00.000 1958732352 Throw from /build/phd2-tqHHV0/phd2-2.6.5.rev20180723/gear_dialog.cpp:1307->OnButtonConnectScope: connect failed
00:03:14.930 00.000 1958732352 Status Line: Mount Connect Failed

PS: Use EQMOD driver
Last Edit: by tkottary.
The topic has been locked.

Ekos|PHD2 connection time out for AZGTI 3 months 4 weeks ago #28518

  • tkottary
  • tkottary's Avatar Topic Author
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 86
  • Thank you received: 16
Here is the update from PHD2 forums on this.

PHD2 requires the driver to support the INDI GUIDER interface, and apparently the synscan driver does not provide that functionality. It provides the ordinary mount capabilities like slewing, syncing and parking, but no guide capability. I think you'll need to post in the INDI forum to see if the driver can be updated to provide GUIDER capability.
The topic has been locked.

Ekos|PHD2 connection time out for AZGTI 3 months 3 weeks ago #28523

Why not try EQMod driver? Synscan is quite limited in functionality.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The topic has been locked.

Ekos|PHD2 connection time out for AZGTI 3 months 3 weeks ago #28573

  • tkottary
  • tkottary's Avatar Topic Author
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 86
  • Thank you received: 16
I remember it did not work with eqmod drive when I was testing it the last few weeks, Ill try it again today.
The topic has been locked.

Ekos|PHD2 connection time out for AZGTI 3 months 3 weeks ago #28627

  • tkottary
  • tkottary's Avatar Topic Author
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 86
  • Thank you received: 16
EqMod Driver does not work alas. tested bunch of other drivers only indi_synscan_telescope works.

INFO 50.992540 sec : Session log file /home/tar/.indi/logs/2018-08-15/indi_eqmod_telescope/indi_eqmod_telescope_04:19:56.log
INFO 96.818921 sec : Connecting to 192.168.4.2@11882 ...
DEBUG 96.877833 sec : Connection successful, attempting handshake...
COMM 96.878120 sec : dispatch_command: ":e1", 4 bytes written
COMM 101.878645 sec : read error, will retry again...
COMM 101.879119 sec : dispatch_command: ":e1", 4 bytes written
COMM 106.884430 sec : read error, will retry again...
COMM 106.885288 sec : dispatch_command: ":e1", 4 bytes written
ERROR 111.888717 sec : Error: Communication failed -> tty read failed, check connection: Timeout error
DEBUG 111.888903 sec : Handshake failed.
The topic has been locked.

Ekos|PHD2 connection time out for AZGTI 3 months 3 weeks ago #28630

You need to set it in PC Direct Mode first.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The topic has been locked.

Ekos|PHD2 connection time out for AZGTI 3 months 3 weeks ago #28633

  • tkottary
  • tkottary's Avatar Topic Author
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 86
  • Thank you received: 16
I am not sure how to set that up without a hand controller :) i 'll look that up.
The topic has been locked.

Ekos|PHD2 connection time out for AZGTI 3 months 3 weeks ago #28638

Wait you're not connected via the hand controller? PC Direct Mode is needed for EQMod if you connect via the handset. How are you connecting now?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The topic has been locked.

Ekos|PHD2 connection time out for AZGTI 3 months 3 weeks ago #28639

  • tkottary
  • tkottary's Avatar Topic Author
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 86
  • Thank you received: 16
I am connecting to the mount via the SynScan Pro app on the Android phone . I have not yet figured a way to directly connect to mount wifi

More was discussed here:
indilib.org/forum/mounts/3482-skywatcher-az-gti-with-ekos.html
The topic has been locked.

Ekos|PHD2 connection time out for AZGTI 1 month 1 week ago #30950

I’m trying to use PHD2 to control my HEQ5 mount via RPi -> Stellarmate -> kstars/ekos/indi, I can confirm that using the EQMod driver with the handset in PC Direct mode is working. The Indi Synscan driver will not.
The topic has been locked.

Ekos|PHD2 connection time out for AZGTI 1 month 1 week ago #30951

  • tkottary
  • tkottary's Avatar Topic Author
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 86
  • Thank you received: 16
Thanks for reply. This thread was raised before eqmod fix was done for AZGTI . This is resolved now.
The topic has been locked.
  • Page:
  • 1
Time to create page: 0.158 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica