Welcome, Guest
Username: Password: Remember me
14 Nov 2018
Glad to announce of release of INDI Library v1.7.5 on 2018-11-14. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...
  • Page:
  • 1

TOPIC: wrong park position (eqmod?)

wrong park position (eqmod?) 1 month 1 week ago #31081

  • alacant
  • alacant's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 222
  • Thank you received: 18
Hi everyone
Latest nightly build.
Hitting Park returns the mount to the wrong position.
Workaround.
1.Park to wrong position
2. Unpark then immediately hit Park again
The mount now returns to the correct position.
Any ideas?
Cheers and clear skies.

log: drive.google.com/open?id=1kfNyKkDBgc3Y6PMV6aO-m-8JXymvK2pJ

Please Log in or Create an account to join the conversation.

ubuntu 18.04
700d, eq6, t7m

wrong park position (eqmod?) 1 month 1 week ago #31083

Where is the parking in the log? Can't see where it started. The EQMOD needs some updating, too much information that can probably be cut down a bit.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

wrong park position (eqmod?) 1 month 1 week ago #31085

  • alacant
  • alacant's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 222
  • Thank you received: 18
Hi. How is parking logged? I hit park-unpark-park as described at the very end of the session.
Thanks

Please Log in or Create an account to join the conversation.

ubuntu 18.04
700d, eq6, t7m

Re:wrong park position (eqmod?) 1 month 1 week ago #31086

Could you clarify which park/unpark buttons you are using? The ones on the INDI panel work flawlessly, but I think there might be problems with those in the mount tab. I didn't dig into that much.

-Eric

Please Log in or Create an account to join the conversation.

HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access

Re:wrong park position (eqmod?) 1 month 1 week ago #31088

  • alacant
  • alacant's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 222
  • Thank you received: 18

TallFurryMan wrote: Could you clarify which park/unpark buttons you are using? The ones on the INDI panel work flawlessly, but I think there might be problems with those in the mount tab. I didn't dig into that much.

-Eric


Hi. I used the park and unpark buttons in the ekos mount module. I did not try with indi.
Thanks

Please Log in or Create an account to join the conversation.

ubuntu 18.04
700d, eq6, t7m

Re:wrong park position (eqmod?) 1 month 1 week ago #31093

They're not any different, they're just a 'frontend' to the INDI button. There should have been a message saying "Parking in progress...". I will add more logging now to INDI::Telescope class to see if there any anything modifying the park values.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Re:wrong park position (eqmod?) 1 month 1 week ago #31095

Jasem, I think the issue may be in the mount module. It seems there is a state that doesn't go through sometimes, that makes the button inoperant. I've seen sometimes the wrong button enabled compared to the INDI state.

-Eric

Please Log in or Create an account to join the conversation.

HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access

Re:wrong park position (eqmod?) 1 month 1 week ago #31096

Well, worst case scenario is that it is disabled.. but it won't make the mount go to the wrong parking position. I just added a bunch of logging statements to trace back any changes to the parking positions. Also EQMod is updated to resolve other minor issues, I will test tonight on my EQ8.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Re:wrong park position (eqmod?) 1 month 1 week ago #31117

  • alacant
  • alacant's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 222
  • Thank you received: 18
Hi. Happens during a meridian flip too. The telescope ends up pointing 180° in Dec away ; the wrong end of the telescope is pointing at the target.
Log to follow.
Thanks

EDIT. log: drive.google.com/open?id=1fwBlWIPhiHfWx_sovMVRdbyg_XuPkPd_

Please Log in or Create an account to join the conversation.

ubuntu 18.04
700d, eq6, t7m
Last Edit: by alacant.

Re:wrong park position (eqmod?) 1 month 6 days ago #31212

  • alacant
  • alacant's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 222
  • Thank you received: 18
Latest nightly looking good. Worked with meridian flip and park but only tested one of each.
log: drive.google.com/open?id=1yhrTQpCEIcOOZvO8duz9yLW-VF54W_JD
Thanks and clear skies

Please Log in or Create an account to join the conversation.

ubuntu 18.04
700d, eq6, t7m
  • Page:
  • 1
Time to create page: 0.100 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica