×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight?

8 months 2 weeks ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 430
Karma: 3
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36953
When you take one of the FITS files and open it in Photoshop or Gimp, how many pixels does it show there when you select Canvas size and image size?
I.e. is the header right or not?

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
Kaczorek
Moderator
Moderator
Posts: 688
Karma: 6
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36955
Both FITS header and actual resolution (checked in PixInsight and Gimp) are 2750x2200.

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 430
Karma: 3
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36956
From your previous post I understand that the FITS header shows 2750x2200. But in the PI console upon importing the image PixInsight reads 1 px less in each dimension. That is also the dimension listed on the ATIK website.
If the ACTUAL pixel COUNT (not FITS header) shows 2750x2200 then the information on the ATIK website must either be 1) wrong, or 2) the resolution was rounded up to the next number that was divisible by 2, or 3) the driver that PI reads out states the wrong value in the console (as does the website), or 4) PI entered the value provided to it by ATIK into the database it uses for its calculations and disregards the FITS header AND the actual pixel count.
Looks like that cannot be solved without input from ATIK. You need confirmation of what the actual pixel count of the sensor really is.

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
starhopper
Expert Boarder
Expert Boarder
Posts: 81
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36975

fusis wrote: Hi!
I can view the image just fine but then when I try to calibrate the images I get: *** Error: Incompatible image geometry
Can someone please give me some directions on what to do? Am I missing something?
Marco


I know this Pixinsight error. To calibrate images Pixinsight needs, that all images (LIGHT, BIAS, ....) have the same image geometry (width and height in pixels). Your image may have different sizes.
This can possible origin from this bug, which came back in my INDI installation:
https://indilib.org/forum/general/4889-false-image-geometry-bug-solved-one-year-ago-is-back-again-please-fix.html

Thomas

Thomas Jäger
www.starhopper.eu
Linux Mint19
300/1200mm, 200/1000mm & 200/618mm Newton, Esprit 100/550mm, C 9.25"
SBIG STL11000M C2, Moravian G2-8300, ZWO ASI183MM-C

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
Kaczorek
Moderator
Moderator
Posts: 688
Karma: 6
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36983
This is NOT PixInsight error. It has been discussed on PixInsight forum and the issue is for sure related to actual geometry written to a FITS.
There is full consistency between actual image geometry and FITS header, however there is no consistency at all between actual image geometry and CCD specs on ATIK site.
Does anybody here use ATIK's windows software so we can confirm image geometry using native application? I don't even have a windows machine to try it on.

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 395
Karma: 5
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36988
Hi Marco,
the calibration error is not related to the warning. I guess in your calibration setup geometries of lights, masterdark and flats do not match.
Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
fusis
Senior Boarder
Senior Boarder
Posts: 41
More
Topic Author
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36990
To all, this issue has been resolved some weeks ago.
It was actually a bug in the ASI camera driver which would leave out some rows of pixels when switching between binning levels.

It was not a Pixinsight issue.

Marco
EKOS - Stellarmate Nightly Builds | EQ5Pro | ZWO ASI294MC Pro | ZWO ASI385MC | HiTecAstro DC Focus

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
starhopper
Expert Boarder
Expert Boarder
Posts: 81
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36997
Hello Fusis,
I am on Jasems PPA and got updates regulary. Are you sure that this bug is gone. It is still there in my installation.

Thomas Jäger
www.starhopper.eu
Linux Mint19
300/1200mm, 200/1000mm & 200/618mm Newton, Esprit 100/550mm, C 9.25"
SBIG STL11000M C2, Moravian G2-8300, ZWO ASI183MM-C

Please Log in or Create an account to join the conversation.

8 months 1 week ago
fusis
Senior Boarder
Senior Boarder
Posts: 41
More
Topic Author
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36999
Hi Starhopper,

I have not experienced it on my last session last Sunday. I'm on the nightly builds, although I have not updated in the last 10 days or so. I only update when I come across serious know issues. This prevents me from running into new issues.

I also keep a backup image available so I can always go back if I run into issues.

Cheers,

Marco

Marco
EKOS - Stellarmate Nightly Builds | EQ5Pro | ZWO ASI294MC Pro | ZWO ASI385MC | HiTecAstro DC Focus

Please Log in or Create an account to join the conversation.

8 months 1 week ago
pch
Gold Boarder
Gold Boarder
Posts: 167
Karma: 2
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #37008
Hi Thomas,
I look at Marco issue, but it was very different than your issue:
www.indilib.org/forum/general/4707-asi29...sue-3x3-and-4x4.html

This is probably the fix for this issue that is the cause for your problem.
In the solution Jasem say:
What changed in the driver is that it now strictly obeys that width % 8 must be zero

If I take the number for your camera:
- it start with a size of 5496, corresponding to width max.
- you ask for bin 4x4 : 5496/4 = 1374
- but 1374/8 = 171.75 , to respect the condition "width % 8 must be zero" it set the width to 171*8 = 1368
- Indi size are always unbinned so it is set to 1368*4 = 5472
- when you return to bin 1x1 it keep this size of 5472 making your new images not compatible with the first series.

The following user(s) said Thank You starhopper

Please Log in or Create an account to join the conversation.

8 months 1 week ago
starhopper
Expert Boarder
Expert Boarder
Posts: 81
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #37012
You may be absolutely right. You can close my issue in mantis, I had to wait if Jasem fixes this driver.
By the way, this binning issue does not happen with EKOS as client. EKOS seems to handle it different.
Thomas

Thomas Jäger
www.starhopper.eu
Linux Mint19
300/1200mm, 200/1000mm & 200/618mm Newton, Esprit 100/550mm, C 9.25"
SBIG STL11000M C2, Moravian G2-8300, ZWO ASI183MM-C

Please Log in or Create an account to join the conversation.

8 months 1 week ago
pch
Gold Boarder
Gold Boarder
Posts: 167
Karma: 2
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #37013
Maybe Ekos do a CCD_FRAME_RESET to return to bin 1x1.
I not do that because one may want to change from bin 4x4 to 1x1 without changing the ROI that is set. If this cause the issue I can reconsider that.

Please Log in or Create an account to join the conversation.

Time to create page: 0.862 seconds