×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Indi1.8.2 conflict with oacapture1.6.0

6 months 3 weeks ago 6 months 3 weeks ago by ecloud.
ecloud
Junior Boarder
Junior Boarder
Posts: 38
More
Topic Author
Indi1.8.2 conflict with oacapture1.6.0 #48034
Since 1.8.2 indi-full has changed its structure of 3rd party drivers. All the package have new names.
While oacapture is dependent on old packages like libasicamera and libefwfilter which are replaced by new packages in indi1.8.2.
So this cause the conflict.
The oacapture deb can be installed with 'dpkg -i --ignore-depends=libasicamera,libefwfilter', and does work good.
I have mail to the author of oacapture, james, but no response by now.
This is a reminder for the people who want to install oacapture on you system.
To solve the conflict, you need to uninstall all the oacapture packages before you upgrade indi to the latest build. Install oacapture again with the ignore option
And also, you need to modify a file to change the oacapture dependency.
/var/lib/dpkg/status
Find oacapture section and remove libasicamera and libefwfilter in the line 'Depends'.

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
AgileParker
Fresh Boarder
Fresh Boarder
Posts: 1
More
Indi1.8.2 conflict with oacapture1.6.0 #48037
After indi-full has changed its structure of 3rd party drivers, all the packages have got new names.
While oacapture is dependent on old packages like libasicamera and libefwfilter which are replaced by new packages in indi1.8.2, I have checked with Facebook also but didn't find a solution to this. How and where can I get more help? This needs to be resolved.

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
knro
Administrator
Administrator
Posts: 8205
Karma: 51
Indi1.8.2 conflict with oacapture1.6.0 #48100
IIRC, the changes were made to accommodate projects like oacapture. Maybe Radek can shed more light on this since I believe he was in communication with the authors of the other projects to agree on a common structure.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
Kaczorek
Moderator
Moderator
Posts: 926
Karma: 6
More
Indi1.8.2 conflict with oacapture1.6.0 #48137
Oacapture provides own libraries and AFAIK does not (and did not in the past) use INDI libraries. I have suggested to author to use shared libraries provided by INDI but I don't think it was implemented. So there aocapture does not depend on INDI, and as the result of providing own libraries it conflicts with INDI and it always did eg. QHY libraries. It's not gonna change unless james (the author of oacapture) uses INDI libraries instead providing his own.

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM

Please Log in or Create an account to join the conversation.

5 months 3 weeks ago
limburg11
Senior Boarder
Senior Boarder
Posts: 53
More
Indi1.8.2 conflict with oacapture1.6.0 #49625
In the latest Astroberry release (today, after running apt update apt upgrade (for PHD2)), when I try to start oacapture I get the following error:

astroberry@astroberry:~ $ oacapture
oacapture: error while loading shared libraries: libqhyccd.so.6: cannot open shared object file: No such file or directory

Seems like this is linked to the problems described here? All I did so far with oacapture was starting it for testing purposes, but a week ago (or so) it could be at least started. And I don’t have a QHY camera...

Celestron C9.25 on HEQ-5 with belt mod, Celestron SCT focuser, ASI294MC Pro, ASI290MM mini (off-axis guiding), Astroberry on RPi4b, PixInsight

Please Log in or Create an account to join the conversation.

5 months 3 weeks ago
Kaczorek
Moderator
Moderator
Posts: 926
Karma: 6
More
Indi1.8.2 conflict with oacapture1.6.0 #49685
It is related to last update of libqhy... Please downgrade the library by running:
wget https://www.astroberry.io/repo/pool/main/libq/libqhy/libqhy_6.0.5-2_armhf.deb
sudo dpkg -i libqhy_6.0.5-2_armhf.deb

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
The following user(s) said Thank You limburg11

Please Log in or Create an account to join the conversation.

5 months 3 weeks ago
limburg11
Senior Boarder
Senior Boarder
Posts: 53
More
Indi1.8.2 conflict with oacapture1.6.0 #49687
After downgrade of libqhy, oacapture could be started again, but it didn‘t find my ASI cam... but after a raspi reboot, this worked, too!

Thx! :)

Celestron C9.25 on HEQ-5 with belt mod, Celestron SCT focuser, ASI294MC Pro, ASI290MM mini (off-axis guiding), Astroberry on RPi4b, PixInsight

Please Log in or Create an account to join the conversation.

5 months 2 weeks ago
Kaczorek
Moderator
Moderator
Posts: 926
Karma: 6
More
Indi1.8.2 conflict with oacapture1.6.0 #50109
New version of oacapture will be released soon. In the meantime if you cannot run it due to latest QHY drivers, run this for workaround:
sudo ln -s /usr/lib/arm-linux-gnueabihf/libqhyccd.so /usr/lib/arm-linux-gnueabihf/libqhyccd.so.6

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM

Please Log in or Create an account to join the conversation.

Time to create page: 0.341 seconds