×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Update issue with NanoPi-M4 (Armbian) (very serious)

  • Posts: 380
  • Thank you received: 27
There have been many problems for a long time, but this version can not be updated at all.

There are the following problems.

・ Indi-full → Installation is not possible because there are no installation candidates.

・ Indi-bin → I cannot install due to lack of dependencies.


-Kstars-bleeding → I cannot install due to lack of dependencies.

● Missing due to dependencies
libindi1
libgcc-s1
libcfitsio 8
libgcc-s1

It cannot be installed because the package cannot be found.

sudo apt-get -o Dpkg :: Options :: = "-force-overwrite" -f install

I tried to install it, but it cannot be installed due to lack of the above dependencies.

When installing with SSH, the previous version was put on hold, and when I followed the instructions of autoremove, KStars, indi-full, etc. were deleted, so I could not install
Currently it is completely unusable. .. ..

If you know how to avoid it, please let me know.
Last edit: 2 years 4 months ago by T-Studio.
2 years 4 months ago #54152

Please Log in or Create an account to join the conversation.

  • Posts: 380
  • Thank you received: 27
I checked, but the dependency does not correspond to the system version.

And it seems that the dependencies cannot be installed.

kstars-bleeding→The dependencies cannot be installed, the required version is too new to get in the repository, and the dependencies cannot be installed.

Dependencies that cannot be installed
libcfitsio8
libqt5gui5-gles
libwcs7

What you can't install
libindi1
The indi-bin

A dependency is required for a newer version of the repository and cannot be installed.

libc6
libgsl23
libqt5core5a
libqt5gui5
libqt5widgets5


Please include the following dependencies in the repository.
2 years 4 months ago #54206

Please Log in or Create an account to join the conversation.

  • Posts: 380
  • Thank you received: 27
I understood the cause.

sudo apt-add-repository ppa:mutlaqja/ppa

When re-registering the repository with this command, the repository for the OS of a different version will be registered.

I'm using bionic, I've tried it several times and the groovy repository is registered.
2 years 4 months ago #54208

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375
Armbian has never been supported. None of repositories provide binary packages for this system. And you are trying to use Ubuntu repository (ppa:mutlaqja/ppa), which is not going to work.
If you want to use it, you need to compile everything from sources.
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 4 months ago #54225

Please Log in or Create an account to join the conversation.

  • Posts: 129
  • Thank you received: 33
I have the NanoPC-T4 and also run Armbian, I don't understand how you've solved the issue? Can you explain a bit? I run bionic desktop and have noticed the problem you mentioned in the past with a few images. I'd like to know how to fix it if it happens again. Thanks
-Brian

NanoPC-T4 - Armbian focal
iOptron CEM25P mount
Photoline 80mm triplet refractor
ZWO ASI294MC Pro Imaging camera
ZWO ASI290MM mini Guide camera
ZWO ASI EAF focuser

2 years 4 months ago #54381

Please Log in or Create an account to join the conversation.

  • Posts: 380
  • Thank you received: 27
I used Synaptic to manually fix the version of the repository.
4 months 2 weeks ago #82899

Please Log in or Create an account to join the conversation.

Time to create page: 0.373 seconds