×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

Pegasus UPBv2 constantly gives a warning about Dew aggresiveness

  • Posts: 35
  • Thank you received: 5
I'm trying out Kstars 3.5.2 but my Pegasus UPBv2 keeps logging an error about

I've attached the INDI logs for this. However, I understand from Pegasus that the DA command is in firmware 2.4 that was released this month.

I've event tried to set the 'Auto Dew Aggressiveness'

The thing I don't have any dew heaters (I've not had the issue yet and still building up my equipment), I have tried with the auto dew heaters on and off.

Does it make sense that INDI driver is even trying to query the UPB for the dew aggressiveness when the dew heaters are turned disabled?

File Attachment:

File Name: indi_pegas...3506.log
File Size:179 KB
RPI 4 B (4Gb) running Manjaro ARM
Kstars/Ekos
SkyWatcher Esprit 80ED
SkyWatcher EQ6-Pro
ZWO ASI1600MM Pro
ZWO ASI290MM-Mini
ZWO EFW
PrimaLuceLab Sesto Senso 2
Pegasus UPBv2
3 months 2 weeks ago #68043
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 47
Is you UPBv2 upgraded to the latest firmware?
If not I strongly recommend you do the upgrade.
I am on the latest firmware with the latest Indi driver and it works very well.

We check the Dew Agressiveness settings because even if it is disabled in Indi because it might have been enabled with the native app. The only way to be sure of the actual status is to ask the UPB.
The message is a nuisance but will not effect the working.
WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
iOptron GEM45
294 mc pro
224 planetary cam
174 guide cam
Powerbox Ultimate
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

Last edit: 3 months 2 weeks ago by Rishi Garrod.
3 months 2 weeks ago #68045

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 5
As I have done nothing to the UPBv2 then I would say no I've not updated the firmware. How do I that?
RPI 4 B (4Gb) running Manjaro ARM
Kstars/Ekos
SkyWatcher Esprit 80ED
SkyWatcher EQ6-Pro
ZWO ASI1600MM Pro
ZWO ASI290MM-Mini
ZWO EFW
PrimaLuceLab Sesto Senso 2
Pegasus UPBv2
3 months 2 weeks ago #68046

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 47
You need to use the Pegasus UPB Windows App. If you connect the UPB to a Windows machine running the app it will detect that you have an older version and offer the upgrade.
WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
iOptron GEM45
294 mc pro
224 planetary cam
174 guide cam
Powerbox Ultimate
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

3 months 2 weeks ago #68048

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 5
Well that's a huge problem here, I only have Macs and Linux devices in my house and even my Mac is a M1.
RPI 4 B (4Gb) running Manjaro ARM
Kstars/Ekos
SkyWatcher Esprit 80ED
SkyWatcher EQ6-Pro
ZWO ASI1600MM Pro
ZWO ASI290MM-Mini
ZWO EFW
PrimaLuceLab Sesto Senso 2
Pegasus UPBv2
3 months 2 weeks ago #68049

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 47
I have just asked Pegasus if there is a non Windows way of upgrading.
There is a test version of Parallels available for the M1 but no idea if that would work.
WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
iOptron GEM45
294 mc pro
224 planetary cam
174 guide cam
Powerbox Ultimate
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

3 months 2 weeks ago #68051

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 47
Sounds like Pegasus are already looking into this for you
WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
iOptron GEM45
294 mc pro
224 planetary cam
174 guide cam
Powerbox Ultimate
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

3 months 2 weeks ago #68052

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 5
Yeah I've already contacted them. One of their support staff is going to look at seeing if the app runs in Wine. At worst I will install a Win10 developer VM on my Linux server and try that.
RPI 4 B (4Gb) running Manjaro ARM
Kstars/Ekos
SkyWatcher Esprit 80ED
SkyWatcher EQ6-Pro
ZWO ASI1600MM Pro
ZWO ASI290MM-Mini
ZWO EFW
PrimaLuceLab Sesto Senso 2
Pegasus UPBv2
3 months 2 weeks ago #68053

Please Log in or Create an account to join the conversation.

  • Posts: 956
  • Thank you received: 128
I get here constantly messages too, but related to Focuser, and I am on the latest FW so it makes no difference, and I have contacted pegasus who are pretty much useless at helping....I am thinking of selling it and moving to a different type old power box due to the complete lack of help from Pegasus as I have several issues, and all they say is “we don’t maintain the INdI driver” all the time....
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
Last edit: 3 months 2 weeks ago by AstroNerd.
3 months 2 weeks ago #68054
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 47
They are actually correct that they do not maintain the Indi driver, we do.
These messages do not effect the way the driver works in any way but indicate that there was an error receiving the status data. I could just remove the messages but I would like to get to a state where they no longer occur.

I have been running both the latest firmware and Indi driver for a while now without issues.
I will upgrade to the latest Indilib to make sure there is no difference between the driver I have been using and the currently released driver.

If you could post the log I can check with them if there are still known issues with the serial communication.
WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
iOptron GEM45
294 mc pro
224 planetary cam
174 guide cam
Powerbox Ultimate
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

Last edit: 3 months 2 weeks ago by Rishi Garrod.
3 months 2 weeks ago #68060

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 5
You are correct that these messages are harmless but as a developer myself seeing warning messages make me concerned. Just so I know, does the Ekos client truncate the message output after so many lines or does it keep all the messages in the client? Because if it truncates old messages that is fine but if it keeps all the messages that could chew up a lot of memory given how quickly the errors happens and if doing an observing run will be a lot of these messages.

I think the issue I have found is that is that the INDI driver has been developed against the latest firmware rather than being defensive to check the firmware version of the UPB first.

Anyway, I'm trying at least get a windows VM to then hopefully install the latest firmware from that, but it's a real pain having to download 20GB developer VM just to install this firmware upgrade.
RPI 4 B (4Gb) running Manjaro ARM
Kstars/Ekos
SkyWatcher Esprit 80ED
SkyWatcher EQ6-Pro
ZWO ASI1600MM Pro
ZWO ASI290MM-Mini
ZWO EFW
PrimaLuceLab Sesto Senso 2
Pegasus UPBv2
3 months 2 weeks ago #68065

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 47
The Indi drivers do track the major versions (so we test for V1 or V2 in the code) but Pegasus have made quiet a few changes recently to their firmware (almost daily at one point). Quite a few of these versions were not stable so I really don't want to support them and the advice is run the latest version. With the wisdom of hindsight it would have been better to do a version check on the "DA" command. There is not a way to load old firmware so from a development side it would be very difficult to ensure the code runs with every version and to be honest I would not have the time either.

The driver will not chew up memory. It reads the messages and then throws them away. These messages indicate that we sent a command and the response we received was not the expected one and in many cases is truncated.
WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
iOptron GEM45
294 mc pro
224 planetary cam
174 guide cam
Powerbox Ultimate
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

3 months 2 weeks ago #68069

Please Log in or Create an account to join the conversation.

Time to create page: 1.349 seconds