×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Astrotrac 360 INDI Driver documentation development

  • Posts: 16
  • Thank you received: 4
Creating this TOPIC to support Jasem with the development of the documentation for the Astrotrac 360 driver which is now working well.

Requesting folks involved in the development to pitch in and improve the documentation together.
The following user(s) said Thank You: Peter
1 month 1 week ago #75467

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 2
1 month 1 week ago #75490

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 4
Screenshots for the first 4 screens of the driver
1 month 6 days ago #75536
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 4
Additional screens showing plate solving and guiding
1 month 6 days ago #75537

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 4
Just getting us started on the text of the documentation. Tried to capture a lot of the subtleties learned the hard way over several months. Really happy now!

Installation:
Go to Stellarmate terminal and run:
update_indi_core
update_indi_drivers

Install the latest version of the firmware for the Astrotrac (file attached)

Connections (critical to follow order):

1. Connect the ST4 cable for autoguiding from the guide camera to the Astrotrac RA drive before powering it up.
2. Disconnect the Dec drive connection and then power up then Astrotrac. Wait for a few seconds and then connect the Dec drive.
3. Now power up the Stellarmate. Use an ethernet cable to connect the Stellarmate to the home router. Now you can VNC into the Stellarmate from your remote computer. Connect the Stellarmate Wi-Fi to the WiFi network of RA drive of the Astrotrac 360.
4. If you are in the field, you will need a Wi-Fi dongle to create a second Wi-Fi network (stellarmate) and you can VNC into that.
5. Make sure you have adequate power to all of your devices (mount, camera, focuser, etc.) or you will have issues (serial readout error etc.)

Running Ekos:
1. Open Ekos and in profiles create a new profile for Astrotrac and all your devices - Astrotrac mount, Camera, Guide Camera, Filter wheel, Focuser and Skysafari (will go over this)
2. Choose local to run Ekos on the local Stellarmate Pi; scan to check the IP address of the Indi server. Enter information about your OTA and guide scope and save the profile.
3. When you run the profile, go to the Astrotrac tab. The screenshots show the settings for each of the tabs. Enter the correct coordinates for your site in Site Management. In Alignment, choose Nearest Plugin for the alignment model. Leave all other settings at default.
5. To connect Skysafari to Ekos, within Skysafari go to Telescope Setup and select Meade Lx200 GPS as the mount. Use the IP address of the INDI server and port 9624 and connect. It should connect and be around Polaris.
6. Polar align the mount (can someone who has done this successfully in Ekos write this section?), I polar align using the ASI AIR Pro.
7. Select a known star in Ekos. Right click and under Astrotrac, select GOTO. The mount will slew near to the star
8. Goto the Polar Alignment tab and make sure the camera settings are correct (main camera, focal length, BIN 2, default filter, Stellarsolver). Select Capture and Solve with action Slew to Target. The plate solving routine should converge in a few iterations. This works beautifully now. Jasem finally perfected it.
9. Use the Focus tab to run the Auto-focus routine. You can put in filter offsets which is super convenient. 
10. The new multi-star guiding features are terrific. I use 2-3 seconds. Good to run fresh calibrations for the night. In the proportional gain settings I use 666.67 for both axes. The performance is insanely good as you can see with 0.15-0.2" error on each axis.
11. Proceed to imaging run

 
The following user(s) said Thank You: Jasem Mutlaq
1 month 6 days ago #75538

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 0
Great start Sameer, I hope to test tomorrow, depending on weather. I will then try out the polar alignment procedure.
The guiding does look fantastic. What tracking mode Doyle use for the mount, 1 or 2? 2 seems to work better for guiding. Can you confirm that? Thanks,

Peter
Last edit: 4 weeks 55 minutes ago by Peter.
4 weeks 55 minutes ago #75871

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 4
I just use the default in the driver. I don’t go into the browser to control the Astrotrac and change the tracking mode
3 weeks 6 days ago #75873

Please Log in or Create an account to join the conversation.

Ok driver documentation ready: indilib.org/telescopes/astrotrac-360.html

Please let me know if we need to add anything else here.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 weeks 6 days ago #75887

Please Log in or Create an account to join the conversation.

1. Connect the ST4 cable for autoguiding from the guide camera to the Astrotrac RA drive before powering it up.
2. Disconnect the Dec drive connection and then power up then Astrotrac. Wait for a few seconds and then connect the Dec drive.

Can you confirm that these steps are a must before using the mount?

Also, any known issues that we should add to the documentations? things to watch out for?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Last edit: 3 weeks 6 days ago by Jasem Mutlaq.
3 weeks 6 days ago #75888

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 4
Yes, Jasem. These are both necessary steps. The autoguiding cable must be connected before booting up the Astrotrac or it won’t receive guide signals. Also, for the master-slave to work correctly, dec connection should be made after RA drive is powered up. Or both could compete to be the RA drive.

Other issues: occasional serial read error. Most likely reason is inadequate power to the mount or WiFi signal interference.
3 weeks 6 days ago #75895

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 4
I haven’t figured out if the driver can guide the mount directly without an ST4 cable.
3 weeks 6 days ago #75896

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 0
Hi Jasem, thanks for all the hard work. Yesterday while testing, I had a few occasions where the mount would start to move in RA at an unusual high speed where I had to stop things by unplugging the power. Not sure yet which command caused it.
I can try to see if guiding is possible through the interface rather than through an ST4 cable.
3 weeks 6 days ago #75901

Please Log in or Create an account to join the conversation.

Time to create page: 0.890 seconds