×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

apt error 3.6.2 beta ?

  • Posts: 138
  • Thank you received: 8

Replied by Nick Birkett on topic apt error 3.6.2 beta ?

I believe this was intentional. I just read a post from Jasem to say that 3.6.2 is in final check before release and beta version was uploaded to stable repo. See reply #88192:

"Can you check in KStars 3.6.2 Beta? I pushed this now to the INDI Stable channel since we are in testing period now for 2 weeks before final release." Jasem Mutlaq
The following user(s) said Thank You: Juergen
2 months 1 week ago #88282

Please Log in or Create an account to join the conversation.

  • Posts: 44
  • Thank you received: 6

Replied by Tracy Perry on topic apt error 3.6.2 beta ?


I'm sorry... did you say a BETA version was being forced out on the stable platform?
If so, that is sheer stupidity at a base level.
A developer should NEVER push out ANY beta product in a stable channel. Not even a "RC" (release candidate) should be put on ANY stable channel of software. They should have an existing infrastructure of BETA testers that participate in the testing.
I know that I personally have lost many hours of capturing because an update was pushed out in the "stable" channel and was not apparently tested. And no, I'm not a programmer, but I've helped with BETA testing software as far back as the VERY early 90's, and even back then, you did NOT push out any BETA code into the stable product line (especially if dealing with a paid for product like StellarMate OS).
A beginner trying to find their way.
Astro What? - my home away from home.
Last edit: 2 months 1 week ago by Tracy Perry.
2 months 1 week ago #88287

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0

Replied by Jack Kolesar on topic apt error 3.6.2 beta ?

Does anybody know if there is any way to go back and can anybody else confirm that this "not-so-stable" branch is crashing when it loads Indi drivers? I show that my indi-full version is 1.9.9+ as well which I believe is the big problem here.
2 months 1 week ago #88288

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0

Replied by Jack Kolesar on topic apt error 3.6.2 beta ?

This is what Ekos debugger is showing me on Indi launch.

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Inferior 1 (process 7591) exited with code 02]
2 months 1 week ago #88289

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic apt error 3.6.2 beta ?

Which INDI driver is crashing?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 1 week ago #88290

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0

Replied by Jack Kolesar on topic apt error 3.6.2 beta ?

All of them. Except for simulators.
Last edit: 2 months 1 week ago by Jack Kolesar.
2 months 1 week ago #88291

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0

Replied by Jack Kolesar on topic apt error 3.6.2 beta ?

Thisi is when I load Celetron Aux in Ekosdebugger.

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New inferior 2 (process 7772)]
[Inferior 1 (process 7768) detached]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
process 7772 is executing new program: /usr/bin/indi_celestron_aux
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Thread 2.1 "indi_celestron_" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff545db40 (LWP 7772)]
__GI___pthread_mutex_lock (mutex=0x5359534255536824) at ../nptl/pthread_mutex_lock.c:67
#0 __GI___pthread_mutex_lock (mutex=0x5359534255536824) at ../nptl/pthread_mutex_lock.c:67
#1 0x00007ffff7e38944 in INDI::BaseDevice::getProperty(char const*, INDI_PROPERTY_TYPE) const () from /lib/x86_64-linux-gnu/libindidriver.so.1
#2 0x00007ffff7e38c7d in INDI::BaseDevice::getSwitch(char const*) const () from /lib/x86_64-linux-gnu/libindidriver.so.1
#3 0x000055555556af15 in CelestronAUX::initProperties() ()
#4 0x00007ffff7e42a88 in INDI::DefaultDevice::ISGetProperties(char const*) () from /lib/x86_64-linux-gnu/libindidriver.so.1
#5 0x00007ffff7e969eb in INDI::Telescope::ISGetProperties(char const*) () from /lib/x86_64-linux-gnu/libindidriver.so.1
#6 0x000055555556a185 in CelestronAUX::ISGetProperties(char const*) ()
#7 0x00007ffff7e423f4 in ISGetProperties () from /lib/x86_64-linux-gnu/libindidriver.so.1
#8 0x00007ffff7e189d7 in dispatch () from /lib/x86_64-linux-gnu/libindidriver.so.1
#9 0x00007ffff7e1b047 in ?? () from /lib/x86_64-linux-gnu/libindidriver.so.1
#10 0x00007ffff7e1b722 in ?? () from /lib/x86_64-linux-gnu/libindidriver.so.1
#11 0x00007ffff7e1b82c in eventLoop () from /lib/x86_64-linux-gnu/libindidriver.so.1
#12 0x00007ffff7e1b352 in main () from /lib/x86_64-linux-gnu/libindidriver.so.1
#13 0x00007ffff74ff083 in __libc_start_main (main=0x7ffff7e1b200 <main>, argc=1, argv=0x7fffffffe0f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffffffe0e8) at ../csu/libc-start.c:308
#14 0x000055555555e4ee in _start ()
2 months 1 week ago #88292

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 3
Hi,

for my side, this beta version runs perfectly with my setup. I have run it all the night like a charm. It solved an issue with the altitude limit field disabled in the Mount module.

Only one thing, at the end of my session, In Guiding module,I tried the new feature "intra-frame dark guiding". The first time I enabled it, Kstars freezed and eventually crashed. After restart Kstars and Ekos with the same profile, this guiding mode could be enabled without crash, and seems to be pretty efficient for my guiding. This happens at my session end, and I have spent only 10 minutes of guiding.

On my lenovo, linux mint 21, ubuntu 22.04
SW 150/750P (Newtownien) - SW ED72/420 on HEQ5 pro using EqMod
ASI071 pro - CC Baader MPCC III (for newtownien)
Guiding with 60mm refractor and QHY5 II mono
Kstars/Ekos on LENOVO Thinkcenter M71 - Linux Mint 21 & Stellarrmate Pi4 8GB
Last edit: 2 months 1 week ago by Val Chevalier.
2 months 1 week ago #88293

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0

Replied by Jack Kolesar on topic apt error 3.6.2 beta ?

Looks like you are running on a Pi. Is anybody else on an x86-64 architecture here? Wonder if it's something with the other libraries.
2 months 1 week ago #88294

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 3
not a Raspi, it's a 86-64 architecture, a lenovo Thinkcenter M71 I3 SSD, with linut mint 21
SW 150/750P (Newtownien) - SW ED72/420 on HEQ5 pro using EqMod
ASI071 pro - CC Baader MPCC III (for newtownien)
Guiding with 60mm refractor and QHY5 II mono
Kstars/Ekos on LENOVO Thinkcenter M71 - Linux Mint 21 & Stellarrmate Pi4 8GB
Last edit: 2 months 1 week ago by Val Chevalier.
2 months 1 week ago #88295

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0

Replied by Jack Kolesar on topic apt error 3.6.2 beta ?

Sorry. Saw the Stellarmate in your sig and assumed you were using that. Hopefully Jasem can chime in and let me know if I'm doing something wrong here. Have some clear skies coming up and really want to try out my "new to me" mount.
2 months 1 week ago #88296

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 8

Replied by Nick Birkett on topic apt error 3.6.2 beta ?

I'm using EQmod with QHY cameras and 3.6.2 beta seems to be working ok.
Check your server and client on the same version. If not then:

In client drop down box in kstars->help-> About kstars (3.6.2 beta)

In server : apt list --installed | grep kstars-bleeding
kstars-bleeding/focal,now 6:3.6.2+202211160926~ubuntu20.04.1 amd64 [installed]
2 months 1 week ago #88301

Please Log in or Create an account to join the conversation.

Time to create page: 1.117 seconds