×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble

1 year 7 months ago 1 year 7 months ago by erittaf. Reason: Added version info
erittaf
Fresh Boarder
Fresh Boarder
Posts: 3
More
Topic Author
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #25420
Hello everyone! First time posting here but I've lurked on the forums a good bit while getting things up and running for the most part. Unfortunately I'm stuck on the focuser module :(

I'm having trouble with INDI/EKOS and the auto focus routine using my Meade LX200 GPS mount and the attached Meade 1209 microfocuser. I'm hoping someone here might have an answer to get this working as expected or at least point me in the right direction. As soon as I can get this problem worked out I think I can actually start imaging!

I have two scenarios with using the focuser in INDI/EKOS, one that works and one that doesn't. The problem is the one that works is the "manual" method

I am able to make the microfocuser move if I use the buttons with these steps:
-Start INDI and connect devices
-Go to the INDI Control Panel screen > LX200GPS tab > Focus tab
-Set the speed to any non zero value (1,2,or 3)
-Set the timer to some value like 500 or 1000 ms
-Click one of the direction buttons (in or out)

Unfortunately even in the same INDI session or after restarting INDI completely, it does not move from the EKOS Focuser tab if I click the autofocus button. It correctly operates the attached Canon DSLR and autoselects a star. It has lines in the display at the bottom that say moving focus in or out by ####ms, but the focuser is silent and does not move.

My steps for this test were as follows:
-Start INDI and connect devices
-Go to EKOS > Focuser tab
-Ensure the LX200gps focuser is selected
-Ensure a good star to focus on is present near the middle of the frame and a rough focus has been acheived with the LX200 mirror positioning.
-Click autofocus
-Wait... The first frame is captured, then the star is autoselected and several subframes are taken. between each subframe the info at the bootom of the screen states the focuser should be moving inward by ####ms but there is no movement.

I have attached two log files of the two scenarios above (I've remove the GPS fix info for privacy but otherwise these are both full session logs where I start INDI, connect, run the appropriate test scenario and then stop INDI. I see in both files lines like the following:
[2018-04-18T22:58:54.516 MDT DEBG ][ org.kde.kstars.indi] - LX200 GPS : "<setGPSFocuserSpeed>

However, only when I'm using the controls on the INDI Control panel do I get focuser movement and these lines in the log:
[2018-04-18T22:33:10.053 MDT DEBG ][ org.kde.kstars.indi] - LX200 GPS : "<setFocuserMotion> "
[2018-04-18T22:33:11.735 MDT DEBG ][ org.kde.kstars.indi] - LX200 GPS : "<setFocuserSpeedMode> "
[2018-04-18T22:33:14.674 MDT DEBG ][ org.kde.kstars.indi] - LX200 GPS : "<setFocuserMotion> "
[2018-04-18T22:33:16.412 MDT DEBG ][ org.kde.kstars.indi] - LX200 GPS : "<setFocuserSpeedMode> "

In the log called "FocuserDoesNotMove.txt" the Focuser should be moving around line 1670 and on where you can see the Focus module has gone into subframing mode.

Any idea why I can't control my focuser from the EKOS focuser tab?

Thanks for any insight you can offer! I'm hoping this one doesn't need to go to the devs :/
Jon

[Edit 04/24] P.S. - Just thought to check version numbers and post those here. INDI Library is version 1.7.0, KStars is version 2.9.4, both obtained from PPA / apt install method on (x)ubuntu 16.04, last updated a couple weeks ago.
Attachments:

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
Pepcm
Fresh Boarder
Fresh Boarder
Posts: 19
More
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #41407
I have exactly the same problem. Both with “lx200autostar” and “lx200gps” drivers the autofocus function does not work in kstars.

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
knro
Administrator
Administrator
Posts: 7421
Karma: 51
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #41408
How about when you click "Focus in" and "Focus out" buttons in Ekos focus tab? does that move the focuser?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
Pepcm
Fresh Boarder
Fresh Boarder
Posts: 19
More
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #41411
No, only on the indi lx200autostar driver tab /focuser.

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
AstroNerd
Moderator
Moderator
Posts: 696
Karma: 1
More
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #41413

Pepcm wrote: No, only on the indi lx200autostar driver tab /focuser.


Hold on this will not work as the Meade 1209 is a DC motor focuser and not a stepper, so unless I am missing something it won’t work at all...as you can’t get absolute position with a 12v DC motor... :)

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
Pepcm
Fresh Boarder
Fresh Boarder
Posts: 19
More
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #41414
That’s true... :S
May be using another plugin (for dc with no position control?).

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
knro
Administrator
Administrator
Posts: 7421
Karma: 51
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #41418
Alright, so the problem was LX200 driver was not using INDI::FocuserInterface, it was using its very old internal system. I just migrated it to use INDI::FocuserInterface and it should work with the autofocus controls now. Better late than never. Please test it and let me know if it works.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
AstroNerd
Moderator
Moderator
Posts: 696
Karma: 1
More
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #41421

knro wrote: Alright, so the problem was LX200 driver was not using INDI::FocuserInterface, it was using its very old internal system. I just migrated it to use INDI::FocuserInterface and it should work with the autofocus controls now. Better late than never. Please test it and let me know if it works.


How can this work when it’s not a stepper motor focuser, but a DC motor with no step control...??

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
erittaf
Fresh Boarder
Fresh Boarder
Posts: 3
More
Topic Author
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #41424
Thanks a bundle. It'll be some time before I can test as we'll be moving to a new house soon. Which version do i need to fetch once I'm ready?

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
erittaf
Fresh Boarder
Fresh Boarder
Posts: 3
More
Topic Author
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #41425
It runs for a set number of milliseconds. It's no where best as precise, but the auto focus routine can still calculate the FWHM (iirc) curve and get closer than unaided focusing.

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
knro
Administrator
Administrator
Posts: 7421
Karma: 51
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #41428

AstroNerd wrote:

knro wrote: Alright, so the problem was LX200 driver was not using INDI::FocuserInterface, it was using its very old internal system. I just migrated it to use INDI::FocuserInterface and it should work with the autofocus controls now. Better late than never. Please test it and let me know if it works.


How can this work when it’s not a stepper motor focuser, but a DC motor with no step control...??


Simple DC focus motors are supported in Ekos. There are really not recommended at all and I think everyone should invest in a stepper motor based focuser, but they still exist so we gotta support them.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
Pepcm
Fresh Boarder
Fresh Boarder
Posts: 19
More
Re:Re:Re:Re:LX200 GPS with Meade 1209 microfocuser trouble #41430
Thanks a lot!
I’m going to test it asap!

PD: i understand that i must update indi simply
P

Please Log in or Create an account to join the conversation.

Time to create page: 0.829 seconds