×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Installing INDI/KSTARS-EKOS on a NanoPC-T4

  • Posts: 559
  • Thank you received: 77
I just received my NanoPC-T4 today. While I tweak some bugs out of my Stellarmate, and use that system for my current astrophotography projects, I wanted to play with a new toy. I will attempt to get everything running on the NanoPC-T4 micro computer as it offers 4 gig RAM, better speed, RTC, and USB3. I have no idea how or if this will work, but it's a challenge and so I will step into it. I would very much appreciate all the help I can get along the way.

If anyone has any suggestions as to where I should start, I'm all ears.


iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
3 years 3 months ago #27774
Attachments:

Please Log in or Create an account to join the conversation.

For $130 that's pricey. At any rate, they say you can install Lubuntu 16.04 on it.. so after you do that, just add the PPA and install as usual.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 years 3 months ago #27795

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 10
I am keen to hear how you get along as this might solve my ASI USB2 problems. Crossing fingers for you.
Skywatcher Newton 200/1000, Sharpstar 60ED, Canon Lenses
Skywatcherr EQ-6 R, AZ-GTI
StellarMate @ Raspberry Pi 3B+
ASI 183 MC Pro
ASI 290 MC guiding cam on APM 60 ImageMaster
Sesto Senso 2 Focuser + Astromechanics Canon Focuser

3 years 3 months ago #27800

Please Log in or Create an account to join the conversation.

  • Posts: 559
  • Thank you received: 77
Well, I installed Lumbuntu and then both INDI and Kstars without a hitch. Kstars ran so much faster - seemly as fast as it does on my new MacBook Air. The internal 16GB eMMC means thew OS , INDI and KStars cab reside internally vs using the SD Card. The little machine also has a M.2 PCLe interface for an SSD drive, but those are too pricy for me. I think the USB3 will be fast enough.

But here's the problem...

It has some kind of bug so that the Time and Date, plus Users and Groups system tools do not work.
I get the an error window that reads

The configuration could not be loaded
And unknown error has occurred

I have downloaded and reinstalled Lubuntu three times from their link. I hope they solve this one bug for me.

PK

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
Last edit: 3 years 2 months ago by Peter Kennett.
3 years 2 months ago #27935

Please Log in or Create an account to join the conversation.

  • Posts: 223
  • Thank you received: 26
Worth a post if not already a known problem.
Search Results
Web results
Lubuntu - Ubuntu Forums
ubuntuforums.org/tags.php?tag=lubuntu

Tom
Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro
3 years 2 months ago #27939

Please Log in or Create an account to join the conversation.

  • Posts: 1116
  • Thank you received: 182
Can you install Ubuntu Mate on it? That's what I did on my Zotac332 miniPC (also 4GB RAM, makes all the difference, I agree!). Indi and KStars run without a hitch on that system.
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
3 years 2 months ago #27945

Please Log in or Create an account to join the conversation.

  • Posts: 559
  • Thank you received: 77
I’ll try. I’m not a Linux user per say, so I do not know how to get the Mate OS ISO on an SD card installed onto the NanoPC. I was hoping the Mate disk image would boot on the Nano but wouldn’t.

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
3 years 2 months ago #27953

Please Log in or Create an account to join the conversation.

  • Posts: 1116
  • Thank you received: 182
Have you specified the correct boot order in the BIOS/EFI?
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
3 years 2 months ago #27984

Please Log in or Create an account to join the conversation.

  • Posts: 559
  • Thank you received: 77
I'm really a neophyte when it comes to this stuff.
I should send it to someone and have them try and get it working, with VNC installed too.
If anyone wants the challenge, message me. I can offer you a unique wood carving from Uganda. :)

Peter

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
3 years 2 months ago #28000

Please Log in or Create an account to join the conversation.

  • Posts: 1009
  • Thank you received: 298
Not that I really want that wood carving (some of them are cursed), but could you elaborate on the users/groups system tools issue?

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
3 years 2 months ago #28001

Please Log in or Create an account to join the conversation.

  • Posts: 559
  • Thank you received: 77
No curses.. just a decoration of African wildlife.
Those evil looking carvings from South Sudan and Congo creep me out too.

When I installed Lubuntu as per their bootable SD card which flashes an image to eMMC, it seems to install correctly.
But when I visit two system tool options (Time and Date, and Users and Groups) it pops up with an error that simply reads:

The configuration could not be loaded
And unknown error has occurred

And gives me no more details on how to fix it.

I thought it would just be user error on my part, but the company (FriendlyArm) emailed me to say they are aware and for me to "wait for an update", giving me no timeline.

So I was hoping that I could install Ubuntu Mate or some other OS that works well with INDI and KStars. Perhaps their FriendlyCore (based on ubuntu-core) would work? I will try that this week.

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
3 years 2 months ago #28002

Please Log in or Create an account to join the conversation.

  • Posts: 1009
  • Thank you received: 298
Certainly a permission error in the sudoers file. What's in "/etc/sudoers"?
Temporary solution, for the date and time, you can probably get away with this in the terminal:That will set the time, then record it in the hardware clock. Use UTC time, then for the time zone:
-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
Last edit: 3 years 2 months ago by Eric.
3 years 2 months ago #28006

Please Log in or Create an account to join the conversation.

Time to create page: 0.356 seconds