×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Ioptron mount connection support needed

6 months 2 weeks ago
Highkamp
Fresh Boarder
Fresh Boarder
Posts: 10
More
Topic Author
Ioptron mount connection support needed #37355
I have not been able to move my mount using Ekos commands even though Ekos shows it (CEM120) as being connected. I have it connected via HC using converter to USB plugged into Stellarmate. My mount has wifi and LAN too but not sure if those are options to connect via SM either. If anyone has connected their SM to iOptron mount I would like to know how.

Thanks

Please Log in or Create an account to join the conversation.

6 months 2 weeks ago 6 months 2 weeks ago by sbradley07.
sbradley07
Junior Boarder
Junior Boarder
Posts: 31
Karma: -1
More
Ioptron mount connection support needed #37358
I am connecting to my CEM60 without issues. I don't connect thru the HC. I use the rs232-usb converter cable from my Stellarmate to the rs232 port on the mount. Did you unpark the mount in Ekos?

Please Log in or Create an account to join the conversation.

6 months 1 week ago
Highkamp
Fresh Boarder
Fresh Boarder
Posts: 10
More
Topic Author
Ioptron mount connection support needed #37363
Thanks. I tried connecting from the r232 on mount to usb converter to SM and it wont recognize unless i connect via HC so i must still be doing something wrong. Yes it was unparked, etc. Not sure why ethernet from mount to SM wont connect either. I have heard some connect mount to SM via the mounts Wifi but that does not sound right either.

Please Log in or Create an account to join the conversation.

6 months 1 week ago 6 months 1 week ago by werper.
werper
Senior Boarder
Senior Boarder
Posts: 69
Karma: 1
More
Ioptron mount connection support needed #37425
I connect to my iEQ45 Pro through the RS232 serial port, not through the hand controller. Of all the problems I've had to work through with SM, that's one I never ran into, SM has always connected to my mount right away, been very stable, and controls the mount perfectly from Kstars planetarium or from Ekos. It could also be the serial to USB interface cable - some/many are not compatible with mounts or astronomy software. Mine has a Prolific brand chip set.

Celestron C8-N
iOptron iEQ45 Pro
Sterrmate OS (beta) RPi 4, 4GB
Canon T3i DSLR - Primary Cam
Starlight Xpress Lodestar X2 Guide Cam
Astromania 60 Guide Scope
Polemaster Polar Alignment Cam
Robofocus Auto Focuser
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

2 weeks 6 days ago
wyshyvanuk
Junior Boarder
Junior Boarder
Posts: 21
More
Ioptron mount connection support needed #43977
Good morning. Any resolution to the iOptron connection issue? I may have a similar issue.
Thanks!!
Ted

Please Log in or Create an account to join the conversation.

2 weeks 5 days ago
Kaczorek
Moderator
Moderator
Posts: 647
Karma: 6
More
Ioptron mount connection support needed #44040
What driver do you use for iOptron?

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM

Please Log in or Create an account to join the conversation.

2 weeks 5 days ago
wyshyvanuk
Junior Boarder
Junior Boarder
Posts: 21
More
Ioptron mount connection support needed #44045
Hi. I'm hoping that the appropriate driver was downloaded with the KStars MacOS release from the INDI website. From the INDI Control Panel: indi_ieq_telescope Ver 1.8 Interface 5.
I'm happy to provide any other information that would help.
Regards,
Ted

Please Log in or Create an account to join the conversation.

2 weeks 4 days ago
PopcornAWH
Fresh Boarder
Fresh Boarder
Posts: 16
More
Ioptron mount connection support needed #44065
I have no trouble at all connecting my CEM40 to a PC when I follow these instructions: www.ioptron.com/v/ASCOM/iOptron_ASCOM_CEM40.pdf

I use the USB port on the mount, to make it work you need to install the FTDI driver on the PC: www.ftdichip.com/Drivers/VCP.htm

These instructions should also work for a CEM120 (if the USB port is used). I noticed the 'Install FTDI driver' part is not in the CEM120 instructions, so that may be the culprit.
The following user(s) said Thank You pug916, wyshyvanuk

Please Log in or Create an account to join the conversation.

2 weeks 4 days ago
dokeeffe
Platinum Boarder
Platinum Boarder
Posts: 378
More
Ioptron mount connection support needed #44074
I connect to my CEM120 via usb directly into the mount (not handset). Works perfectly.
Maybe enable debug logging and have a look at the output, or paste the log here.
Derek

Celestron CPC1100 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
github.com/dokeeffe
twitter.com/BallyhouraStars
The following user(s) said Thank You wyshyvanuk

Please Log in or Create an account to join the conversation.

2 weeks 4 days ago
DerPit
Gold Boarder
Gold Boarder
Posts: 249
Karma: 1
More
Ioptron mount connection support needed #44075
The CEM120 needs a different driver (talking Protocol 3.0) than the smaller ones (Protocol 2.5).
So you'd need the indi_ioptronv3_telescope driver. While command sets are quite similar and you likely can connect, especially the get position one is different, which will make operation fail.

openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+ASI290 mini
The following user(s) said Thank You pug916, wyshyvanuk

Please Log in or Create an account to join the conversation.

2 weeks 4 days ago
wyshyvanuk
Junior Boarder
Junior Boarder
Posts: 21
More
Ioptron mount connection support needed #44078
Alas, unlike the original poster, I have an iOptron IEQ45 GTN, the model just prior to the Pro. It has the RS232 port rather than the USB. I'm using an RS232/USB convertor with what I believe is a Prolific chip. Sorry for causing confusion!!

Please Log in or Create an account to join the conversation.

2 weeks 4 days ago
DerPit
Gold Boarder
Gold Boarder
Posts: 249
Karma: 1
More
Ioptron mount connection support needed #44080
Not sure which INDI version you have, if it is a newer one, you might try the old driver, indi_ieqlegacy_telescope.

openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+ASI290 mini

Please Log in or Create an account to join the conversation.

Time to create page: 1.397 seconds