I did. and I did run update_indi_core and update_indi_drivers, since the driver for the am5, indi_lx200am5, wasn't present in the download.
So I got the driver I needed, but now the camera drivers crash. I opened a bug by posting here with Stellarmate in the headline.

BTW, the download seems really out-of-date, apt-list --upgradable listed 91 packages needing updates

Read More...

I downloaded StellarmateOS 64-bit, and installed it on a 128GB card in a Rπ, 8GB memory.
I did this because no driver was present for ZWO AM5 mount, but there were instructions on another thread for updating indi core and indi drivers to include this fix.
So I did update_indi_core and update_indi_drivers.
When I tried it out on my rig, I got core dumps as soon as I loaded an Ekos profile with the cameras connected.
The cameras are a Toupcam 2600 clone, and an ASI120MM-S. Both drivers crashed, depending on load order, which brought down the entire kstars process.
I tried to read the core files with gdb, but gdb complained that there was no stack!
I have a core file, if anyone wants to take a look.

Read More...

indi_lx200am5 missing from astroberry distro. The driver assigned by Ekos gets an error, 'Could not get date format from mount', which leads to incorrect date formats, which leads to Ekos being unable to slew the mount.

I have updated via apt update & upgrade. Rπ 4 w/8GB ram

Read More...

Wes Mitchell replied to the topic 'ZWO AM5 Harmonic Drive Mount' in the forum. 3 days ago

I ran into this trying to use my astroberry to control my AM5 mount. The error messages were, from first to last,

"Couldn't get date format string from device"
then
Error setting UTC offset
followed by the errors in slewing; something to the effect that "Couldn't slew to <<RA, DEC>> JNow (I don't recall the exact words), so I assume the error in getting the date cascaded into an error computing the slew target coordinates.
My astroberry is up to date with respect to the astroberry repositories (but not, of course, with kstars-bleeding)

Read More...

Using the configuration in my last reply, I am able to independently control both ASI cameras now, no problems connecting. I've taken various test shots, played with gain, etc. I haven't had any clear nights to try guiding yet, but I'm hopeful that since the 120MM-S can be told to capture photos, then that should be enough.

Hardware: ASI183MC main camera, ASI120MM guide camera.
USB3 port on main wired to USB3 port on Pegasus powerbox
USB3 port on guide wired to USB2 port (!) on main, per ZWO recommendation

For the ekos profile, I have only
CCD: ZWO CCD
no entry for guide camera.

Indi seems to want to pick up the guide camera from the main, also somewhere in ZWO or ekos documentation? Not sure.
This profile causes the main camera to use the indi_asi_ccd process, and I think the guide uses it also. I think I was getting some kind of conflicts, maybe at usb bus level, when I had a profile with zwo camera 1 and zwo camera 2, as each one was associated with the indi_asi_single_ccd process..... But all this is speculation, based upon trying a lot of different combinations.

HTH
Wes

Read More...

Hi,

A quick note: I set up a profile just using Zwo CCD for the main camera, and leaving the guide camera blank. The guide connects to the main via USB, both are Zwo.
So far, it's working very well, either locally from the RPi, or remotely from kstars on my Mac.

Read More...

New installation of Ubuntu

Linux minibuntu 5.4.0-125-generic #141-Ubuntu SMP Wed Aug 10 13:42:03 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
on a Qotom miniPC with 8G memory.

Fresh installation of indi-full and kstars-bleeding packages.

Crashes on startup, looking for a file in a parsing routine. How do I get the needed file to move on from this?
Thanks
Wes

0 __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50
#1 0x00007ffff4961859 in __GI_abort () at abort.c:79
#2 0x00007ffff4d3b911 in ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#3 0x00007ffff4d4738c in ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#4 0x00007ffff4d473f7 in std::terminate() ()
from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#5 0x00007ffff4d476a9 in __cxa_throw ()
from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#6 0x0000555555651789 in KSUtils::JPLParser::JPLParser (this=0x7fffffffd7c0,
path=...) at ./kstars/auxiliary/ksutils.cpp:1743
#7 0x0000555555dbb88d in AsteroidsComponent::loadDataFromText (
this=0x5555583a6050) at ./kstars/skycomponents/asteroidscomponent.cpp:95
#8 0x00005555559c74e6 in BinaryListComponent<KSAsteroid, AsteroidsComponent>::loadData (this=0x5555583a6098, dropBinaryFile=<optimized out>)
at ./kstars/skycomponents/binarylistcomponent.h:239
#9 0x0000555555dbc243 in BinaryListComponent<KSAsteroid, AsteroidsComponent>::loadData (this=0x5555583a6098)
at ./kstars/skycomponents/binarylistcomponent.h:156
#10 AsteroidsComponent::AsteroidsComponent (this=0x5555583a6050,
parent=0x5555583b35b0, __in_chrg=<optimized out>,

Read More...

Hi Wolfgang,

That was what was designated by default when I set up the kstars profile on the astroberry. Should I change it to use the other driver?

Wes

Read More...

Interesting .... if I start with astroberry, no kstars, start indi_server through the web manager, I get:
astroberry@astroberry:~ $ ps -ef | grep indi
astrobe+ 1079 1 0 10:21 ? 00:00:01 /usr/bin/python3 /var/www/indiwebmanager/main.py -v -l /var/log/astroberry/indiwebmanager.log
astrobe+ 4744 1 0 10:41 ? 00:00:00 indiserver -p 7624 -m 100 -v -f /tmp/indiFIFO
astrobe+ 4746 4744 0 10:41 ? 00:00:00 indi_skysafari
astrobe+ 4748 4744 0 10:41 ? 00:00:00 indi_pegasus_upb
astrobe+ 4750 4744 0 10:41 ? 00:00:00 indi_asi_single_ccd
astrobe+ 4752 4744 0 10:41 ? 00:00:00 indi_asi_single_ccd
astrobe+ 4754 4744 0 10:41 ? 00:00:00 indi_ioptronv3_telescope
astrobe+ 7442 2121 0 10:54 pts/1 00:00:00 grep --color=auto indi
astroberry@astroberry:~ $ indi_getprop | grep ASI120
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI120MM-S=Off
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI120MM-S=Off

Note two asi_single_ccd processes running, but the ASI120MM-S isn't showing up. The properties for the ASI183 showed up TWICE:
ZWO ASI183MC Pro.CONNECTION.CONNECT=Off
ZWO ASI183MC Pro.CONNECTION.DISCONNECT=On
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_NAME=ZWO Camera
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_EXEC=indi_asi_single_ccd
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_VERSION=2.0
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_INTERFACE=2
ZWO ASI183MC Pro.POLLING_PERIOD.PERIOD_MS=1000
ZWO ASI183MC Pro.DEBUG.ENABLE=Off
ZWO ASI183MC Pro.DEBUG.DISABLE=On
ZWO ASI183MC Pro.SIMULATION.ENABLE=Off
ZWO ASI183MC Pro.SIMULATION.DISABLE=On
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_LOAD=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_SAVE=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_DEFAULT=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_PURGE=Off
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI183MC Pro=On
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI120MM-S=Off
ZWO ASI183MC Pro.CONNECTION.CONNECT=Off
ZWO ASI183MC Pro.CONNECTION.DISCONNECT=On
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_NAME=ZWO Camera
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_EXEC=indi_asi_single_ccd
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_VERSION=2.0
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_INTERFACE=2
ZWO ASI183MC Pro.POLLING_PERIOD.PERIOD_MS=1000
ZWO ASI183MC Pro.DEBUG.ENABLE=Off
ZWO ASI183MC Pro.DEBUG.DISABLE=On
ZWO ASI183MC Pro.SIMULATION.ENABLE=Off
ZWO ASI183MC Pro.SIMULATION.DISABLE=On
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_LOAD=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_SAVE=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_DEFAULT=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_PURGE=Off
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI183MC Pro=On
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI120MM-S=Off

Does this mean that both indi_asi_single_ccd processes are both talking to the ASI183?

After I start kstars on the astroberry, and start Ekos with the local equipment profile, the duplicate profile elements disappear, and the profile elements for the ASI120 are, I assume, correct:

ZWO ASI183MC Pro.CONNECTION.CONNECT=Off
ZWO ASI183MC Pro.CONNECTION.DISCONNECT=On
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_NAME=ZWO Camera
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_EXEC=indi_asi_single_ccd
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_VERSION=2.0
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_INTERFACE=2
ZWO ASI183MC Pro.POLLING_PERIOD.PERIOD_MS=1000
ZWO ASI183MC Pro.DEBUG.ENABLE=Off
ZWO ASI183MC Pro.DEBUG.DISABLE=On
ZWO ASI183MC Pro.SIMULATION.ENABLE=Off
ZWO ASI183MC Pro.SIMULATION.DISABLE=On
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_LOAD=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_SAVE=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_DEFAULT=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_PURGE=Off
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI183MC Pro=On
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI120MM-S=Off
ZWO ASI120MM-S.CONNECTION.CONNECT=Off
ZWO ASI120MM-S.CONNECTION.DISCONNECT=On
ZWO ASI120MM-S.DRIVER_INFO.DRIVER_NAME=ZWO Camera
ZWO ASI120MM-S.DRIVER_INFO.DRIVER_EXEC=indi_asi_single_ccd
ZWO ASI120MM-S.DRIVER_INFO.DRIVER_VERSION=2.0
ZWO ASI120MM-S.DRIVER_INFO.DRIVER_INTERFACE=6
ZWO ASI120MM-S.POLLING_PERIOD.PERIOD_MS=1000
ZWO ASI120MM-S.DEBUG.ENABLE=Off
ZWO ASI120MM-S.DEBUG.DISABLE=On
ZWO ASI120MM-S.SIMULATION.ENABLE=Off
ZWO ASI120MM-S.SIMULATION.DISABLE=On
ZWO ASI120MM-S.CONFIG_PROCESS.CONFIG_LOAD=Off
ZWO ASI120MM-S.CONFIG_PROCESS.CONFIG_SAVE=Off
ZWO ASI120MM-S.CONFIG_PROCESS.CONFIG_DEFAULT=Off
ZWO ASI120MM-S.CONFIG_PROCESS.CONFIG_PURGE=Off
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_FILTER=CCD Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_FILTER=CCD Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI120MM-S.CAMERAS_LIST.ZWO ASI183MC Pro=Off
ZWO ASI120MM-S.CAMERAS_LIST.ZWO ASI120MM-S=On

I still see several duplicated properties though. Seems like this is a potential problem. How do I clean this up? How do I get the asi_single_ccd processes talking to the correct devices?

Thanks
Wes

Read More...

When I set up my RPi to run both ekos and indi, it works pretty well ... most of the time (I'll get to that).
When I try to run Ekos on my laptop and connect to indi on the (asRPi, it always fails to recognize at least one device.
Often, it will be one of the two cameras, either the main ccd or the guide camera.
Sometimes, Ekos will report that it simply couldn't find one of the devices. Other times, there is an error message to the effect that a USB port was either not found, or in use by another device.

So I suspect this has more to do with USB and less with indi. I'm running a Pegasus Powerbox to supply power to the mount and all the devices, including the Pi. I currently have the cameras and the mount USB connections going to the powerbox.

After shutting down the remote Ekos session, if I try to restart the local Ekos on the RPi, it gets very confused and cannot find two or more devices. I have been resorting to shutting down the Pi, and powering down the entire system, to somehow "clear" the error state.

How can I debug this? Does INDI keep some cache of the usb ports it used the last time a session started? Or is this more an issue at the OS level? I've also noticed that the devices are very finicky about establishing usb connections depending on when you physically connect them. What's the best sequence? Connect everything while power is off, then power up the hub, and then the Pi?

Thanks

Read More...

How do I change the password used in the browser client to connect to the astroberry desktop? Do I change the VNC password on the astroberry server?
Thanks

Read More...