×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

indi-ieq45-8407 always drives to 00:00:00

Thanks for the log file, it was useful. I believe I fixed the issues, I'll ask Peter to make another OSX package so you can test.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: David Elmore
7 years 3 months ago #3754

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174
David, you can try it with INDI_Server_2.0.8.dmg . Peter
The following user(s) said Thank You: David Elmore
7 years 3 months ago #3760

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0

File Attachment:

File Name: indi_ieq_t....log.txt
File Size:400 KB


File Attachment:

File Name: ieq_notes_...4847.txt
File Size:4 KB


Thank you both. Installed new Indi Server from Cloud Makers with indi_ieq_telescope version 1.0. Ran tests -- Still coordinate and other problems. See notes.
Sorry about all the GLT and GAS entries in the log.
7 years 3 months ago #3763
Attachments:

Please Log in or Create an account to join the conversation.

Can you tell me what was the controller RA and DEC when you run the test?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
7 years 3 months ago #3764

Please Log in or Create an account to join the conversation.

No need, I was sending the wrong command (Thanks to Peter for catching this!). Please re-test again. This time, have all options turned on (Driver Debug + Scope verbose) for the first minute only, then turn off Scope verbose, and then proceed with your regular testing (parking, home, guiding...etc). Thanks for the detailed testing, it is very useful.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
7 years 3 months ago #3766

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174
7 years 3 months ago #3767

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
CMD(:Sd+22200623#)the number is 0.01 arc-seconds, not dd:mm:ss,DEC=22200623/360000
Last edit: 7 years 3 months ago by Taozhenwei.
7 years 3 months ago #3768

Please Log in or Create an account to join the conversation.

Yes, thanks bboxxson, I already figured this out today but the reply from the GLT command threw me off because dividing by 360000 yielded declination over 90, but Peter caught that and I was suppose to send GEC instead. I will make the necessary modifications to take this into account.

EDIT: I'm sure not if RA is sent as hours * 360000 or should it be in degrees? RA * 15 * 360000?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Last edit: 7 years 3 months ago by Jasem Mutlaq.
7 years 3 months ago #3774

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174
One more build but same version... INDI_Server_2.0.9.dmg . Peter
7 years 3 months ago #3776

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0

File Attachment:

File Name: indi_ieq_n...4209.txt
File Size:3 KB


CloudMakers INDI_server_2.0.9-2 and INDI Control Panel. Turned off scope verbose after about a minute. This should help.
See notes and log. The RA is off by 10x and 0.1X. Position reported is 10X too great. Selected position sends mount to RA/10.
There is a condition when dec will slew continuously after attempting to select a position. It appears the only recovery to keep future attempts to Eq. Coordinate, Home, or Park without dec run away is to cycle the power to the mount.
7 years 3 months ago #3781
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0

File Attachment:

File Name: indi_ieq_t....log.txt
File Size:14 KB

Had to add .txt to the name of the log file for it to upload.
7 years 3 months ago #3783
Attachments:

Please Log in or Create an account to join the conversation.

Ok, So RA is in milliseconds and DEC is in centi-arcseconds. I think that should hopefully fix the RA/DEC values. Now for the other issues:

1. !! Main>Home>Go to Home --- drove both RA to NZ (home position). Dec driving continuously.

What happens if you do the same from the controller?

2. !! Main>Tracking Mode> --- unpredictable what box will wind up checked when one is selected.

I can see that the controller is being asked to change to whatever you pressed. :RT0 is for sidereal rate, so not sure why it's not updated the box, but it's just an update issue.

3. !! Options>Configuration>Default or >Load --- did not change Port back to startup port name.

Tested it here and it should. Just select "Load", and not "Default", so that it loads last saved settings.

4. !! the indicated time on the Handbox! But UTC offset was set to 000. Including UTC offse

UTC Offset is in hours

5. !! Tried 40:00:00, -105:00:00 Error must be between 0 and 360.

In INDI, longitude is 0 - 360 increasing eastwards. Most of the time you shouldn't worry about this as your client send your location data. Peter, does it account for the 0-360 INDI Standard?

6. !! Main>Site Mangement>Park Options --- Setting defauls said canot change park position while

Hopefully it should now only complain if there is active motion.

Thanks for the extensive testings! I think we're almost there!!
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Last edit: 7 years 3 months ago by Jasem Mutlaq.
7 years 3 months ago #3784

Please Log in or Create an account to join the conversation.

Time to create page: 0.487 seconds